aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-05 21:05:57 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-08-15 15:43:56 +0000
commit37d8cee876efce6468c1821361328b6f3a7e0dc6 (patch)
tree0095cb1a1b703d7b280a4bf13c85e4ab9f3a4dac /main
parent2bcd48020270f17638c75732efa7f35feb26a6de (diff)
main/dbus: run dbus-daemon with supervise-daemon
Diffstat (limited to 'main')
-rw-r--r--main/dbus/APKBUILD4
-rw-r--r--main/dbus/dbus.initd12
2 files changed, 10 insertions, 6 deletions
diff --git a/main/dbus/APKBUILD b/main/dbus/APKBUILD
index a5d37f1fe65..57a1f7d82d5 100644
--- a/main/dbus/APKBUILD
+++ b/main/dbus/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dbus
pkgver=1.12.16
-pkgrel=0
+pkgrel=1
pkgdesc="Freedesktop.org message bus system"
options="!check" # Introduces circular dependency with xorg-server (xvfb-run -> xvfb)
url="https://www.freedesktop.org/Software/dbus"
@@ -74,4 +74,4 @@ x11() {
}
sha512sums="27ae805170e9515a8bb0fba5f29d414edc70e3b6b28b7b65bbea47035b8eafa9ac4820cdc92645be6035f6748f8aa45679e1ffc84ba74a64859a3056d318b9bb dbus-1.12.16.tar.gz
-f3d924e0f0fdced39f0470fac362834acf9f346acdfadbcdf44f627a1b550a69d1d04b3760ff06dc86a7335824f48d3c1faa09a17071e08731705a5fb016a155 dbus.initd"
+4c6beba2382416e60a3adfa85ef843d90d93ca5f38c23f573e058ffca6d4fc3850d11d40938c74383bba61599569b7fdfb1fcf3b9d2f1463e6b2e2cc81097c84 dbus.initd"
diff --git a/main/dbus/dbus.initd b/main/dbus/dbus.initd
index af4fd0c6c72..2fbd3e54643 100644
--- a/main/dbus/dbus.initd
+++ b/main/dbus/dbus.initd
@@ -2,12 +2,16 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-extra_started_commands="reload"
+supervisor=supervise-daemon
+
+name="System Message Bus"
+description="D-Bus System Message Bus"
-description="D-BUS system messagebus"
-pidfile="/var/run/dbus.pid"
command="/usr/bin/dbus-daemon"
command_args="--system"
+command_args_foreground="--nofork"
+
+extra_started_commands="reload"
depend() {
need localmount
@@ -26,7 +30,7 @@ stop_post() {
}
reload() {
- ebegin "Reloading D-BUS messagebus config"
+ ebegin "Reloading $name configuration"
/usr/bin/dbus-send --print-reply --system --type=method_call \
--dest=org.freedesktop.DBus \
/ org.freedesktop.DBus.ReloadConfig > /dev/null