aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authormarmota <53559634+marmota@users.noreply.github.com>2019-08-06 09:03:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-08-23 11:33:31 +0000
commit4a1c2560e9f82b0ea22d42fbba65e9994a3bd2cc (patch)
tree6900b8d46dec85f3966458c8f46c36eb97152cb8 /main
parent12c1369b8aefcd6d5a13305895e8848e43d6b9da (diff)
main/bluez: package btmgmt tool
fixes #10036
Diffstat (limited to 'main')
-rw-r--r--main/bluez/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/main/bluez/APKBUILD b/main/bluez/APKBUILD
index f5c9c3b4bc7..7b32a2c507c 100644
--- a/main/bluez/APKBUILD
+++ b/main/bluez/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
pkgver=5.50
-pkgrel=3
+pkgrel=4
pkgdesc="Tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch="all"
@@ -11,7 +11,7 @@ replaces="udev"
makedepends="dbus-dev libusb-compat-dev eudev-dev json-c-dev
libical-dev readline-dev glib-dev linux-headers
autoconf automake libtool ell-dev"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-bccmd $pkgname-btmon $pkgname-cups
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-bccmd $pkgname-btmgmt $pkgname-btmon $pkgname-cups
$pkgname-deprecated $pkgname-hid2hci $pkgname-meshctl $pkgname-obexd"
source="https://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.xz
bluetooth.initd
@@ -66,6 +66,11 @@ bccmd() {
mv "$pkgdir"/usr/bin/bccmd "$subpkgdir"/usr/bin/
}
+btmgmt() {
+ pkgdesc="Bluez tool for the Bluetooth Management API"
+ install -Dm755 "$builddir"/tools/btmgmt "$subpkgdir"/usr/bin/btmgmt
+}
+
btmon() {
pkgdesc="Bluez bluetooth monitor"
mkdir -p "$subpkgdir"/usr/bin