aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-11 12:29:44 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2017-11-13 09:08:08 +0000
commit682f09400477367c80199d2f00677dbcf435fa1a (patch)
treeb49a0950148df51e723011e53f7b863e49792e84 /main
parent01ad9eb7bbc5e8c93ca9f1443092d68b0c12b0ab (diff)
main/perl-text-password-pronounceable: add missing make dependency and modernize
Diffstat (limited to 'main')
-rw-r--r--main/perl-text-password-pronounceable/APKBUILD31
1 files changed, 13 insertions, 18 deletions
diff --git a/main/perl-text-password-pronounceable/APKBUILD b/main/perl-text-password-pronounceable/APKBUILD
index c6f01c8b13e..7cbb331e6ed 100644
--- a/main/perl-text-password-pronounceable/APKBUILD
+++ b/main/perl-text-password-pronounceable/APKBUILD
@@ -2,37 +2,32 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-text-password-pronounceable
pkgver=0.30
-pkgrel=0
+pkgrel=1
pkgdesc="Text::Password::Pronounceable perl module"
url="http://search.cpan.org/dist/Text-Password-Pronounceable/"
arch="noarch"
license="GPLv2 or Artistic"
depends="perl"
-makedepends="perl-dev"
-install=""
+makedepends="perl-dev perl-module-install"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/T/TS/TSIBLEY/Text-Password-Pronounceable-$pkgver.tar.gz"
-_builddir="$srcdir"/Text-Password-Pronounceable-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/Text-Password-Pronounceable-$pkgver"
build() {
- cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make && make test || return 1
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}