aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-08-15 19:22:39 +0200
committerJakub Jirutka <jakub@jirutka.cz>2019-08-15 19:23:43 +0200
commit900ea77e7a09bb9f78e5e10f128bd264be5b50a7 (patch)
tree9f39fb94934a72d365adda2b6e2727855555b41f /main
parent7385b622c218014df2bb6196ed29870cacc447aa (diff)
main/libressl: upgrade to 2.9.2
Diffstat (limited to 'main')
-rw-r--r--main/libressl/APKBUILD10
-rw-r--r--main/libressl/fix-getprogname.patch50
2 files changed, 56 insertions, 4 deletions
diff --git a/main/libressl/APKBUILD b/main/libressl/APKBUILD
index 2c550639acb..6563efb0b09 100644
--- a/main/libressl/APKBUILD
+++ b/main/libressl/APKBUILD
@@ -10,9 +10,9 @@
# - CVE-2017-8301
#
pkgname=libressl
-pkgver=2.7.5
+pkgver=2.9.2
_namever=${pkgname}${pkgver%.*}
-pkgrel=1
+pkgrel=0
pkgdesc="Version of the TLS/crypto stack forked from OpenSSL"
url="http://www.libressl.org/"
arch="all"
@@ -28,6 +28,7 @@ source="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/$pkgname-$pkgver.tar.gz
starttls-ldap.patch
ssl-libcompat.patch
s_client-add-options-verify_.patch
+ fix-getprogname.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -95,7 +96,8 @@ _libs() {
fi
}
-sha512sums="00828dd115f6395186ce4c9cadb604612763f67f2ad2236a331062add8115f6494a655cbec237ae069e373ffb915ed4025c993e06456c3da69b279e5f7e2b8d4 libressl-2.7.5.tar.gz
+sha512sums="b43e73e47c1f14da3c702ab42f29f1d67645a4fa425441337bd6c125b481ef78a40fd13e6b34dadb2af337e1c0c190cfb616186d4db9c9a743a37e594b9b8033 libressl-2.9.2.tar.gz
9f1628fbc2a697b6570353920d784b161ca0a122047066d8bee15225bad1e5271aa2ed72b145506bcd4ffe58b35da2caf38c4a048db7e014dabd16b5eba44581 starttls-ldap.patch
ef8150843f5aae577a859198439673591764fb3ab1da03436607328962f084356fd7f793484c3ad5f2294bd9e8dad15644c311b0da811acbc83eed4b71c0145a ssl-libcompat.patch
-4c992872addbe4fd612ba9e3f859b5ba69b448aafa7676751ca7ca09bbcfc47a2a1cad468c235f8d1a65c65e8efb38f27c512a32b444346c39ec0d8dcfbcd346 s_client-add-options-verify_.patch"
+4c992872addbe4fd612ba9e3f859b5ba69b448aafa7676751ca7ca09bbcfc47a2a1cad468c235f8d1a65c65e8efb38f27c512a32b444346c39ec0d8dcfbcd346 s_client-add-options-verify_.patch
+73741073629cf85c155d7fc1c66ac41c5a29022a01a36bd3f26953edc60b07bd73f9d728ab8223d3833a14be2dcca88707373dcc2a97532aeb536a22bef9da77 fix-getprogname.patch"
diff --git a/main/libressl/fix-getprogname.patch b/main/libressl/fix-getprogname.patch
new file mode 100644
index 00000000000..7e80e1eeb9c
--- /dev/null
+++ b/main/libressl/fix-getprogname.patch
@@ -0,0 +1,50 @@
+From a747aacc23607c993cc481378782b2c7dd5bc53b Mon Sep 17 00:00:00 2001
+From: Ishimoto Shinobu <47295761+protonesso@users.noreply.github.com>
+Date: Tue, 21 May 2019 22:41:05 +0900
+Subject: [PATCH 1/2] avoid glibc
+
+cause problems on musl systems
+
+Patch-Source: https://github.com/libressl-portable/portable/issues/528
+---
+ crypto/compat/getprogname_linux.c | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/crypto/compat/getprogname_linux.c b/crypto/compat/getprogname_linux.c
+index 2c8974326..4e7e31f41 100644
+--- a/crypto/compat/getprogname_linux.c
++++ b/crypto/compat/getprogname_linux.c
+@@ -26,9 +26,7 @@ getprogname(void)
+ #if defined(__ANDROID_API__) && __ANDROID_API__ < 21
+ extern const char *__progname;
+ return __progname;
+-#elif defined(__GLIBC__)
+- return program_invocation_short_name;
+ #else
+-#error "Cannot emulate getprogname"
++ return program_invocation_short_name;
+ #endif
+ }
+
+From 65159f37d0b5cc4c191edf6fbfd14ce57ecc58b7 Mon Sep 17 00:00:00 2001
+From: Ishimoto Shinobu <47295761+protonesso@users.noreply.github.com>
+Date: Wed, 22 May 2019 10:47:47 +0300
+Subject: [PATCH 2/2] Remove info about glibc
+
+---
+ crypto/compat/getprogname_linux.c | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/crypto/compat/getprogname_linux.c b/crypto/compat/getprogname_linux.c
+index 4e7e31f41..6550eb863 100644
+--- a/crypto/compat/getprogname_linux.c
++++ b/crypto/compat/getprogname_linux.c
+@@ -12,8 +12,6 @@ getprogname(void)
+ * Since Android is using portions of OpenBSD libc, it should have
+ * a symbol called __progname [1].
+ *
+- * Regarding program_invocation_short_name, it is a GNU libc ext [2] and
+- * so make it conditional to __GLIBC__ [3].
+ *
+ * .. [0] https://github.com/aosp-mirror/platform_bionic/blob/1eb6d3/libc/include/stdlib.h#L160
+ *