aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-12-03 13:22:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-12-03 13:22:38 +0000
commitd5172d82d07003826489fbc70747aeaf19f45480 (patch)
tree8d206695cdede47defbff29d20ab37f699d82052 /main
parent179325d5d671a061959f905fc47a5c9a26b32ca9 (diff)
main/qemu: upgrade to 3.0.0
Diffstat (limited to 'main')
-rw-r--r--main/qemu/0001-ui-add-x_keymap.o-to-modules.patch65
-rw-r--r--main/qemu/0006-linux-user-signal.c-define-__SIGRTMIN-MAX-for-non-GN.patch8
-rw-r--r--main/qemu/APKBUILD10
3 files changed, 8 insertions, 75 deletions
diff --git a/main/qemu/0001-ui-add-x_keymap.o-to-modules.patch b/main/qemu/0001-ui-add-x_keymap.o-to-modules.patch
deleted file mode 100644
index de69365316d..00000000000
--- a/main/qemu/0001-ui-add-x_keymap.o-to-modules.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-From 68898bc82bcb0e697ed03c2405321033ba7feaf7 Mon Sep 17 00:00:00 2001
-From: Paolo Bonzini <pbonzini@redhat.com>
-Date: Thu, 17 May 2018 14:39:42 +0200
-Subject: [PATCH] ui: add x_keymap.o to modules
-
-x_keymap.o is common to the SDL and GTK+ modules, and it causes the
-QEMU binary to link to the X11 libraries. Add it separately to the
-modules to keep the main QEMU binary smaller.
-
-Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
-Message-id: 1526560782-18732-1-git-send-email-pbonzini@redhat.com
-
-[ kraxel: fix lm32 target build (milkymist-tmu2) ]
-
-Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
----
- hw/display/Makefile.objs | 2 ++
- ui/Makefile.objs | 11 +++++++----
- 2 files changed, 9 insertions(+), 4 deletions(-)
-
-diff --git a/hw/display/Makefile.objs b/hw/display/Makefile.objs
-index 3c7c75b94d..11321e466b 100644
---- a/hw/display/Makefile.objs
-+++ b/hw/display/Makefile.objs
-@@ -20,6 +20,8 @@ common-obj-$(CONFIG_MILKYMIST) += milkymist-vgafb.o
- common-obj-$(CONFIG_ZAURUS) += tc6393xb.o
-
- common-obj-$(CONFIG_MILKYMIST_TMU2) += milkymist-tmu2.o
-+milkymist-tmu2.o-cflags := $(X11_CFLAGS)
-+milkymist-tmu2.o-libs := $(X11_LIBS)
-
- obj-$(CONFIG_OMAP) += omap_dss.o
- obj-$(CONFIG_OMAP) += omap_lcdc.o
-diff --git a/ui/Makefile.objs b/ui/Makefile.objs
-index cc784346cb..00f6976c30 100644
---- a/ui/Makefile.objs
-+++ b/ui/Makefile.objs
-@@ -15,10 +15,6 @@ common-obj-$(CONFIG_COCOA) += cocoa.o
- common-obj-$(CONFIG_VNC) += $(vnc-obj-y)
- common-obj-$(call lnot,$(CONFIG_VNC)) += vnc-stubs.o
-
--common-obj-$(CONFIG_X11) += x_keymap.o
--x_keymap.o-cflags := $(X11_CFLAGS)
--x_keymap.o-libs := $(X11_LIBS)
--
- # ui-sdl module
- common-obj-$(CONFIG_SDL) += sdl.mo
- ifeq ($(CONFIG_SDLABI),1.2)
-@@ -46,6 +42,13 @@ gtk.mo-objs += gtk-gl-area.o
- endif
- endif
-
-+ifeq ($(CONFIG_X11),y)
-+sdl.mo-objs += x_keymap.o
-+gtk.mo-objs += x_keymap.o
-+x_keymap.o-cflags := $(X11_CFLAGS)
-+x_keymap.o-libs := $(X11_LIBS)
-+endif
-+
- common-obj-$(CONFIG_CURSES) += curses.mo
- curses.mo-objs := curses.o
- curses.mo-cflags := $(CURSES_CFLAGS)
---
-2.17.0
-
diff --git a/main/qemu/0006-linux-user-signal.c-define-__SIGRTMIN-MAX-for-non-GN.patch b/main/qemu/0006-linux-user-signal.c-define-__SIGRTMIN-MAX-for-non-GN.patch
index 7ea1dba6d73..d5dc673e67c 100644
--- a/main/qemu/0006-linux-user-signal.c-define-__SIGRTMIN-MAX-for-non-GN.patch
+++ b/main/qemu/0006-linux-user-signal.c-define-__SIGRTMIN-MAX-for-non-GN.patch
@@ -18,9 +18,9 @@ diff --git a/linux-user/signal.c b/linux-user/signal.c
index 7d6246f..6019dbb 100644
--- a/linux-user/signal.c
+++ b/linux-user/signal.c
-@@ -32,6 +32,13 @@
-
- //#define DEBUG_SIGNAL
+@@ -26,6 +26,13 @@
+ #include "trace.h"
+ #include "signal-common.h"
+#ifndef __SIGRTMIN
+#define __SIGRTMIN 32
@@ -29,7 +29,7 @@ index 7d6246f..6019dbb 100644
+#define __SIGRTMAX (NSIG-1)
+#endif
+
- static struct target_sigaltstack target_sigaltstack_used = {
+ struct target_sigaltstack target_sigaltstack_used = {
.ss_sp = 0,
.ss_size = 0,
--
diff --git a/main/qemu/APKBUILD b/main/qemu/APKBUILD
index 697f6f9076f..3a52c0bc8c7 100644
--- a/main/qemu/APKBUILD
+++ b/main/qemu/APKBUILD
@@ -3,8 +3,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qemu
-pkgver=2.12.1
-pkgrel=2
+pkgver=3.0.0
+pkgrel=0
pkgdesc="QEMU is a generic machine emulator and virtualizer"
url="http://qemu.org/"
arch="all"
@@ -157,7 +157,6 @@ source="http://wiki.qemu-project.org/download/$pkgname-$pkgver.tar.xz
0001-linux-user-fix-build-with-musl-on-ppc64le.patch
fix-sockios-header.patch
test-crypto-ivgen-skip-essiv.patch
- 0001-ui-add-x_keymap.o-to-modules.patch
$pkgname-guest-agent.confd
$pkgname-guest-agent.initd
@@ -384,9 +383,9 @@ _all_modules() {
mkdir -p "$subpkgdir"
}
-sha512sums="e05c2bcd06640322452e64e26e4964b3bc9419645de8356f4e83484e37968a0b47dc8377c8c6641941973b247cb0dc22c7dad302d039baa194b1864f2c6ad7e4 qemu-2.12.1.tar.xz
+sha512sums="a764302f50b9aca4134bbbc1f361b98e71240cdc7b25600dfe733bf4cf17bd86000bd28357697b08f3b656899dceb9e459350b8d55557817444ed5d7fa380a5a qemu-3.0.0.tar.xz
405008589cad1c8b609eca004d520bf944366e8525f85a19fc6e283c95b84b6c2429822ba064675823ab69f1406a57377266a65021623d1cd581e7db000134fd 0001-elfload-load-PIE-executables-to-right-address.patch
-ec84b27648c01c6e58781295dcd0c2ff8e5a635f9836ef50c1da5d0ed125db1afc4cb5b01cb97606d6dd8f417acba93e1560d9a32ca29161a4bb730b302440ea 0006-linux-user-signal.c-define-__SIGRTMIN-MAX-for-non-GN.patch
+f52d9b3ccaa0e7613496ef3a6b820f4870d67fb89ad22c7aa3ffd6cb7c79c07f6206f060fe4e9b5b9b356b3dfee1fe2e19288497e7b8865411021eda31ca9f25 0006-linux-user-signal.c-define-__SIGRTMIN-MAX-for-non-GN.patch
1ac043312864309e19f839a699ab2485bca51bbf3d5fdb39f1a87b87e3cbdd8cbda1a56e6b5c9ffccd65a8ac2f600da9ceb8713f4dbba26f245bc52bcd8a1c56 0001-linux-user-fix-build-with-musl-on-aarch64.patch
224f5b44da749921e8a821359478c5238d8b6e24a9c0b4c5738c34e82f3062ec4639d495b8b5883d304af4a0d567e38aa6623aac1aa3a7164a5757c036528ac0 musl-F_SHLCK-and-F_EXLCK.patch
5da8114b9bd2e62f0f1f0f73f393fdbd738c5dea827ea60cedffd6f6edd0f5a97489c7148d37a8ec5a148d4e65d75cbefe9353714ee6b6f51a600200133fc914 fix-sigevent-and-sigval_t.patch
@@ -396,7 +395,6 @@ fd178f2913639a0c33199b3880cb17536961f2b3ff171c12b27f4be6bca032d6b88fd16302d09c69
d8933df9484158c2b4888254e62117d78f8ed7c18527b249419f39c2b2ab1afa148010884b40661f8965f1ef3105580fceffdfddbb2c9221dc1c62066722ba65 0001-linux-user-fix-build-with-musl-on-ppc64le.patch
39590476a4ebd7c1e79a4f0451b24c75b1817a2a83abaa1f71bb60b225d772152f0af8f3e51ff65645e378c536ffa6ff551dade52884d03a14b7c6a19c5c97d4 fix-sockios-header.patch
8b8db136f78bd26b5da171effa9e11016ec2bc3e2fc8107228b5543b47aa370978ed883794aa4f917f334e284a5b49e82070e1da2d31d49301195b6713a48eff test-crypto-ivgen-skip-essiv.patch
-e052ece28af1e7a81828322999b6f1ff5c030c717a897fe80ea04d5ba7f9d477786d91cfbf2eb3444c46b1bc8d3b72a771c26c819bc3ecfd216dd02b6567796e 0001-ui-add-x_keymap.o-to-modules.patch
d90c034cae3f9097466854ed1a9f32ab4b02089fcdf7320e8f4da13b2b1ff65067233f48809911485e4431d7ec1a22448b934121bc9522a2dc489009e87e2b1f qemu-guest-agent.confd
1cd24c2444c5935a763c501af2b0da31635aad9cf62e55416d6477fcec153cddbe7de205d99616def11b085e0dd366ba22463d2270f831d884edbc307c7864a6 qemu-guest-agent.initd
9b7a89b20fcf737832cb7b4d5dc7d8301dd88169cbe5339eda69fbb51c2e537d8cb9ec7cf37600899e734209e63410d50d0821bce97e401421db39c294d97be2 80-kvm.rules