aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-04-25 11:10:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-04-25 11:12:57 +0000
commitd52e92010695793340c9fdde2987cf0f61049833 (patch)
tree57e4e223c66c8df19b1caca88612ddb61cf53942 /main
parent216c819d6f649975eba0d5d5a671fa68c192f63a (diff)
main/libgnome: build fix for glib-2.36 and split -lang
Diffstat (limited to 'main')
-rw-r--r--main/libgnome/APKBUILD16
-rw-r--r--main/libgnome/glib-2.36.patch14
2 files changed, 25 insertions, 5 deletions
diff --git a/main/libgnome/APKBUILD b/main/libgnome/APKBUILD
index f8fbd4b41c1..515f0efb08b 100644
--- a/main/libgnome/APKBUILD
+++ b/main/libgnome/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libgnome
pkgver=2.32.1
-pkgrel=3
+pkgrel=4
pkgdesc="GNOME base library"
url="http://www.gnome.org/"
arch="all"
@@ -11,8 +11,9 @@ depends=
depends_dev="gtk+-dev gconf-dev libcanberra-dev gnome-vfs-dev libbonobo-dev"
makedepends="$depends_dev"
install="$pkgname.post-install $pkgname.pre-deinstall $pkgname.post-upgrade"
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://ftp.acc.umu.se/pub/gnome/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://ftp.acc.umu.se/pub/gnome/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
+ glib-2.36.patch"
_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
@@ -29,7 +30,7 @@ build() {
cd "$_builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
- --disable-scrollkeeper
+ || return 1
make || return 1
}
@@ -41,4 +42,9 @@ package() {
find "$pkgdir" -name '*.la' -delete
}
-md5sums="a4345e6087ae6195d65a4674ffdca559 libgnome-2.32.1.tar.bz2"
+md5sums="a4345e6087ae6195d65a4674ffdca559 libgnome-2.32.1.tar.bz2
+67e4f7b0acea497406f06b04df608982 glib-2.36.patch"
+sha256sums="b2c63916866485793b87398266dd7778548c1734923c272a94d84ee011b6f7a4 libgnome-2.32.1.tar.bz2
+a0895e37c81f5f45c0f05931416ddbad6284735eded43b75dc8d0947a5bddd55 glib-2.36.patch"
+sha512sums="f94e603255a93e73249e0fd9ed5604d732b44ad46f3cc3065afb46fc6162f6cf29304f49440b5c06303b8e68608b6fd16236076813febb5f1cbdcde4bfc3b3e3 libgnome-2.32.1.tar.bz2
+1c7ed4c8012584c980f80ce12ee2e8ab1340432766b35b3139844927e183ef33d09a02eb7ec10bb8c7312950d2c1d0d1bdeef92512cded2278223470b2936087 glib-2.36.patch"
diff --git a/main/libgnome/glib-2.36.patch b/main/libgnome/glib-2.36.patch
new file mode 100644
index 00000000000..6aad3dbc14f
--- /dev/null
+++ b/main/libgnome/glib-2.36.patch
@@ -0,0 +1,14 @@
+$NetBSD: patch-libgnome_Makefile.in,v 1.1 2013/04/19 20:37:41 prlw1 Exp $
+
+Avoid compilation error caused by use of deprecated g_thread API
+
+--- ./libgnome/Makefile.in.orig 2013-04-19 20:27:06.000000000 +0000
++++ ./libgnome/Makefile.in
+@@ -311,7 +311,6 @@ INCLUDES = \
+ -I$(srcdir)/.. \
+ $(WARN_CFLAGS) \
+ $(LIBGNOME_CFLAGS) \
+- -DG_DISABLE_DEPRECATED \
+ -DLIBGNOME_PREFIX=\""$(prefix)"\" \
+ -DLIBGNOME_LIBDIR=\""$(libdir)"\" \
+ -DLIBGNOME_DATADIR=\""$(datadir)"\" \