aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-10-26 18:51:19 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-10-26 19:47:58 +0200
commitd6529c8d14d870c966dc74c3008cdce15dabb7c5 (patch)
tree0b9de4660ef32fa295c8ab166a4613bb0c36f6b8 /main
parentaf0c01ac63cfe01e0feb2f423efb822c93ba7e03 (diff)
downloadaports-d6529c8d14d870c966dc74c3008cdce15dabb7c5.tar.gz
aports-d6529c8d14d870c966dc74c3008cdce15dabb7c5.tar.bz2
aports-d6529c8d14d870c966dc74c3008cdce15dabb7c5.tar.xz
[various] rename dependency python to python2
Diffstat (limited to 'main')
-rw-r--r--main/ansible/APKBUILD2
-rw-r--r--main/apache2-mod-wsgi/APKBUILD2
-rw-r--r--main/asciidoc/APKBUILD2
-rw-r--r--main/cjdns/APKBUILD2
-rw-r--r--main/clang/APKBUILD4
-rw-r--r--main/compiler-rt/APKBUILD2
-rw-r--r--main/d-feet/APKBUILD2
-rw-r--r--main/doxygen/APKBUILD2
-rw-r--r--main/duplicity/APKBUILD2
-rw-r--r--main/email2trac/APKBUILD2
-rw-r--r--main/fail2ban/APKBUILD2
-rw-r--r--main/fetchmail/APKBUILD4
-rw-r--r--main/flake8/APKBUILD2
-rw-r--r--main/freeradius/APKBUILD2
-rw-r--r--main/gigolo/APKBUILD2
-rw-r--r--main/glib/APKBUILD2
-rw-r--r--main/gnome-doc-utils/APKBUILD2
-rw-r--r--main/gobject-introspection/APKBUILD2
-rw-r--r--main/graphite2/APKBUILD2
-rw-r--r--main/gtest/APKBUILD2
-rw-r--r--main/gtk-doc/APKBUILD2
-rw-r--r--main/halberd/APKBUILD2
-rw-r--r--main/jack/APKBUILD2
-rw-r--r--main/libcap-ng/APKBUILD2
-rw-r--r--main/libepoxy/APKBUILD2
-rw-r--r--main/libevdev/APKBUILD2
-rw-r--r--main/libevent/APKBUILD2
-rw-r--r--main/libgit2/APKBUILD2
-rw-r--r--main/libglade/APKBUILD2
-rw-r--r--main/libgsf/APKBUILD2
-rw-r--r--main/libxcb/APKBUILD2
-rw-r--r--main/llvm/APKBUILD2
-rw-r--r--main/mesa/APKBUILD2
-rw-r--r--main/mutagen/APKBUILD4
-rw-r--r--main/ninja/APKBUILD2
-rw-r--r--main/nodejs-lts/APKBUILD2
-rw-r--r--main/nodejs/APKBUILD2
-rw-r--r--main/offlineimap/APKBUILD2
-rw-r--r--main/openpgm/APKBUILD2
-rw-r--r--main/openvswitch/APKBUILD2
-rw-r--r--main/patchwork/APKBUILD2
-rw-r--r--main/pssh/APKBUILD2
-rw-r--r--main/py-boto/APKBUILD2
-rw-r--r--main/py-cliapp/APKBUILD2
-rw-r--r--main/py-configshell/APKBUILD2
-rw-r--r--main/py-country/APKBUILD2
-rw-r--r--main/py-dbus/APKBUILD2
-rw-r--r--main/py-django-djblets/APKBUILD2
-rw-r--r--main/py-django-pipeline/APKBUILD2
-rw-r--r--main/py-django-registation/APKBUILD2
-rw-r--r--main/py-django-simple-captcha/APKBUILD2
-rw-r--r--main/py-django/APKBUILD2
-rw-r--r--main/py-docutils/APKBUILD2
-rw-r--r--main/py-ediarpc/APKBUILD2
-rw-r--r--main/py-exifread/APKBUILD2
-rw-r--r--main/py-eyed3/APKBUILD2
-rw-r--r--main/py-feedparser/APKBUILD2
-rw-r--r--main/py-flask-assets/APKBUILD2
-rw-r--r--main/py-flask-script/APKBUILD2
-rw-r--r--main/py-flask-wtf/APKBUILD2
-rw-r--r--main/py-flup/APKBUILD2
-rw-r--r--main/py-funcsigs/APKBUILD2
-rw-r--r--main/py-fuse/APKBUILD2
-rw-r--r--main/py-gflags/APKBUILD2
-rw-r--r--main/py-google-api-python-client/APKBUILD2
-rw-r--r--main/py-hiredis/APKBUILD2
-rw-r--r--main/py-hoedown/APKBUILD2
-rw-r--r--main/py-httplib2/APKBUILD2
-rw-r--r--main/py-icu/APKBUILD2
-rw-r--r--main/py-imagesize/APKBUILD2
-rw-r--r--main/py-irc/APKBUILD2
-rw-r--r--main/py-larch/APKBUILD2
-rw-r--r--main/py-lockfile/APKBUILD2
-rw-r--r--main/py-mako/APKBUILD2
-rw-r--r--main/py-mccabe/APKBUILD2
-rw-r--r--main/py-meld3/APKBUILD2
-rw-r--r--main/py-mock/APKBUILD2
-rw-r--r--main/py-munkres/APKBUILD2
-rw-r--r--main/py-musicbrainzngs/APKBUILD2
-rw-r--r--main/py-mysqldb/APKBUILD2
-rw-r--r--main/py-nose/APKBUILD2
-rw-r--r--main/py-oauth2/APKBUILD2
-rw-r--r--main/py-oauth2client/APKBUILD2
-rw-r--r--main/py-parsing/APKBUILD2
-rw-r--r--main/py-pbr/APKBUILD2
-rw-r--r--main/py-pep8/APKBUILD2
-rw-r--r--main/py-phonenumbers/APKBUILD2
-rw-r--r--main/py-pillow/APKBUILD2
-rw-r--r--main/py-purl/APKBUILD2
-rw-r--r--main/py-pygments/APKBUILD2
-rw-r--r--main/py-pylast/APKBUILD2
-rw-r--r--main/py-redis/APKBUILD2
-rw-r--r--main/py-roman/APKBUILD2
-rw-r--r--main/py-rsa/APKBUILD2
-rw-r--r--main/py-simpleparse/APKBUILD2
-rw-r--r--main/py-sphinx/APKBUILD2
-rw-r--r--main/py-templayer/APKBUILD2
-rw-r--r--main/py-tracing/APKBUILD2
-rw-r--r--main/py-ttystatus/APKBUILD2
-rw-r--r--main/py-twitter/APKBUILD2
-rw-r--r--main/py-unidecode/APKBUILD2
-rw-r--r--main/py-urlgrabber/APKBUILD2
-rw-r--r--main/py-urlnorm/APKBUILD2
-rw-r--r--main/py-vobject/APKBUILD2
-rw-r--r--main/py-webassets/APKBUILD2
-rw-r--r--main/py-wtforms/APKBUILD2
-rw-r--r--main/pyflakes/APKBUILD2
-rw-r--r--main/python2/APKBUILD2
-rw-r--r--main/scons/APKBUILD2
-rw-r--r--main/seabios/APKBUILD2
-rw-r--r--main/sems/APKBUILD4
-rw-r--r--main/smem/APKBUILD2
-rw-r--r--main/speedometer/APKBUILD2
-rw-r--r--main/speedtest-cli/APKBUILD2
-rw-r--r--main/strongswan/APKBUILD2
-rw-r--r--main/subunit/APKBUILD2
-rw-r--r--main/subversion/APKBUILD2
-rw-r--r--main/supervisor/APKBUILD2
-rw-r--r--main/tdb/APKBUILD2
-rw-r--r--main/teeworlds/APKBUILD2
-rw-r--r--main/trac/APKBUILD2
-rw-r--r--main/vde2/APKBUILD2
-rw-r--r--main/virtinst/APKBUILD2
-rw-r--r--main/vte/APKBUILD2
-rw-r--r--main/weechat/APKBUILD4
-rw-r--r--main/zeromq/APKBUILD2
-rw-r--r--main/zfs/APKBUILD2
127 files changed, 132 insertions, 132 deletions
diff --git a/main/ansible/APKBUILD b/main/ansible/APKBUILD
index 3680c720fc..3db19233f1 100644
--- a/main/ansible/APKBUILD
+++ b/main/ansible/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A configuration-management, deployment, task-execution, and multinode o
url="http://ansible.com"
arch="noarch"
license="GPL3+"
-depends="python py-yaml py-paramiko py-jinja2 py-markupsafe"
+depends="python2 py-yaml py-paramiko py-jinja2 py-markupsafe"
makedepends="python2-dev py-setuptools"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::http://releases.ansible.com/ansible/$pkgname-$pkgver.tar.gz"
diff --git a/main/apache2-mod-wsgi/APKBUILD b/main/apache2-mod-wsgi/APKBUILD
index f69f79e9b0..0799c41be6 100644
--- a/main/apache2-mod-wsgi/APKBUILD
+++ b/main/apache2-mod-wsgi/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Python WSGI Module for Apache2"
url="http://code.google.com/p/modwsgi/"
arch="all"
license="ASL 2.0"
-depends="apache2 python"
+depends="apache2 python2"
depends_dev=
makedepends="$depends_dev apache2-dev python2-dev"
install=""
diff --git a/main/asciidoc/APKBUILD b/main/asciidoc/APKBUILD
index 0564df4325..2fd8c070d5 100644
--- a/main/asciidoc/APKBUILD
+++ b/main/asciidoc/APKBUILD
@@ -6,7 +6,7 @@ pkgdesc="Text based documentation"
url="http://www.methods.co.nz/asciidoc/"
arch="noarch"
license="GPL2"
-depends="python libxml2-utils docbook-xsl"
+depends="python2 libxml2-utils docbook-xsl"
makedepends=""
install=""
subpackages="$pkgname-doc $pkgname-vim"
diff --git a/main/cjdns/APKBUILD b/main/cjdns/APKBUILD
index 0f437ae1d5..87c7f6742c 100644
--- a/main/cjdns/APKBUILD
+++ b/main/cjdns/APKBUILD
@@ -9,7 +9,7 @@ url="https://github.com/cjdelisle/cjdns"
arch="all !x86"
license="GPL3"
depends=
-makedepends="bash nodejs-lts python linux-headers libseccomp-dev"
+makedepends="bash nodejs-lts python2 linux-headers libseccomp-dev"
install="$pkgname.post-install"
subpackages="$pkgname-doc"
source="${pkgname}-${pkgver}.tar.gz::https://github.com/cjdelisle/${pkgname}/archive/cjdns-v${pkgver}.tar.gz"
diff --git a/main/clang/APKBUILD b/main/clang/APKBUILD
index 484c9c6f1b..f4a8d68bbf 100644
--- a/main/clang/APKBUILD
+++ b/main/clang/APKBUILD
@@ -17,7 +17,7 @@ makedepends="$depends_dev
llvm-dev llvm llvm-static
make
paxmark
- python
+ python2
"
install=
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-analyzer"
@@ -127,7 +127,7 @@ clang() {
analyzer() {
pkgdesc="clang source code analysis framework"
- depends="python"
+ depends="python2"
mkdir -p "$subpkgdir"/usr/bin \
"$subpkgdir"/usr/libexec \
"$subpkgdir"/usr/share/ \
diff --git a/main/compiler-rt/APKBUILD b/main/compiler-rt/APKBUILD
index 053361a917..eb13fcf0e9 100644
--- a/main/compiler-rt/APKBUILD
+++ b/main/compiler-rt/APKBUILD
@@ -11,7 +11,7 @@ depends=""
depends_dev=""
makedepends="$depends_dev
cmake
- python
+ python2
llvm
llvm-dev
llvm-static
diff --git a/main/d-feet/APKBUILD b/main/d-feet/APKBUILD
index 89074bb447..ea72e76974 100644
--- a/main/d-feet/APKBUILD
+++ b/main/d-feet/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A powerful D-Bus Debugger"
url="http://live.gnome.org/DFeet/"
arch="noarch"
license="GPLv2+"
-depends="python py-gobject3"
+depends="python2 py-gobject3"
makedepends="py-gobject3-dev itstool gtk+3.0-dev gobject-introspection-dev
libxml2-utils"
install=""
diff --git a/main/doxygen/APKBUILD b/main/doxygen/APKBUILD
index edbff0fc70..22d9cead42 100644
--- a/main/doxygen/APKBUILD
+++ b/main/doxygen/APKBUILD
@@ -7,7 +7,7 @@ url="http://www.doxygen.org/"
arch="all"
license="GPL"
depends=""
-makedepends="flex bison coreutils perl python cmake"
+makedepends="flex bison coreutils perl python2 cmake"
subpackages=""
source="http://ftp.stack.nl/pub/users/dimitri/doxygen-$pkgver.src.tar.gz
doxygen-1.8.11-install.patch
diff --git a/main/duplicity/APKBUILD b/main/duplicity/APKBUILD
index 18a78ac8d7..cbe93ae7dc 100644
--- a/main/duplicity/APKBUILD
+++ b/main/duplicity/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Encrypted bandwidth-efficient backup using the rsync algorithm"
url="http://duplicity.nongnu.org/"
arch="all"
license="GPL"
-depends="python py-boto gnupg ncftp py-lockfile"
+depends="python2 py-boto gnupg ncftp py-lockfile"
makedepends="python2-dev py-setuptools librsync-dev"
install=
subpackages="$pkgname-doc $pkgname-lang"
diff --git a/main/email2trac/APKBUILD b/main/email2trac/APKBUILD
index 7d83009b2a..c22663f838 100644
--- a/main/email2trac/APKBUILD
+++ b/main/email2trac/APKBUILD
@@ -8,7 +8,7 @@ url="https://subtrac.sara.nl/oss/email2trac"
arch="all"
license="GPLv2+"
depends="trac"
-makedepends="python"
+makedepends="python2"
install=""
subpackages=""
source="ftp://ftp.sara.nl/pub/outgoing/email2trac-$pkgver.tar.gz"
diff --git a/main/fail2ban/APKBUILD b/main/fail2ban/APKBUILD
index 92ad41aeee..3062cd5716 100644
--- a/main/fail2ban/APKBUILD
+++ b/main/fail2ban/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Scans log files for login failures then updates iptables to reject orig
url="http://www.fail2ban.org"
arch="noarch"
license="GPL2+"
-depends="python iptables logrotate"
+depends="python2 iptables logrotate"
makedepends="python2-dev py-setuptools"
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz
fail2ban.confd
diff --git a/main/fetchmail/APKBUILD b/main/fetchmail/APKBUILD
index f1ca687dea..dce1ff4443 100644
--- a/main/fetchmail/APKBUILD
+++ b/main/fetchmail/APKBUILD
@@ -10,7 +10,7 @@ license="GPL"
depends=
pkgusers="fetchmail"
pkggroups="fetchmail"
-makedepends="libressl-dev python autoconf automake gettext-dev"
+makedepends="libressl-dev python2 autoconf automake gettext-dev"
install="fetchmail.pre-install"
subpackages="$pkgname-doc fetchmailconf"
source="http://downloads.sourceforge.net/project/${pkgname}/branch_6.3/${pkgname}-${pkgver}.tar.xz
@@ -52,7 +52,7 @@ package() {
}
fetchmailconf() {
- depends="python"
+ depends="python2"
pkgdesc="A GUI for generating fetchmail configuration files"
install=
mkdir -p "$subpkgdir"/usr/bin
diff --git a/main/flake8/APKBUILD b/main/flake8/APKBUILD
index a1d8ae0401..b5520a027e 100644
--- a/main/flake8/APKBUILD
+++ b/main/flake8/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="A modular source code checker"
url="https://gitlab.com/pycqa/flake8"
arch="noarch"
license="MIT"
-depends="python py-setuptools py-mccabe py-pep8 pyflakes"
+depends="python2 py-setuptools py-mccabe py-pep8 pyflakes"
depends_dev=""
makedepends="python2-dev"
install=""
diff --git a/main/freeradius/APKBUILD b/main/freeradius/APKBUILD
index e8da92c19a..31db987233 100644
--- a/main/freeradius/APKBUILD
+++ b/main/freeradius/APKBUILD
@@ -229,7 +229,7 @@ postgresql() {
}
python() {
- depends="freeradius=$pkgver-r$pkgrel python"
+ depends="freeradius=$pkgver-r$pkgrel python2"
provides="freeradius3-python=$pkgver-r$pkgrel"
pkgdesc="Python module for FreeRADIUS server"
mkdir -p "${subpkgdir}"${radlibdir}
diff --git a/main/gigolo/APKBUILD b/main/gigolo/APKBUILD
index b00a4475be..429c872041 100644
--- a/main/gigolo/APKBUILD
+++ b/main/gigolo/APKBUILD
@@ -8,7 +8,7 @@ url="http://www.uvena.de/gigolo/"
license="GPLv2"
arch="all"
depends=
-makedepends="gtk+-dev python"
+makedepends="gtk+-dev python2"
install=
subpackages="$pkgname-doc $pkgname-lang"
source="http://archive.xfce.org/src/apps/gigolo/${pkgver%.*}/gigolo-$pkgver.tar.bz2"
diff --git a/main/glib/APKBUILD b/main/glib/APKBUILD
index e3f8190500..e2b5211b2d 100644
--- a/main/glib/APKBUILD
+++ b/main/glib/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
license='GPL'
depends=
triggers="$pkgname.trigger=/usr/share/glib-2.0/schemas:/usr/lib/gio/modules"
-depends_dev="perl python gettext-dev zlib-dev bzip2-dev libffi-dev
+depends_dev="perl python2 gettext-dev zlib-dev bzip2-dev libffi-dev
util-linux-dev"
makedepends="$depends_dev pcre-dev"
source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
diff --git a/main/gnome-doc-utils/APKBUILD b/main/gnome-doc-utils/APKBUILD
index e59f6f5d84..d18000b49b 100644
--- a/main/gnome-doc-utils/APKBUILD
+++ b/main/gnome-doc-utils/APKBUILD
@@ -6,7 +6,7 @@ pkgdesc="Documentation utilities for Gnome"
url="http://www.gnome.org"
arch="noarch"
license="GPL LGPL"
-depends="python docbook-xml rarian py-libxml2 libxslt"
+depends="python2 docbook-xml rarian py-libxml2 libxslt"
makedepends="libxslt-dev libxml2-dev perl-xml-parser rarian-dev
gettext-dev intltool"
subpackages="$pkgname-lang $pkgname-doc"
diff --git a/main/gobject-introspection/APKBUILD b/main/gobject-introspection/APKBUILD
index 4c60301b7b..750ea34431 100644
--- a/main/gobject-introspection/APKBUILD
+++ b/main/gobject-introspection/APKBUILD
@@ -6,7 +6,7 @@ pkgdesc="Introspection system for GObject-based libraries"
url="http://live.gnome.org/GObjectIntrospection"
arch="all"
license="LGPL GPL"
-depends_dev="python glib-dev libffi-dev cairo-dev libtool"
+depends_dev="python2 glib-dev libffi-dev cairo-dev libtool"
makedepends="$depends_dev flex bison python2-dev"
depends=
replaces="libgirepository"
diff --git a/main/graphite2/APKBUILD b/main/graphite2/APKBUILD
index 2ccbf6885e..16d5b7ee70 100644
--- a/main/graphite2/APKBUILD
+++ b/main/graphite2/APKBUILD
@@ -10,7 +10,7 @@ arch="all"
license="LGPL"
depends=""
depends_dev="freetype-dev"
-makedepends="$depends_dev python cmake"
+makedepends="$depends_dev python2 cmake"
install=""
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/silnrsi/$_realname/archive/$pkgver.tar.gz
diff --git a/main/gtest/APKBUILD b/main/gtest/APKBUILD
index a12b8a3b48..9008addf44 100644
--- a/main/gtest/APKBUILD
+++ b/main/gtest/APKBUILD
@@ -7,7 +7,7 @@ url="http://code.google.com/p/googletest"
arch="all"
license="BSD"
depends="libgcc bash"
-depends_dev="python cmake"
+depends_dev="python2 cmake"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
diff --git a/main/gtk-doc/APKBUILD b/main/gtk-doc/APKBUILD
index 14f3aac199..91e0b6ed3f 100644
--- a/main/gtk-doc/APKBUILD
+++ b/main/gtk-doc/APKBUILD
@@ -6,7 +6,7 @@ pkgdesc="Documentation tool for public library API"
url="http://www.gtk.org/gtk-doc/"
arch="noarch"
license="GPL FDL"
-depends="docbook-xsl gnome-doc-utils perl pkgconfig python"
+depends="docbook-xsl gnome-doc-utils perl pkgconfig python2"
makedepends="rarian-dev py-libxml2 gettext itstool"
source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"
diff --git a/main/halberd/APKBUILD b/main/halberd/APKBUILD
index 7829223fbc..d498716ffc 100644
--- a/main/halberd/APKBUILD
+++ b/main/halberd/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Tool to discover HTTP load balancers"
url="http://halberd.superadditive.com"
arch="noarch"
license="GPL2+"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev help2man"
install=""
diff --git a/main/jack/APKBUILD b/main/jack/APKBUILD
index ff9640c950..08cd5d4a00 100644
--- a/main/jack/APKBUILD
+++ b/main/jack/APKBUILD
@@ -9,7 +9,7 @@ license="GPLv2 GPLv2+ LGPLv2+"
depends=""
depends_dev=""
makedepends="$depends_dev alsa-lib-dev dbus-dev expat-dev libsamplerate-dev
- libsndfile-dev ncurses-dev readline-dev python"
+ libsndfile-dev ncurses-dev readline-dev python2"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-dbus $pkgname-example-clients:_clients"
source="https://dl.dropboxusercontent.com/u/28869550/jack-$pkgver.tar.bz2
diff --git a/main/libcap-ng/APKBUILD b/main/libcap-ng/APKBUILD
index f27bca81a6..99f4d7305b 100644
--- a/main/libcap-ng/APKBUILD
+++ b/main/libcap-ng/APKBUILD
@@ -8,7 +8,7 @@ arch="all"
license="GPL"
depends=
depends_dev="linux-headers"
-makedepends="python $depends_dev"
+makedepends="python2 $depends_dev"
install=
subpackages="$pkgname-dev $pkgname-doc $pkgname-utils"
source="http://people.redhat.com/sgrubb/libcap-ng/libcap-ng-$pkgver.tar.gz
diff --git a/main/libepoxy/APKBUILD b/main/libepoxy/APKBUILD
index b4be2585b5..ad97467b57 100644
--- a/main/libepoxy/APKBUILD
+++ b/main/libepoxy/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
license="MIT"
depends=""
depends_dev="libx11-dev mesa-dev"
-makedepends="$depends_dev autoconf automake libtool util-macros python"
+makedepends="$depends_dev autoconf automake libtool util-macros python2"
install=""
subpackages="$pkgname-dev"
source="libepoxy-$pkgver.tar.gz::https://codeload.github.com/anholt/libepoxy/tar.gz/v$pkgver"
diff --git a/main/libevdev/APKBUILD b/main/libevdev/APKBUILD
index ddfda0b1ed..efb38c1a29 100644
--- a/main/libevdev/APKBUILD
+++ b/main/libevdev/APKBUILD
@@ -7,7 +7,7 @@ url="https://www.freedesktop.org/wiki/Software/libevdev"
arch="all"
license="MIT"
depends=""
-makedepends="python linux-headers"
+makedepends="python2 linux-headers"
subpackages="$pkgname-dev $pkgname-doc"
source="https://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz"
diff --git a/main/libevent/APKBUILD b/main/libevent/APKBUILD
index 0f5e1d5453..13ec0052c2 100644
--- a/main/libevent/APKBUILD
+++ b/main/libevent/APKBUILD
@@ -7,7 +7,7 @@ url="http://libevent.org/"
arch="all"
license="BSD"
depends=""
-depends_dev="python"
+depends_dev="python2"
makedepends="$depends_dev libressl-dev"
subpackages="$pkgname-dev"
source="https://github.com/$pkgname/$pkgname/releases/download/release-${pkgver}-stable/$pkgname-${pkgver}-stable.tar.gz"
diff --git a/main/libgit2/APKBUILD b/main/libgit2/APKBUILD
index 922db7fcb6..e768971f6a 100644
--- a/main/libgit2/APKBUILD
+++ b/main/libgit2/APKBUILD
@@ -10,7 +10,7 @@ arch="all"
license="GPLv2"
depends=""
depends_dev="curl-dev libssh2-dev"
-makedepends="$depends_dev python cmake zlib-dev libressl-dev"
+makedepends="$depends_dev python2 cmake zlib-dev libressl-dev"
install=""
subpackages="$pkgname-dev $pkgname-libs"
source="$pkgname-$pkgver.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz"
diff --git a/main/libglade/APKBUILD b/main/libglade/APKBUILD
index 6011725c7c..162228eeb3 100644
--- a/main/libglade/APKBUILD
+++ b/main/libglade/APKBUILD
@@ -9,7 +9,7 @@ license="LGPL"
subpackages="$pkgname-dev $pkgname-doc"
depends="libxml2-utils"
depends_dev="gtk+2.0-dev libxml2-dev"
-makedepends="$depends_dev python autoconf automake libtool"
+makedepends="$depends_dev python2 autoconf automake libtool"
install="$pkgname.post-install $pkgname.pre-upgrade $pkgname.post-upgrade
$pkgname.post-deinstall"
source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/2.6/$pkgname-$pkgver.tar.bz2
diff --git a/main/libgsf/APKBUILD b/main/libgsf/APKBUILD
index a4eb3aafcc..fb05f28e49 100644
--- a/main/libgsf/APKBUILD
+++ b/main/libgsf/APKBUILD
@@ -8,7 +8,7 @@ arch="all"
license="GPL LGPL"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
depends=
-makedepends="libxml2-dev glib-dev bzip2-dev intltool python zlib-dev"
+makedepends="libxml2-dev glib-dev bzip2-dev intltool python2 zlib-dev"
source="http://ftp.gnome.org/pub/GNOME/sources/$pkgname/1.14/$pkgname-$pkgver.tar.xz"
depends_dev="bzip2-dev"
diff --git a/main/libxcb/APKBUILD b/main/libxcb/APKBUILD
index 7e642f0077..572cc56050 100644
--- a/main/libxcb/APKBUILD
+++ b/main/libxcb/APKBUILD
@@ -9,7 +9,7 @@ license="custom"
depends=
subpackages="$pkgname-dev $pkgname-doc"
depends_dev="libxau-dev xcb-proto"
-makedepends="$depends_dev libxslt python libpthread-stubs libxdmcp-dev"
+makedepends="$depends_dev libxslt python2 libpthread-stubs libxdmcp-dev"
source="http://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2
"
diff --git a/main/llvm/APKBUILD b/main/llvm/APKBUILD
index 63c0b4521c..940ae57627 100644
--- a/main/llvm/APKBUILD
+++ b/main/llvm/APKBUILD
@@ -22,7 +22,7 @@ makedepends="$depends_dev
make
paxmark
py-sphinx
- python
+ python2
python2-dev
zlib-dev
"
diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index 180f9a8ce4..9f0fac6a69 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -20,7 +20,7 @@ subpackages="$pkgname-dev
depends_dev="libdrm-dev dri2proto libx11-dev libxext-dev libxxf86vm-dev
libxdamage-dev libxfixes-dev libxcb-dev glproto dri3proto presentproto
libxshmfence-dev"
-makedepends="$depends_dev expat-dev xextproto python libxt-dev makedepend
+makedepends="$depends_dev expat-dev xextproto python2 libxt-dev makedepend
talloc-dev py-libxml2 flex bison llvm-dev eudev-dev libvdpau-dev
libxvmc-dev gettext zlib-dev wayland-dev libelf-dev py-mako
autoconf automake libtool"
diff --git a/main/mutagen/APKBUILD b/main/mutagen/APKBUILD
index aa1516fe00..45b4b5075e 100644
--- a/main/mutagen/APKBUILD
+++ b/main/mutagen/APKBUILD
@@ -6,7 +6,7 @@ pkgdesc="An audio metadata tag reader and writer implemented in pure python"
url="http://code.google.com/p/mutagen/"
arch="noarch"
license="GPL2"
-depends="python py-mutagen"
+depends="python2 py-mutagen"
makedepends="python2-dev"
subpackages="$pkgname-doc py-$pkgname:py"
source="https://bitbucket.org/lazka/mutagen/downloads/mutagen-$pkgver.tar.gz"
@@ -25,7 +25,7 @@ package() {
py() {
pkgdesc="Python library for mutagen"
- depends="python"
+ depends="python2"
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
diff --git a/main/ninja/APKBUILD b/main/ninja/APKBUILD
index a3d7b4cc60..e042c29987 100644
--- a/main/ninja/APKBUILD
+++ b/main/ninja/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
license="Apache"
depends=""
depends_dev=""
-makedepends="$depends_dev asciidoc python re2c gtest"
+makedepends="$depends_dev asciidoc python2 re2c gtest"
install=""
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/martine/ninja/archive/v$pkgver.tar.gz"
diff --git a/main/nodejs-lts/APKBUILD b/main/nodejs-lts/APKBUILD
index e2c830654c..a784a1d939 100644
--- a/main/nodejs-lts/APKBUILD
+++ b/main/nodejs-lts/APKBUILD
@@ -9,7 +9,7 @@ url='http://nodejs.org/'
arch='all'
license='MIT'
# gold is needed for mksnapshot
-makedepends="$depends_dev python openssl-dev zlib-dev libuv-dev
+makedepends="$depends_dev python2 openssl-dev zlib-dev libuv-dev
linux-headers paxmark binutils-gold"
subpackages="$pkgname-dev $pkgname-doc"
replaces="nodejs"
diff --git a/main/nodejs/APKBUILD b/main/nodejs/APKBUILD
index c31db1249b..69ba7271e3 100644
--- a/main/nodejs/APKBUILD
+++ b/main/nodejs/APKBUILD
@@ -7,7 +7,7 @@ url="http://nodejs.org/"
arch="all"
license="MIT"
# gold is needed for mksnapshot
-makedepends="python openssl-dev zlib-dev libuv-dev linux-headers paxmark
+makedepends="python2 openssl-dev zlib-dev libuv-dev linux-headers paxmark
binutils-gold"
subpackages="$pkgname-dev $pkgname-doc"
replaces="nodejs-lts"
diff --git a/main/offlineimap/APKBUILD b/main/offlineimap/APKBUILD
index df893a234f..f28e8922aa 100644
--- a/main/offlineimap/APKBUILD
+++ b/main/offlineimap/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Synchronizes emails between two repositories"
url="http://www.offlineimap.org"
arch="noarch"
license="GPL2+"
-depends="python py2-six"
+depends="python2 py2-six"
depends_dev=""
makedepends="python2-dev asciidoc"
install=""
diff --git a/main/openpgm/APKBUILD b/main/openpgm/APKBUILD
index 266bc56687..a380253384 100644
--- a/main/openpgm/APKBUILD
+++ b/main/openpgm/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
license="LGPL 2.1"
depends=""
depends_dev=""
-makedepends="$depends_dev python perl"
+makedepends="$depends_dev python2 perl"
install=""
subpackages="$pkgname-dev"
source="https://openpgm.googlecode.com/files/libpgm-$pkgver.tar.bz2
diff --git a/main/openvswitch/APKBUILD b/main/openvswitch/APKBUILD
index 5758a59307..1c1f2baa76 100644
--- a/main/openvswitch/APKBUILD
+++ b/main/openvswitch/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
license="ASL 2.0"
depends=""
depends_dev="libressl-dev"
-makedepends="$depends_dev perl python linux-headers bash py-six"
+makedepends="$depends_dev perl python2 linux-headers bash py-six"
subpackages="$pkgname-doc $pkgname-dbg $pkgname-dev $pkgname-monitor $pkgname-bash-completion:bashcomp"
source="http://openvswitch.org/releases/$pkgname-$pkgver.tar.gz
ovsdb-server.initd
diff --git a/main/patchwork/APKBUILD b/main/patchwork/APKBUILD
index 1353307352..3b787a5306 100644
--- a/main/patchwork/APKBUILD
+++ b/main/patchwork/APKBUILD
@@ -82,7 +82,7 @@ postgresql() {
pwclient() {
pkgdesc="command-line client for patchwork"
- depends="python"
+ depends="python2"
install -Dm775 "$pkgdir"/usr/share/webapps/patchwork/patchwork/bin/pwclient \
"$subpkgdir"/usr/bin/pwclient || return 1
}
diff --git a/main/pssh/APKBUILD b/main/pssh/APKBUILD
index 24a8556335..214b09cfd3 100644
--- a/main/pssh/APKBUILD
+++ b/main/pssh/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="PSSH provides parallel versions of OpenSSH and related tools: pssh, psc
url="https://code.google.com/p/parallel-ssh/"
arch="noarch"
license="BSD"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev"
install=""
diff --git a/main/py-boto/APKBUILD b/main/py-boto/APKBUILD
index 31b21fa7e7..eded251641 100644
--- a/main/py-boto/APKBUILD
+++ b/main/py-boto/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="An interface to infrastructural services offered by Amazon Web Services
url="http://docs.pythonboto.org/en/latest/index.html"
arch="noarch"
license="MIT"
-depends="python"
+depends="python2"
makedepends="python2-dev py-setuptools"
install=""
subpackages="$pkgname-doc"
diff --git a/main/py-cliapp/APKBUILD b/main/py-cliapp/APKBUILD
index dbb3b5d430..7991ef8069 100644
--- a/main/py-cliapp/APKBUILD
+++ b/main/py-cliapp/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Framework for Unix-like command line programs"
url="http://liw.fi/cliapp/"
arch="noarch"
license="GPL3+"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="py-setuptools"
install=""
diff --git a/main/py-configshell/APKBUILD b/main/py-configshell/APKBUILD
index ff78d0a123..4d1a4c34f0 100644
--- a/main/py-configshell/APKBUILD
+++ b/main/py-configshell/APKBUILD
@@ -9,7 +9,7 @@ pkgdesc="Python library that provides a framework for building simple but nice C
url="https://github.com/agrover/configshell-fb"
arch="noarch"
license="AGPL3"
-depends="python py-six py-urwid py-parsing"
+depends="python2 py-six py-urwid py-parsing"
depends_dev=""
makedepends="$depends_dev python2-dev py-setuptools"
install=""
diff --git a/main/py-country/APKBUILD b/main/py-country/APKBUILD
index f6c46865f6..ac74d3cf6c 100644
--- a/main/py-country/APKBUILD
+++ b/main/py-country/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="ISO country, subdivision, language, currency and script definitions and
url=https://pypi.python.org/pypi/pycountry
arch="noarch"
license="LGPL2+"
-depends="python"
+depends="python2"
makedepends="python2-dev py-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
diff --git a/main/py-dbus/APKBUILD b/main/py-dbus/APKBUILD
index c1841c4674..5b507c7ca6 100644
--- a/main/py-dbus/APKBUILD
+++ b/main/py-dbus/APKBUILD
@@ -6,7 +6,7 @@ pkgdesc="Python bindings for DBUS"
url="http://www.freedesktop.org/wiki/Software/DBusBindings"
arch="all"
license="GPL LGPL"
-depends="python>=2.6.5"
+depends="python2"
depends_dev="py-dbus"
makedepends="dbus-glib-dev python2-dev"
subpackages="$pkgname-dev $pkgname-doc"
diff --git a/main/py-django-djblets/APKBUILD b/main/py-django-djblets/APKBUILD
index 8b03390d9c..1675e95609 100644
--- a/main/py-django-djblets/APKBUILD
+++ b/main/py-django-djblets/APKBUILD
@@ -9,7 +9,7 @@ url="https://github.com/djblets/djblets/"
arch="noarch"
license="BSD"
makedepends="python2-dev py-setuptools"
-depends="python py-django-pipeline"
+depends="python2 py-django-pipeline"
source="$pkgname-$pkgver.tar.gz::https://github.com/djblets/djblets/archive/release-${pkgver}.tar.gz"
_builddir="${srcdir}/djblets-release-${pkgver}"
diff --git a/main/py-django-pipeline/APKBUILD b/main/py-django-pipeline/APKBUILD
index f216e37ab2..ff1cd69372 100644
--- a/main/py-django-pipeline/APKBUILD
+++ b/main/py-django-pipeline/APKBUILD
@@ -10,7 +10,7 @@ arch="noarch"
license="BSD"
#makedepends="python2-dev py-setuptools py-django"
makedepends="python2-dev py-setuptools"
-depends="python"
+depends="python2"
source="$pkgname-$pkgver.tar.gz::https://github.com/cyberdelia/django-pipeline/archive/${pkgver}.tar.gz"
_builddir="${srcdir}/${_pkgname}-${pkgver}"
diff --git a/main/py-django-registation/APKBUILD b/main/py-django-registation/APKBUILD
index 4e94a07f1e..a5eda0f7f1 100644
--- a/main/py-django-registation/APKBUILD
+++ b/main/py-django-registation/APKBUILD
@@ -9,7 +9,7 @@ url="https://github.com/ubernostrum/django-registration"
arch="noarch"
license="BSD"
makedepends="python2-dev py-setuptools"
-depends="python"
+depends="python2"
source="${_pkgname}-${pkgver}.tar.gz::https://github.com/ubernostrum/django-registration/archive/${pkgver}.tar.gz"
_builddir="${srcdir}/${_pkgname}-${pkgver}"
diff --git a/main/py-django-simple-captcha/APKBUILD b/main/py-django-simple-captcha/APKBUILD
index efef719dc9..a990cabd58 100644
--- a/main/py-django-simple-captcha/APKBUILD
+++ b/main/py-django-simple-captcha/APKBUILD
@@ -9,7 +9,7 @@ url="https://github.com/mbi/django-simple-captcha"
arch="noarch"
license="BSD"
makedepends="python2-dev py-setuptools"
-depends="python"
+depends="python2"
source="$_pkgname-$pkgver.tar.gz::https://github.com/mbi/django-simple-captcha/archive/$pkgver.tar.gz"
_builddir="${srcdir}/${_pkgname}-$pkgver"
diff --git a/main/py-django/APKBUILD b/main/py-django/APKBUILD
index f2f3adc7b9..e32b1ce451 100644
--- a/main/py-django/APKBUILD
+++ b/main/py-django/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A high-level Python Web framework"
url="http://djangoproject.com/"
arch="noarch"
license="BSD"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-docutils/APKBUILD b/main/py-docutils/APKBUILD
index 94c795bd6f..e264a63cbd 100644
--- a/main/py-docutils/APKBUILD
+++ b/main/py-docutils/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Documentation Utilities for Python"
url="http://docutils.sourceforge.net/"
arch="noarch"
license="PublicDomain"
-depends="python py-pillow py-roman"
+depends="python2 py-pillow py-roman"
makedepends="python2-dev py-setuptools"
install=
subpackages="$pkgname-doc"
diff --git a/main/py-ediarpc/APKBUILD b/main/py-ediarpc/APKBUILD
index ca57b620a0..37019fee32 100644
--- a/main/py-ediarpc/APKBUILD
+++ b/main/py-ediarpc/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Python RPC library"
url="https://bitbucket.org/tortoiselabs/ediarpc"
arch="noarch"
license="ISC"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev"
install=""
diff --git a/main/py-exifread/APKBUILD b/main/py-exifread/APKBUILD
index b0d5d48428..645abf4331 100644
--- a/main/py-exifread/APKBUILD
+++ b/main/py-exifread/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Read Exif metadata from tiff and jpeg files"
url="https://pypi.python.org/pypi/ExifRead"
arch="noarch"
license="BSD"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-eyed3/APKBUILD b/main/py-eyed3/APKBUILD
index eacf6f3e38..6695a76616 100644
--- a/main/py-eyed3/APKBUILD
+++ b/main/py-eyed3/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="A Python module and program for processing information about mp3 files"
url="http://eyed3.nicfit.net/"
arch="noarch"
license="GPL"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-feedparser/APKBUILD b/main/py-feedparser/APKBUILD
index 039e08aa16..24dbe51ab3 100644
--- a/main/py-feedparser/APKBUILD
+++ b/main/py-feedparser/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A Python feed parser for RSS and Atom"
url="https://github.com/kurtmckee/feedparser"
arch="noarch"
license="BSD"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-flask-assets/APKBUILD b/main/py-flask-assets/APKBUILD
index bf0228842e..b1ef7f722e 100644
--- a/main/py-flask-assets/APKBUILD
+++ b/main/py-flask-assets/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Flask asset management"
url="https://pypi.python.org/pypi/Flask-Assets"
arch="noarch"
license="BSD"
-depends="python py-flask py-webassets"
+depends="python2 py-flask py-webassets"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-flask-script/APKBUILD b/main/py-flask-script/APKBUILD
index 720ee0bc1e..79b5c5717a 100644
--- a/main/py-flask-script/APKBUILD
+++ b/main/py-flask-script/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Flask scripting support"
url="https://pypi.python.org/pypi/Flask-Script"
arch="noarch"
license="BSD"
-depends="python py-flask"
+depends="python2 py-flask"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-flask-wtf/APKBUILD b/main/py-flask-wtf/APKBUILD
index 846bd787c9..cd1d5aa59b 100644
--- a/main/py-flask-wtf/APKBUILD
+++ b/main/py-flask-wtf/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Flask WTForms extension"
url="https://pypi.python.org/pypi/Flask-WTF"
arch="noarch"
license="BSD"
-depends="python py-flask py-wtforms"
+depends="python2 py-flask py-wtforms"
depends_dev=""
makedepends="python2-dev py-setuptools py-wtforms"
install=""
diff --git a/main/py-flup/APKBUILD b/main/py-flup/APKBUILD
index 8bc9daac5e..a57a59c6f6 100644
--- a/main/py-flup/APKBUILD
+++ b/main/py-flup/APKBUILD
@@ -9,7 +9,7 @@ url="http://www.saddi.com/software/flup/"
arch="noarch"
license="BSD"
makedepends="python2-dev py-setuptools"
-depends="python"
+depends="python2"
source="$pkgname-$pkgver.tar.gz::http://www.saddi.com/software/flup/dist/${_pkgname}-${pkgver}.tar.gz"
_builddir="${srcdir}/${_pkgname}-${pkgver}"
diff --git a/main/py-funcsigs/APKBUILD b/main/py-funcsigs/APKBUILD
index 6c8507c6fe..04ef4a347f 100644
--- a/main/py-funcsigs/APKBUILD
+++ b/main/py-funcsigs/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Python function signatures from PEP362 for Python 2.6, 2.7 and 3.2+"
url="http://funcsigs.readthedocs.org"
arch="noarch"
license="ASL"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="$depends_dev python2-dev py-setuptools"
install=""
diff --git a/main/py-fuse/APKBUILD b/main/py-fuse/APKBUILD
index 3b6154ec43..ffe367ef72 100644
--- a/main/py-fuse/APKBUILD
+++ b/main/py-fuse/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Python bindings for FUSE - filesystem in userspace"
url="https://github.com/libfuse/python-fuse/"
arch="all"
license="LGPL2+"
-depends="python"
+depends="python2"
makedepends="python2-dev py-setuptools fuse-dev"
source="https://github.com/libfuse/python-fuse/releases/download/$pkgver/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
diff --git a/main/py-gflags/APKBUILD b/main/py-gflags/APKBUILD
index 33a9209307..f4fd8e1a96 100644
--- a/main/py-gflags/APKBUILD
+++ b/main/py-gflags/APKBUILD
@@ -6,7 +6,7 @@ pkgdesc="Commandline flags module for Python"
url="http://code.google.com/p/python-gflags"
arch="noarch"
license="BSD"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-google-api-python-client/APKBUILD b/main/py-google-api-python-client/APKBUILD
index 0bb4536322..e39ac07f03 100644
--- a/main/py-google-api-python-client/APKBUILD
+++ b/main/py-google-api-python-client/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Google API Client Library for Python"
url="https://code.google.com/p/google-api-python-client/"
arch="noarch"
license="Apache"
-depends="python py-httplib2 py-oauth2client py-uritemplate py-six"
+depends="python2 py-httplib2 py-oauth2client py-uritemplate py-six"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-hiredis/APKBUILD b/main/py-hiredis/APKBUILD
index ff51784dc4..a7fbe933d7 100644
--- a/main/py-hiredis/APKBUILD
+++ b/main/py-hiredis/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Python extension that wraps hiredis"
url="https://github.com/redis/hiredis-py"
arch="all"
license="BSD"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools hiredis-dev"
install=""
diff --git a/main/py-hoedown/APKBUILD b/main/py-hoedown/APKBUILD
index ba7c61c3d3..5371dbbebe 100644
--- a/main/py-hoedown/APKBUILD
+++ b/main/py-hoedown/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Python binding for hoedown, a markdown parsing library"
url="https://github.com/hhatto/python-hoedown"
arch="all"
license="MIT"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-httplib2/APKBUILD b/main/py-httplib2/APKBUILD
index 17f957a1e8..14bb517650 100644
--- a/main/py-httplib2/APKBUILD
+++ b/main/py-httplib2/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A Python HTTP client library"
url="https://github.com/jcgregorio/httplib2"
arch="noarch"
license="MIT"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-icu/APKBUILD b/main/py-icu/APKBUILD
index be29e7ce5d..39e1b574af 100644
--- a/main/py-icu/APKBUILD
+++ b/main/py-icu/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Python binding for ICU"
url="http://pyicu.osafoundation.org/"
arch="all"
license="MIT"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev icu-dev"
install=""
diff --git a/main/py-imagesize/APKBUILD b/main/py-imagesize/APKBUILD
index 03abe22d44..b1716a8431 100644
--- a/main/py-imagesize/APKBUILD
+++ b/main/py-imagesize/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Getting image size from png/jpeg/jpeg2000/gif file"
url="https://github.com/shibukawa/imagesize_py"
arch="noarch"
license="MIT"
-depends="python"
+depends="python2"
makedepends="py-setuptools"
source="$pkgname-$pkgver.tar.gz::https://github.com/shibukawa/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
diff --git a/main/py-irc/APKBUILD b/main/py-irc/APKBUILD
index 9df2f3d992..9d73093e97 100644
--- a/main/py-irc/APKBUILD
+++ b/main/py-irc/APKBUILD
@@ -9,7 +9,7 @@ url="http://python-irclib.sourceforge.net/"
arch="noarch"
license="LGPL2+"
depends=""
-depends_dev="python"
+depends_dev="python2"
makedepends="$depends_dev py-hgtools py-setuptools"
install=""
subpackages="$pkgname-scripts"
diff --git a/main/py-larch/APKBUILD b/main/py-larch/APKBUILD
index 4f07b5f83c..b22bcfb63d 100644
--- a/main/py-larch/APKBUILD
+++ b/main/py-larch/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Copy-on-write B-tree data structure"
url="http://liw.fi/larch/"
arch="noarch"
license="GPL3+"
-depends="python py-tracing py-cliapp py-ttystatus"
+depends="python2 py-tracing py-cliapp py-ttystatus"
depends_dev=""
makedepends="py-setuptools"
install=""
diff --git a/main/py-lockfile/APKBUILD b/main/py-lockfile/APKBUILD
index 48d96ab02e..607953149b 100644
--- a/main/py-lockfile/APKBUILD
+++ b/main/py-lockfile/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A Python file locking module"
url="https://github.com/smontanaro/pylockfile"
arch="noarch"
license="MIT"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-mako/APKBUILD b/main/py-mako/APKBUILD
index 2e36314159..f3da19dcb6 100644
--- a/main/py-mako/APKBUILD
+++ b/main/py-mako/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A Python fast templating language"
url="http://www.makotemplates.org/"
arch="noarch"
license="MIT"
-depends="python py-markupsafe"
+depends="python2 py-markupsafe"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-mccabe/APKBUILD b/main/py-mccabe/APKBUILD
index a0585360ad..4bba01c8cd 100644
--- a/main/py-mccabe/APKBUILD
+++ b/main/py-mccabe/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A McCabe complexity checker plugin for Flake8"
url="https://github.com/flintwork/mccabe"
arch="noarch"
license="MIT"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-meld3/APKBUILD b/main/py-meld3/APKBUILD
index 5fb25b6346..10b10e79a8 100644
--- a/main/py-meld3/APKBUILD
+++ b/main/py-meld3/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="An HTML/XML templating engine"
url="https://github.com/supervisor/meld3"
arch="noarch"
license="ZPL"
-depends="python"
+depends="python2"
depends_dev="python2-dev py-setuptools"
makedepends="$depends_dev"
install=""
diff --git a/main/py-mock/APKBUILD b/main/py-mock/APKBUILD
index 08f557a0e0..361c9698da 100644
--- a/main/py-mock/APKBUILD
+++ b/main/py-mock/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A Python Mocking and Patching Library for Testing"
url="https://github.com/testing-cabal/mock"
arch="noarch"
license="BSD"
-depends="python py-pbr py-funcsigs py-six"
+depends="python2 py-pbr py-funcsigs py-six"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-munkres/APKBUILD b/main/py-munkres/APKBUILD
index f552f683cf..6f965f6d41 100644
--- a/main/py-munkres/APKBUILD
+++ b/main/py-munkres/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Munkres algorithm for the assignment problem"
url="http://bmc.github.com/munkres/"
arch="noarch"
license="BSD"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev"
install=""
diff --git a/main/py-musicbrainzngs/APKBUILD b/main/py-musicbrainzngs/APKBUILD
index ef29ad61a5..cbf8c22be6 100644
--- a/main/py-musicbrainzngs/APKBUILD
+++ b/main/py-musicbrainzngs/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Bindings for the MusicBrainz NGS service"
url="https://github.com/alastair/python-musicbrainzngs"
arch="noarch"
license="BSD"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-mysqldb/APKBUILD b/main/py-mysqldb/APKBUILD
index d4f8bb82fb..3e97557906 100644
--- a/main/py-mysqldb/APKBUILD
+++ b/main/py-mysqldb/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="MySQL database connector for Python (legacy version)"
url="https://github.com/farcepest/MySQLdb1"
arch="all"
license="GPL"
-depends="python"
+depends="python2"
depends_dev="mariadb-dev"
makedepends="$depends_dev python2-dev py-setuptools"
install=""
diff --git a/main/py-nose/APKBUILD b/main/py-nose/APKBUILD
index 601b887229..ca0a566d06 100644
--- a/main/py-nose/APKBUILD
+++ b/main/py-nose/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A Python unittest module"
url="http://readthedocs.org/docs/nose/"
arch="noarch"
license="LGPL2+"
-depends="python py-setuptools"
+depends="python2 py-setuptools"
depends_dev=""
makedepends="python2-dev"
install=""
diff --git a/main/py-oauth2/APKBUILD b/main/py-oauth2/APKBUILD
index 08a729a1e5..cd2b1cfa44 100644
--- a/main/py-oauth2/APKBUILD
+++ b/main/py-oauth2/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A Python library for OAuth"
url="https://github.com/simplegeo/python-oauth2"
arch="noarch"
license="MIT"
-depends="python py-httplib2"
+depends="python2 py-httplib2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-oauth2client/APKBUILD b/main/py-oauth2client/APKBUILD
index 31098abf44..7e4f335d38 100644
--- a/main/py-oauth2client/APKBUILD
+++ b/main/py-oauth2client/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="A client library for OAuth 2.0"
url="https://github.com/google/oauth2client"
arch="noarch"
license="Apache"
-depends="python py-asn1 py-httplib2 py-asn1-modules py-rsa py-six"
+depends="python2 py-asn1 py-httplib2 py-asn1-modules py-rsa py-six"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-parsing/APKBUILD b/main/py-parsing/APKBUILD
index b03f8ee788..4b6e69440c 100644
--- a/main/py-parsing/APKBUILD
+++ b/main/py-parsing/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="An object-oriented approach to text processing"
url="http://pyparsing.wikispaces.com/"
arch="noarch"
license="MIT"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-pbr/APKBUILD b/main/py-pbr/APKBUILD
index 523be176ed..b3472c504e 100644
--- a/main/py-pbr/APKBUILD
+++ b/main/py-pbr/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Python Build Reasonableness"
url="https://pypi.python.org/pypi/pbr"
arch="noarch"
license="APACHE2.0"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="$depends_dev python2-dev py-setuptools"
install=""
diff --git a/main/py-pep8/APKBUILD b/main/py-pep8/APKBUILD
index 164912e0ac..3b80a9961a 100644
--- a/main/py-pep8/APKBUILD
+++ b/main/py-pep8/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A Python style guide checker"
url="https://pypi.python.org/pypi/pep8/"
arch="noarch"
license="MIT"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-phonenumbers/APKBUILD b/main/py-phonenumbers/APKBUILD
index 564a5d6aac..6d6d36c114 100644
--- a/main/py-phonenumbers/APKBUILD
+++ b/main/py-phonenumbers/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="International phone number library for Python"
url=https://github.com/daviddrysdale/python-phonenumbers
arch="noarch"
license="ASL 2.0"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-pillow/APKBUILD b/main/py-pillow/APKBUILD
index 915cc52627..c4b95060e8 100644
--- a/main/py-pillow/APKBUILD
+++ b/main/py-pillow/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A Python Imaging Library"
url="http://python-pillow.org/"
arch="all"
license="PSF"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools freetype-dev jpeg-dev libwebp-dev tiff-dev
libpng-dev lcms2-dev openjpeg-dev zlib-dev"
diff --git a/main/py-purl/APKBUILD b/main/py-purl/APKBUILD
index fb6acec437..490c7db3c8 100644
--- a/main/py-purl/APKBUILD
+++ b/main/py-purl/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="An immutable Python URL class for easy URL-building and manipulation"
url="https://github.com/codeinthehole/purl"
arch="noarch"
license="MIT"
-depends="python py-six"
+depends="python2 py-six"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-pygments/APKBUILD b/main/py-pygments/APKBUILD
index 0cc2bcb5db..0f36ab64c6 100644
--- a/main/py-pygments/APKBUILD
+++ b/main/py-pygments/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A syntax highlighting package written in Python."
url="http://pygments.org/"
arch="noarch"
license="BSD"
-depends="python py-setuptools"
+depends="python2 py-setuptools"
makedepends=""
install=""
subpackages="$pkgname-doc"
diff --git a/main/py-pylast/APKBUILD b/main/py-pylast/APKBUILD
index 9219ecfd81..dbb49e6461 100644
--- a/main/py-pylast/APKBUILD
+++ b/main/py-pylast/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="A Python interface to the last.fm API"
url="https://github.com/pylast/pylast"
arch="noarch"
license="Apache"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-redis/APKBUILD b/main/py-redis/APKBUILD
index 0bea56206c..0042582647 100644
--- a/main/py-redis/APKBUILD
+++ b/main/py-redis/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Python client for Redis key-value store"
url="https://github.com/andymccurdy/redis-py"
arch="noarch"
license="MIT"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-roman/APKBUILD b/main/py-roman/APKBUILD
index a55df70335..5853c81b6f 100644
--- a/main/py-roman/APKBUILD
+++ b/main/py-roman/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Integer to Roman numerals converter"
url="http://pypi.python.org/pypi/roman"
arch="noarch"
license="Python"
-depends="python"
+depends="python2"
makedepends="python2-dev py-setuptools"
install=""
subpackages=""
diff --git a/main/py-rsa/APKBUILD b/main/py-rsa/APKBUILD
index dad5affc99..5c321dfb8e 100644
--- a/main/py-rsa/APKBUILD
+++ b/main/py-rsa/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Pure-Python RSA implementation"
url="http://stuvel.eu/rsa"
arch="noarch"
license="BSD"
-depends="python py-asn1"
+depends="python2 py-asn1"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-simpleparse/APKBUILD b/main/py-simpleparse/APKBUILD
index a16827773c..6183cfb06c 100644
--- a/main/py-simpleparse/APKBUILD
+++ b/main/py-simpleparse/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Python library providing simple and fast parser generator"
url="http://launchpad.net/simpleparse"
arch="all"
license="BSD"
-depends="python"
+depends="python2"
depends_dev="python2-dev"
makedepends="$depends_dev"
install=
diff --git a/main/py-sphinx/APKBUILD b/main/py-sphinx/APKBUILD
index 0e559621a4..899c649548 100644
--- a/main/py-sphinx/APKBUILD
+++ b/main/py-sphinx/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Python Documentation Generator"
url="http://sphinx.pocoo.org/"
arch="noarch"
license="BSD"
-depends="python make py-docutils py-jinja2 py-pygments py-setuptools py2-six
+depends="python2 make py-docutils py-jinja2 py-pygments py-setuptools py2-six
py-sphinx_rtd_theme py-alabaster py-babel py-snowballstemmer
py-imagesize"
makedepends="$depends_dev"
diff --git a/main/py-templayer/APKBUILD b/main/py-templayer/APKBUILD
index fcbbe8f0c5..9947912dca 100644
--- a/main/py-templayer/APKBUILD
+++ b/main/py-templayer/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Templayer is a layered template library for Python and Django"
url="http://excess.org/templayer/"
arch="noarch"
license="LGPL"
-depends="python"
+depends="python2"
makedepends="python2-dev py-setuptools"
install=
subpackages="$pkgname-doc"
diff --git a/main/py-tracing/APKBUILD b/main/py-tracing/APKBUILD
index 67691053ce..94a0c1df7c 100644
--- a/main/py-tracing/APKBUILD
+++ b/main/py-tracing/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Debug log/trace messages"
url="http://liw.fi/tracing/"
arch="noarch"
license="GPL3+"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="py-setuptools"
install=""
diff --git a/main/py-ttystatus/APKBUILD b/main/py-ttystatus/APKBUILD
index 9b6c508c76..f5bb3ab530 100644
--- a/main/py-ttystatus/APKBUILD
+++ b/main/py-ttystatus/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Terminal progress bar and status output for command line"
url="http://liw.fi/ttystatus/"
arch="noarch"
license="GPL3+"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="py-setuptools"
install=""
diff --git a/main/py-twitter/APKBUILD b/main/py-twitter/APKBUILD
index b46c4de45a..dc42f54b38 100644
--- a/main/py-twitter/APKBUILD
+++ b/main/py-twitter/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Python wrapper around the Twitter API'"
url="https://pypi.python.org/pypi/python-twitter"
arch="noarch"
license="Apache"
-depends="python py-httplib2 py-simplejson py-oauth2 py-requests-oauthlib"
+depends="python2 py-httplib2 py-simplejson py-oauth2 py-requests-oauthlib"
depends_dev="python2-dev py-setuptools"
makedepends="$depends_dev"
install=""
diff --git a/main/py-unidecode/APKBUILD b/main/py-unidecode/APKBUILD
index 2ed3097394..4719a9c921 100644
--- a/main/py-unidecode/APKBUILD
+++ b/main/py-unidecode/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A Python ASCII transliterations of Unicode text"
url="https://pypi.python.org/pypi/Unidecode"
arch="noarch"
license="GPL2+"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-urlgrabber/APKBUILD b/main/py-urlgrabber/APKBUILD
index e93aa86b3d..818f9377ed 100644
--- a/main/py-urlgrabber/APKBUILD
+++ b/main/py-urlgrabber/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="A python module for fetching files"
url="http://urlgrabber.baseurl.org/"
arch="noarch"
license="LGPL2+"
-depends="python py-curl"
+depends="python2 py-curl"
depends_dev=""
makedepends="$depends_dev"
install=""
diff --git a/main/py-urlnorm/APKBUILD b/main/py-urlnorm/APKBUILD
index e84289d9da..9164b5accf 100644
--- a/main/py-urlnorm/APKBUILD
+++ b/main/py-urlnorm/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Normalize a URL to a standard unicode encoding"
url="https://pypi.python.org/pypi/urlnorm"
arch="noarch"
license="MIT"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-vobject/APKBUILD b/main/py-vobject/APKBUILD
index 6eca455c70..6b1dc8dc8a 100644
--- a/main/py-vobject/APKBUILD
+++ b/main/py-vobject/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Module for parsing and generating vCard and vCalendar files"
url="http://vobject.skyhouseconsulting.com"
arch="noarch"
license="Apache"
-depends="python py-dateutil py-icu"
+depends="python2 py-dateutil py-icu"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-webassets/APKBUILD b/main/py-webassets/APKBUILD
index 0ecd7666f7..a979e162d3 100644
--- a/main/py-webassets/APKBUILD
+++ b/main/py-webassets/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Asset management for web development"
url="https://pypi.python.org/pypi/webassets"
arch="noarch"
license="BSD"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/py-wtforms/APKBUILD b/main/py-wtforms/APKBUILD
index 30c0b51ba6..28bb5bdfb0 100644
--- a/main/py-wtforms/APKBUILD
+++ b/main/py-wtforms/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="A flexible forms validation and rendering Python library"
url="http://wtforms.simplecodes.com/"
arch="noarch"
license="BSD"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
diff --git a/main/pyflakes/APKBUILD b/main/pyflakes/APKBUILD
index 97e52f227a..5db20d2339 100644
--- a/main/pyflakes/APKBUILD
+++ b/main/pyflakes/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="A passive checker of Python programs"
url="https://github.com/pyflakes/pyflakes"
arch="noarch"
license="MIT"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="python2-dev"
install=""
diff --git a/main/python2/APKBUILD b/main/python2/APKBUILD
index ae98676e2a..f5889dd178 100644
--- a/main/python2/APKBUILD
+++ b/main/python2/APKBUILD
@@ -28,7 +28,7 @@ prepare() {
# make sure our /dev/shm is world writeable
if ! touch /dev/shm/$pkgname-$pkgver; then
- error "/dev/shm is not world writeable. this will cause a broken python build"
+ error "/dev/shm is not world writeable. this will cause a broken python2 build"
return 1
fi
rm /dev/shm/$pkgname-$pkgver
diff --git a/main/scons/APKBUILD b/main/scons/APKBUILD
index 4a5ed6e75c..b59b38d080 100644
--- a/main/scons/APKBUILD
+++ b/main/scons/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="scons software construction system"
url="http://www.scons.org/"
arch="noarch"
license="MIT"
-depends="python"
+depends="python2"
makedepends="python2-dev"
install=""
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
diff --git a/main/seabios/APKBUILD b/main/seabios/APKBUILD
index ee2d27916e..0a3691226e 100644
--- a/main/seabios/APKBUILD
+++ b/main/seabios/APKBUILD
@@ -8,7 +8,7 @@ arch="x86 x86_64"
license="LGPLv3"
depends="$pkgname-bin=$pkgver-r$pkgrel seavgabios-bin=$pkgver-r$pkgrel"
depends_dev=""
-makedepends="$depends_dev python iasl"
+makedepends="$depends_dev python2 iasl"
install=""
subpackages="$pkgname-bin:_seabios seavgabios-bin:_seavgabios"
source="http://code.coreboot.org/p/seabios/downloads/get/seabios-$pkgver.tar.gz
diff --git a/main/sems/APKBUILD b/main/sems/APKBUILD
index 137f2a141c..95f89b2757 100644
--- a/main/sems/APKBUILD
+++ b/main/sems/APKBUILD
@@ -157,7 +157,7 @@ gsm() {
ivr() {
pkgdesc="IVR (python) functionallity for SEMS"
- depends="sems python"
+ depends="sems python2"
cd "$pkgdir"
_mv_sub etc/sems/etc/ivr.conf \
usr/lib/sems/plug-in/ivr.so \
@@ -221,7 +221,7 @@ voicemail() {
_python() {
pkgdesc="Python bindings for SEMS"
- depends="python sems"
+ depends="python2 sems"
cd "$pkgdir"
_mv_sub \
usr/lib/sems/plug-in/py_sems*
diff --git a/main/smem/APKBUILD b/main/smem/APKBUILD
index cf7b2c6746..a01a2a5405 100644
--- a/main/smem/APKBUILD
+++ b/main/smem/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="memory reporting tool"
url="http://www.selenic.com/smem/"
arch="noarch"
license="GPL"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="$depends_dev"
install=""
diff --git a/main/speedometer/APKBUILD b/main/speedometer/APKBUILD
index bd77620703..008fbe2093 100644
--- a/main/speedometer/APKBUILD
+++ b/main/speedometer/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Measure and display the rate of data across a network connection or dat
url="http://excess.org/speedometer/"
arch="noarch"
license="LGPL"
-depends="python py-urwid"
+depends="python2 py-urwid"
makedepends=
install=
subpackages=
diff --git a/main/speedtest-cli/APKBUILD b/main/speedtest-cli/APKBUILD
index f8b8e7780b..2a5c92c15e 100644
--- a/main/speedtest-cli/APKBUILD
+++ b/main/speedtest-cli/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Command line interface for testing internet bandwidth using speedtest.n
url="https://github.com/sivel/speedtest-cli"
arch="noarch"
license="ASL 2.0"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="$depends_dev python2-dev py-setuptools"
install=""
diff --git a/main/strongswan/APKBUILD b/main/strongswan/APKBUILD
index c2fb9e4b96..f358c9dcdf 100644
--- a/main/strongswan/APKBUILD
+++ b/main/strongswan/APKBUILD
@@ -12,7 +12,7 @@ pkggroups="ipsec"
license="GPL2 RSA-MD5 RSA-PKCS11 DES"
depends="iproute2"
depends_dev=""
-makedepends="$depends_dev linux-headers python sqlite-dev libressl-dev curl-dev
+makedepends="$depends_dev linux-headers python2 sqlite-dev libressl-dev curl-dev
gmp-dev libcap-dev"
install="$pkgname.pre-install"
subpackages="$pkgname-doc $pkgname-dbg"
diff --git a/main/subunit/APKBUILD b/main/subunit/APKBUILD
index a4961fe449..340744bf62 100644
--- a/main/subunit/APKBUILD
+++ b/main/subunit/APKBUILD
@@ -6,7 +6,7 @@ pkgdesc="A streaming protocol for test results"
url="https://launchpad.net/subunit"
arch="all"
license="Apache BSD"
-depends="python"
+depends="python2"
depends_dev=""
makedepends="$depends_dev check-dev cppunit-dev perl-dev python2-dev"
install=""
diff --git a/main/subversion/APKBUILD b/main/subversion/APKBUILD
index 6a559c75f4..9f39f1edc0 100644
--- a/main/subversion/APKBUILD
+++ b/main/subversion/APKBUILD
@@ -10,7 +10,7 @@ license="apache bsd"
depends=
makedepends="apr-dev apr-util-dev expat-dev neon-dev libressl-dev zlib-dev
e2fsprogs-dev sqlite-dev apache2-dev perl-dev swig serf-dev
- python2-dev autoconf automake libtool python"
+ python2-dev autoconf automake libtool python2"
install="$pkgname.pre-install"
subpackages="$pkgname-dev $pkgname-doc mod_dav_svn
perl-$pkgname:pl py-$pkgname:py $pkgname-libs"
diff --git a/main/supervisor/APKBUILD b/main/supervisor/APKBUILD
index c69fea8cb0..b5913a1b76 100644
--- a/main/supervisor/APKBUILD
+++ b/main/supervisor/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="A system for controlling process state under UNIX"
url="http://supervisord.org"
arch="noarch"
license="BSD"
-depends="python py-meld3 py-setuptools"
+depends="python2 py-meld3 py-setuptools"
depends_dev="python2-dev"
makedepends="$depends_dev"
install=""
diff --git a/main/tdb/APKBUILD b/main/tdb/APKBUILD
index 5525c97879..58fd638058 100644
--- a/main/tdb/APKBUILD
+++ b/main/tdb/APKBUILD
@@ -7,7 +7,7 @@ url="http://tdb.samba.org/"
arch="all"
license="LGPLv3+"
depends=""
-depends_dev="python"
+depends_dev="python2"
makedepends="$depends_dev python2-dev"
install=""
subpackages="$pkgname-dev py-$pkgname:_py $pkgname-libs"
diff --git a/main/teeworlds/APKBUILD b/main/teeworlds/APKBUILD
index 86e0c9eca5..2e939240a1 100644
--- a/main/teeworlds/APKBUILD
+++ b/main/teeworlds/APKBUILD
@@ -9,7 +9,7 @@ pkgdesc='Multiplayer 2D shooter'
url='https://www.teeworlds.com'
license='custom'
depends=
-makedepends='python mesa-dev glu-dev sdl-dev freetype-dev alsa-lib-dev bam'
+makedepends="python2 mesa-dev glu-dev sdl-dev freetype-dev alsa-lib-dev bam"
subpackages="$pkgname-server $pkgname-common"
source="https://downloads.teeworlds.com/teeworlds-$pkgver-src.tar.gz"
diff --git a/main/trac/APKBUILD b/main/trac/APKBUILD
index 5c221e024d..6fc2e6f354 100644
--- a/main/trac/APKBUILD
+++ b/main/trac/APKBUILD
@@ -10,7 +10,7 @@ pkgdesc="Trac is a minimalistic web-based project management, wiki and bug/issue
url="http://trac.edgewall.com/"
arch="noarch"
license="GPL"
-depends="python py-setuptools py-genshi"
+depends="python2 py-setuptools py-genshi"
makedepends="python2-dev"
install="$pkgname.pre-install"
source="http://download.edgewall.org/trac/Trac-$pkgver.tar.gz
diff --git a/main/vde2/APKBUILD b/main/vde2/APKBUILD
index 6a017e008d..23eb7fad89 100644
--- a/main/vde2/APKBUILD
+++ b/main/vde2/APKBUILD
@@ -8,7 +8,7 @@ arch="all"
license="GPL"
depends="libressl"
install="vde2.pre-install"
-makedepends="linux-headers libressl-dev libpcap-dev python"
+makedepends="linux-headers libressl-dev libpcap-dev python2"
subpackages="$pkgname-doc $pkgname-dev $pkgname-libs"
source="http://downloads.sourceforge.net/project/vde/vde2/$pkgver/vde2-$pkgver.tar.gz
musl-build-fix.patch
diff --git a/main/virtinst/APKBUILD b/main/virtinst/APKBUILD
index 8da7f80e4d..4a2ad6806c 100644
--- a/main/virtinst/APKBUILD
+++ b/main/virtinst/APKBUILD
@@ -6,7 +6,7 @@ pkgdesc="CLI tool for provision operating systems into virtual machines"
arch="noarch"
url="http://virt-manager.org/"
license="GPL2+"
-depends="libvirt python py-urlgrabber py-libxml2 py-libvirt"
+depends="libvirt python2 py-urlgrabber py-libxml2 py-libvirt"
makedepends="gettext-dev libvirt-dev python2-dev grep"
install=""
subpackages="$pkgname-doc $pkgname-lang"
diff --git a/main/vte/APKBUILD b/main/vte/APKBUILD
index 486b69845b..5a0a57f13f 100644
--- a/main/vte/APKBUILD
+++ b/main/vte/APKBUILD
@@ -9,7 +9,7 @@ license="LGPL2+"
depends=""
options="suid"
depends_dev="glib-dev pango-dev gtk+2.0-dev py-gtk-dev"
-makedepends="$depends_dev intltool python ncurses-dev"
+makedepends="$depends_dev intltool python2 ncurses-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://ftp.gnome.org/pub/GNOME/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2
allow_alt_in_terminal.patch
diff --git a/main/weechat/APKBUILD b/main/weechat/APKBUILD
index 5f83e95fa8..74b3ba0df2 100644
--- a/main/weechat/APKBUILD
+++ b/main/weechat/APKBUILD
@@ -36,8 +36,8 @@ _plugin() {
pkgdesc="WeeChat $_name plugin"
depends="weechat"
- if [ "$_name" = python ]; then
- depends="$depends python"
+ if [ "$_name" = python2 ]; then
+ depends="$depends python2"
fi
mkdir -p "$subpkgdir"/$_dir
diff --git a/main/zeromq/APKBUILD b/main/zeromq/APKBUILD
index d47d6cc632..02c99c1c27 100644
--- a/main/zeromq/APKBUILD
+++ b/main/zeromq/APKBUILD
@@ -8,7 +8,7 @@ url="http://www.zeromq.org/"
arch="all"
license="LGPLv3+ with exceptions"
depends=""
-makedepends="util-linux-dev libsodium-dev perl python asciidoc xmlto
+makedepends="util-linux-dev libsodium-dev perl python2 asciidoc xmlto
autoconf automake"
subpackages="$pkgname-dev $pkgname-doc libzmq"
source="https://github.com/zeromq/zeromq4-1/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
diff --git a/main/zfs/APKBUILD b/main/zfs/APKBUILD
index 777036b615..feb8deeb6f 100644
--- a/main/zfs/APKBUILD
+++ b/main/zfs/APKBUILD
@@ -80,7 +80,7 @@ scripts() {
utils_py() {
pkgdesc="$pkgdesc (python utils)"
- depends="python"
+ depends="python2"
mkdir -p "$subpkgdir"/usr/bin
for i in "$pkgdir"/usr/bin/*.py; do
mv $i "$subpkgdir"/usr/bin || return 1