summaryrefslogtreecommitdiffstats
path: root/non-free
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-12-05 11:27:54 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2018-12-05 19:34:17 +0100
commit8204be095a670386f7464f27f067d843db3330bd (patch)
treec19649f132d30255dbe6b758409e1392dc0b4712 /non-free
parent5b59b876d70c3ede55476f91c9c05ec51a160fca (diff)
non-free/intel-ucode: fix build and clean up license
Diffstat (limited to 'non-free')
-rw-r--r--non-free/intel-ucode/APKBUILD28
-rw-r--r--non-free/intel-ucode/LICENSE123
-rw-r--r--non-free/intel-ucode/intel-microcode2ucode.c156
3 files changed, 11 insertions, 296 deletions
diff --git a/non-free/intel-ucode/APKBUILD b/non-free/intel-ucode/APKBUILD
index 488a35e7772..82c0cef3699 100644
--- a/non-free/intel-ucode/APKBUILD
+++ b/non-free/intel-ucode/APKBUILD
@@ -6,30 +6,24 @@ pkgdesc="Microcode update files for Intel CPUs"
arch=noarch
url="https://downloadcenter.intel.com/SearchResult.aspx?lang=eng&keyword=%22microcode%22"
license="custom"
-source="https://downloadmirror.intel.com/28087/eng/microcode-$pkgver.tgz
- LICENSE
- intel-microcode2ucode.c"
+makedepens="iucode-tool"
+source="https://downloadmirror.intel.com/28087/eng/microcode-$pkgver.tgz"
options="!check"
build() {
cd "$srcdir"
- gcc -Wall ${CFLAGS} -o intel-microcode2ucode intel-microcode2ucode.c
- ./intel-microcode2ucode ./microcode.dat
+ rm -f intel-ucode/list intel-ucode-with-caveats/list
+ mkdir -p kernel/x86/microcode
+ iucode_tool -w kernel/x86/microcode/GenuineIntel.bin \
+ intel-ucode/ intel-ucode-with-caveats/
+ echo kernel/x86/microcode/GenuineIntel.bin | \
+ cpio -o -H newc -R 0:0 > intel-ucode.img
}
package() {
cd "$srcdir"
-
- install -d -m755 "$pkgdir"/boot
- mkdir -p kernel/x86/microcode
- mv microcode.bin kernel/x86/microcode/GenuineIntel.bin
-
- echo kernel/x86/microcode/GenuineIntel.bin | \
- cpio -o -H newc -R 0:0 > "$pkgdir"/boot/intel-ucode.img
-
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -D -m0644 intel-ucode.img "$pkgdir"/boot/intel-ucode.img
+ install -Dm644 license "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-sha512sums="3cd6794a5ce26e86f7b644e523ba978699316046e593da215b73b17c4b43049ac4a81636e2ce3e727d06c2efbac98657764aa3ff355edb429127585bb49a9b10 microcode-20180807a.tgz
-d80ce9087e2ffd0168600a34de195d6514d3a496bc233294cd838498e1ce668b9ad4463bbbe7958feec0421b5aed3ade1633432ce086241e03ed06bbd53b83a5 LICENSE
-ee60f968acab4067f5660449eabae533b5d3996cd59fd4b69d0e23e0b264da216ab6e6ccd554222cf355fc14dbd348562a2d36a87a60f1f54433603e04998cd1 intel-microcode2ucode.c"
+sha512sums="3cd6794a5ce26e86f7b644e523ba978699316046e593da215b73b17c4b43049ac4a81636e2ce3e727d06c2efbac98657764aa3ff355edb429127585bb49a9b10 microcode-20180807a.tgz"
diff --git a/non-free/intel-ucode/LICENSE b/non-free/intel-ucode/LICENSE
deleted file mode 100644
index c05358c0f85..00000000000
--- a/non-free/intel-ucode/LICENSE
+++ /dev/null
@@ -1,123 +0,0 @@
-INTEL SOFTWARE LICENSE AGREEMENT
-
-IMPORTANT - READ BEFORE COPYING, INSTALLING OR USING.
-Do not use or load this software and any associated materials (collectively,
-the "Software") until you have carefully read the following terms and
-conditions. By loading or using the Software, you agree to the terms of this
-Agreement. If you do not wish to so agree, do not install or use the Software.
-
-LICENSES: Please Note:
-- If you are a network administrator, the "Site License" below shall
-apply to you.
-- If you are an end user, the "Single User License" shall apply to you.
-- If you are an original equipment manufacturer (OEM), the "OEM License"
-shall apply to you.
-
-SITE LICENSE. You may copy the Software onto your organization's computers
-for your organization's use, and you may make a reasonable number of
-back-up copies of the Software, subject to these conditions:
-
-1. This Software is licensed for use only in conjunction with Intel
-component products. Use of the Software in conjunction with non-Intel
-component products is not licensed hereunder.
-2. You may not copy, modify, rent, sell, distribute or transfer any part
-of the Software except as provided in this Agreement, and you agree to
-prevent unauthorized copying of the Software.
-3. You may not reverse engineer, decompile, or disassemble the Software.
-4. You may not sublicense or permit simultaneous use of the Software by
-more than one user.
-5. The Software may include portions offered on terms in addition to those
-set out here, as set out in a license accompanying those portions.
-
-SINGLE USER LICENSE. You may copy the Software onto a single computer for
-your personal, noncommercial use, and you may make one back-up copy of the
-Software, subject to these conditions:
-
-1. This Software is licensed for use only in conjunction with Intel
-component products. Use of the Software in conjunction with non-Intel
-component products is not licensed hereunder.
-2. You may not copy, modify, rent, sell, distribute or transfer any part
-of the Software except as provided in this Agreement, and you agree to
-prevent unauthorized copying of the Software.
-3. You may not reverse engineer, decompile, or disassemble the Software.
-4. You may not sublicense or permit simultaneous use of the Software by
-more than one user.
-5. The Software may include portions offered on terms in addition to those
-set out here, as set out in a license accompanying those portions.
-
-OEM LICENSE: You may reproduce and distribute the Software only as an
-integral part of or incorporated in Your product or as a standalone
-Software maintenance update for existing end users of Your products,
-excluding any other standalone products, subject to these conditions:
-
-1. This Software is licensed for use only in conjunction with Intel
-component products. Use of the Software in conjunction with non-Intel
-component products is not licensed hereunder.
-2. You may not copy, modify, rent, sell, distribute or transfer any part
-of the Software except as provided in this Agreement, and you agree to
-prevent unauthorized copying of the Software.
-3. You may not reverse engineer, decompile, or disassemble the Software.
-4. You may only distribute the Software to your customers pursuant to a
-written license agreement. Such license agreement may be a "break-the-
-seal" license agreement. At a minimum such license shall safeguard
-Intel's ownership rights to the Software.
-5. The Software may include portions offered on terms in addition to those
-set out here, as set out in a license accompanying those portions.
-
-NO OTHER RIGHTS. No rights or licenses are granted by Intel to You, expressly
-or by implication, with respect to any proprietary information or patent,
-copyright, mask work, trademark, trade secret, or other intellectual property
-right owned or controlled by Intel, except as expressly provided in this
-Agreement.
-
-OWNERSHIP OF SOFTWARE AND COPYRIGHTS. Title to all copies of the Software
-remains with Intel or its suppliers. The Software is copyrighted and
-protected by the laws of the United States and other countries, and
-international treaty provisions. You may not remove any copyright notices
-from the Software. Intel may make changes to the Software, or to items
-referenced therein, at any time without notice, but is not obligated to
-support or update the Software. Except as otherwise expressly provided, Intel
-grants no express or implied right under Intel patents, copyrights,
-trademarks, or other intellectual property rights. You may transfer the
-Software only if the recipient agrees to be fully bound by these terms and if
-you retain no copies of the Software.
-
-LIMITED MEDIA WARRANTY. If the Software has been delivered by Intel on
-physical media, Intel warrants the media to be free from material physical
-defects for a period of ninety days after delivery by Intel. If such a defect
-is found, return the media to Intel for replacement or alternate delivery of
-the Software as Intel may select.
-
-EXCLUSION OF OTHER WARRANTIES. EXCEPT AS PROVIDED ABOVE, THE SOFTWARE IS
-PROVIDED "AS IS" WITHOUT ANY EXPRESS OR IMPLIED WARRANTY OF ANY KIND
-INCLUDING WARRANTIES OF MERCHANTABILITY, NONINFRINGEMENT, OR FITNESS FOR A
-PARTICULAR PURPOSE. Intel does not warrant or assume responsibility for the
-accuracy or completeness of any information, text, graphics, links or other
-items contained within the Software.
-
-LIMITATION OF LIABILITY. IN NO EVENT SHALL INTEL OR ITS SUPPLIERS BE LIABLE
-FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, LOST PROFITS,
-BUSINESS INTERRUPTION, OR LOST INFORMATION) ARISING OUT OF THE USE OF OR
-INABILITY TO USE THE SOFTWARE, EVEN IF INTEL HAS BEEN ADVISED OF THE
-POSSIBILITY OF SUCH DAMAGES. SOME JURISDICTIONS PROHIBIT EXCLUSION OR
-LIMITATION OF LIABILITY FOR IMPLIED WARRANTIES OR CONSEQUENTIAL OR INCIDENTAL
-DAMAGES, SO THE ABOVE LIMITATION MAY NOT APPLY TO YOU. YOU MAY ALSO HAVE
-OTHER LEGAL RIGHTS THAT VARY FROM JURISDICTION TO JURISDICTION.
-
-TERMINATION OF THIS AGREEMENT. Intel may terminate this Agreement at any time
-if you violate its terms. Upon termination, you will immediately destroy the
-Software or return all copies of the Software to Intel.
-
-APPLICABLE LAWS. Claims arising under this Agreement shall be governed by the
-laws of California, excluding its principles of conflict of laws and the
-United Nations Convention on Contracts for the Sale of Goods. You may not
-export the Software in violation of applicable export laws and regulations.
-Intel is not obligated under any other agreements unless they are in writing
-and signed by an authorized representative of Intel.
-
-GOVERNMENT RESTRICTED RIGHTS. The Software is provided with "RESTRICTED
-RIGHTS." Use, duplication, or disclosure by the Government is subject to
-restrictions as set forth in FAR52.227-14 and DFAR252.227-7013 et seq. or its
-successor. Use of the Software by the Government constitutes acknowledgment
-of Intel's proprietary rights therein. Contractor or Manufacturer is Intel
-2200 Mission College Blvd., Santa Clara, CA 95052.
diff --git a/non-free/intel-ucode/intel-microcode2ucode.c b/non-free/intel-ucode/intel-microcode2ucode.c
deleted file mode 100644
index fe410ac86ef..00000000000
--- a/non-free/intel-ucode/intel-microcode2ucode.c
+++ /dev/null
@@ -1,156 +0,0 @@
-/*
- * Convert Intel microcode.dat into a single binary microcode.bin file
- *
- * Based on code by Kay Sievers <kay.sievers@vrfy.org>
- * Changed to create a single file by Thomas Bächler <thomas@archlinux.org>
- */
-
-
-#ifndef _GNU_SOURCE
-# define _GNU_SOURCE 1
-#endif
-
-#include <stdio.h>
-#include <unistd.h>
-#include <stdlib.h>
-#include <string.h>
-#include <time.h>
-#include <limits.h>
-#include <stdbool.h>
-#include <inttypes.h>
-#include <fcntl.h>
-#include <errno.h>
-#include <sys/stat.h>
-
-struct microcode_header_intel {
- unsigned int hdrver;
- unsigned int rev;
- unsigned int date;
- unsigned int sig;
- unsigned int cksum;
- unsigned int ldrver;
- unsigned int pf;
- unsigned int datasize;
- unsigned int totalsize;
- unsigned int reserved[3];
-};
-
-union mcbuf {
- struct microcode_header_intel hdr;
- unsigned int i[0];
- char c[0];
-};
-
-int main(int argc, char *argv[])
-{
- const char *filename = "/lib/firmware/microcode.dat";
- FILE *f;
- char line[LINE_MAX];
- char buf[4000000];
- union mcbuf *mc;
- size_t bufsize, count, start;
- int rc = EXIT_SUCCESS;
-
- if (argv[1] != NULL)
- filename = argv[1];
-
- count = 0;
- mc = (union mcbuf *) buf;
- f = fopen(filename, "re");
- if (f == NULL) {
- printf("open %s: %m\n", filename);
- rc = EXIT_FAILURE;
- goto out;
- }
-
- while (fgets(line, sizeof(line), f) != NULL) {
- if (sscanf(line, "%x, %x, %x, %x",
- &mc->i[count],
- &mc->i[count + 1],
- &mc->i[count + 2],
- &mc->i[count + 3]) != 4)
- continue;
- count += 4;
- }
- fclose(f);
-
- bufsize = count * sizeof(int);
- printf("%s: %lu(%luk) bytes, %zu integers\n",
- filename,
- bufsize,
- bufsize / 1024,
- count);
-
- if (bufsize < sizeof(struct microcode_header_intel))
- goto out;
-
- f = fopen("microcode.bin", "we");
- if (f == NULL) {
- printf("open microcode.bin: %m\n");
- rc = EXIT_FAILURE;
- goto out;
- }
-
- start = 0;
- for (;;) {
- size_t size;
- unsigned int family, model, stepping, type;
- unsigned int year, month, day;
-
- mc = (union mcbuf *) &buf[start];
-
- if (mc->hdr.totalsize)
- size = mc->hdr.totalsize;
- else
- size = 2000 + sizeof(struct microcode_header_intel);
-
- if (mc->hdr.ldrver != 1 || mc->hdr.hdrver != 1) {
- printf("unknown version/format:\n");
- rc = EXIT_FAILURE;
- break;
- }
-
- /*
- * 0- 3 stepping
- * 4- 7 model
- * 8-11 family
- * 12-13 type
- * 16-19 extended model
- * 20-27 extended family
- */
- stepping = mc->hdr.sig & 0x0f;
- model = (mc->hdr.sig >> 4) & 0x0f;
- family = (mc->hdr.sig >> 8) & 0x0f;
- type = (mc->hdr.sig >> 12) & 0x0f;
- if (family == 0x06)
- model += ((mc->hdr.sig >> 16) & 0x0f) << 4;
- if (family == 0x0f)
- family += (mc->hdr.sig >> 20) & 0xff;
-
- year = mc->hdr.date & 0xffff;
- month = mc->hdr.date >> 24;
- day = (mc->hdr.date >> 16) & 0xff;
-
- printf("\n");
- printf("signature: 0x%02x (stepping %d, model %d, family %d, type %d)\n",
- mc->hdr.sig, stepping, model, family, type);
- printf("flags: 0x%02x\n", mc->hdr.pf);
- printf("revision: 0x%02x\n", mc->hdr.rev);
- printf("date: %04x-%02x-%02x\n", year, month, day);
- printf("size: %zu\n", size);
-
- if (fwrite(mc, size, 1, f) != 1) {
- printf("write microcode.bin: %m\n");
- rc = EXIT_FAILURE;
- goto out;
- }
-
- start += size;
- if (start >= bufsize)
- break;
- }
- fclose(f);
- printf("\n");
-out:
- return rc;
-}