aboutsummaryrefslogtreecommitdiffstats
path: root/rebuild-alpine.sh
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2011-03-01 02:00:55 +0000
committerAndrew Manison <amanison@anselsystems.com>2011-10-03 09:16:07 +0000
commit5ea7b2db97d7477d14e7c2f19fd0cce3566a92e7 (patch)
tree9a911144419f6756073bfc127a962e2975a1f2c0 /rebuild-alpine.sh
parent156496e672265c6cd1efc67111356c34379b4ef4 (diff)
rebuild-alpine: Fixed extraction of email address for maintainer
Diffstat (limited to 'rebuild-alpine.sh')
-rwxr-xr-xrebuild-alpine.sh6
1 files changed, 3 insertions, 3 deletions
diff --git a/rebuild-alpine.sh b/rebuild-alpine.sh
index cb4c2745254..c93e4b6c1fc 100755
--- a/rebuild-alpine.sh
+++ b/rebuild-alpine.sh
@@ -37,11 +37,11 @@ build () {
else
echo "Package $1/$p failed to build (output in $rootdir/$1_$p.txt)"
if [ -n "$mail" ] ; then
- maintainer=$(grep Maintainer APKBUILD | cut -d " " -f 3-)
+ maintainer=$(grep Maintainer APKBUILD | cut -d " " -f 3- | sed 's/.*< *//;s/ *>.*//;' )
if [ -n "$maintainer" ] ; then
- recipients="'$maintainer' -cc dev@lists.alpinelinux.org"
+ recipients="$maintainer -cc alpine-devel@lists.alpinelinux.org"
else
- recipients="dev@lists.alpinelinux.org"
+ recipients="alpine-devel@lists.alpinelinux.org"
fi
if [ -n "$mail" ] ; then
echo "sending mail to [$recipients]"