aboutsummaryrefslogtreecommitdiffstats
path: root/testing/acme.sh/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-27 04:37:34 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-28 16:55:54 +0000
commit70054dac10685a139465345317532bf8f44ca660 (patch)
tree35448ffacd893037815c21cdce0614e7e690e38a /testing/acme.sh/APKBUILD
parent3aa33d6d47aa2fa396a5bcfe1215d8c90eace256 (diff)
testing/acme.sh: add missing openssl dependency
- Removed check() and build() functions that do nothing - added options="!check" Closes GH-7373
Diffstat (limited to 'testing/acme.sh/APKBUILD')
-rw-r--r--testing/acme.sh/APKBUILD16
1 files changed, 3 insertions, 13 deletions
diff --git a/testing/acme.sh/APKBUILD b/testing/acme.sh/APKBUILD
index 505872c302d..19f480e4162 100644
--- a/testing/acme.sh/APKBUILD
+++ b/testing/acme.sh/APKBUILD
@@ -2,27 +2,17 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=acme.sh
pkgver=2.8.0
-pkgrel=0
+pkgrel=1
pkgdesc="An ACME Shell script, an acme client alternative to certbot"
+options="!check" # No testsuite
url="https://github.com/Neilpang/acme.sh"
arch="noarch"
license="GPL-3.0"
-depends="curl"
+depends="curl cmd:openssl"
source="$pkgname-$pkgver.tar.gz::https://github.com/Neilpang/acme.sh/archive/$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
-build() {
- cd "$builddir"
- return 0
-}
-
-check() {
- cd "$builddir"
- return 0
-}
-
package() {
- cd "$builddir"
install -dm755 "$pkgdir"/usr/share/acme.sh/deploy
install -dm755 "$pkgdir"/usr/share/acme.sh/dnsapi
install -dm755 "$pkgdir"/usr/bin