aboutsummaryrefslogtreecommitdiffstats
path: root/testing/advancecomp
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-05-02 18:37:55 +0200
committerFrancesco Colista <fcolista@alpinelinux.org>2018-05-08 06:58:20 +0000
commit0e2909f56ff7a51f74bbe7f1acddff1cabe6a757 (patch)
treef3aece32a28557e5ad85e7eef117f5a39ac85b62 /testing/advancecomp
parent1e108e867674ffe06cf723713a8e2f091fbe2948 (diff)
testing/advancecomp: new aport
Diffstat (limited to 'testing/advancecomp')
-rw-r--r--testing/advancecomp/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/advancecomp/APKBUILD b/testing/advancecomp/APKBUILD
new file mode 100644
index 00000000000..227476646b5
--- /dev/null
+++ b/testing/advancecomp/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=advancecomp
+pkgver=2.1
+pkgrel=0
+pkgdesc="A collection of recompression utilities for your .ZIP archives, .PNG snapshots, .MNG video clips and .GZ files"
+url="https://www.advancemame.it/"
+arch="all"
+license="GPL-3.0"
+makedepends="automake autoconf libtool zlib-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/amadvance/advancecomp/archive/v$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ autoreconf -vif
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="9789e2abfc17a1630efcb15c04c8806edfd8ca074f19f53476c9f4057287a661de2cb386ad6c81c0112c127ac1283cc6b3162c15765d3b4623c800ce2d240cbc advancecomp-2.1.tar.gz"