aboutsummaryrefslogtreecommitdiffstats
path: root/testing/afl/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-05-02 23:34:47 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-05-02 23:38:31 +0200
commitc77214bb493941bbe93a1a97a2a89a96b77f7e60 (patch)
tree8772233226d5a7437f5266aea76ecfe5abf5c051 /testing/afl/APKBUILD
parent73233acb7aefbd6ded31ae04498b10e2dbd373b8 (diff)
testing/afl: fix error during strip process on non intel platforms
Diffstat (limited to 'testing/afl/APKBUILD')
-rw-r--r--testing/afl/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/testing/afl/APKBUILD b/testing/afl/APKBUILD
index 443666117db..b0970618049 100644
--- a/testing/afl/APKBUILD
+++ b/testing/afl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Marian <m.buschsieweke@uni-muenster.de>
pkgname=afl
pkgver=2.41b
-pkgrel=0
+pkgrel=1
pkgdesc="American fuzzy lop - a fuzzer relying on genetic algorithms instead brute force"
url="http://lcamtuf.coredump.cx/afl/"
arch="all"
@@ -32,9 +32,12 @@ package() {
rm -f "$pkgdir/usr/bin/afl-clang" "$pkgdir/usr/bin/afl-clang++" \
"$pkgdir/usr/bin/afl-gcc" "$pkgdir/usr/bin/afl-g++"
- if [ "$CARCH" = "ppc64le" ]; then
- rm -f "$pkgdir"/usr/share/afl/testcases/others/elf/small_exec.elf
- fi
+ # small_exec.elf is an Intel binary which causes an error during
+ # the strip() process on non Intel plattforms.
+ case "$CARCH" in
+ x86*) ;;
+ *) rm -f "$pkgdir"/usr/share/afl/testcases/others/elf/small_exec.elf ;;
+ esac
}
sha512sums="e1af6e6c4dedcc3f7f17857bf45a2efeb64bdc51633003c5bd700c51eb30c72f1f4e7fed5f6570ec98ccbd22b54dbcf08cc3faec4d28004fe0fa863a4d7ea90f afl-2.41b.tgz"