aboutsummaryrefslogtreecommitdiffstats
path: root/testing/arc-theme
diff options
context:
space:
mode:
authorSascha Paunovic <azarus@posteo.net>2018-06-28 15:21:46 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-07-11 13:29:56 +0000
commit95a40fbca282b64504a81f24e67c6a72ddcea12b (patch)
tree1923b42f24c7d94dd6f0ea520fe9661ece1f9405 /testing/arc-theme
parent463511b847a5ea9078b85aa0749e5e3b43161e71 (diff)
testing/arc-theme: improve abuild
also take maintainership
Diffstat (limited to 'testing/arc-theme')
-rw-r--r--testing/arc-theme/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/testing/arc-theme/APKBUILD b/testing/arc-theme/APKBUILD
index af9a3f62283..a23481810a2 100644
--- a/testing/arc-theme/APKBUILD
+++ b/testing/arc-theme/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
+# Maintainer: Sascha Paunovic <azarus@posteo.net>
pkgname=arc-theme
pkgver=20170302
pkgrel=0
@@ -9,10 +9,9 @@ arch="noarch"
license="GPL-3.0"
depends="gtk-murrine-engine"
makedepends="automake autoconf libtool gtk+3.0-dev"
-install=""
-subpackages=""
source="arc-theme-$pkgver.tar.gz::https://github.com/horst3180/arc-theme/archive/$pkgver.tar.gz"
-builddir="$srcdir/arc-theme-$pkgver"
+options="!check" # no test suite
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -29,13 +28,12 @@ build() {
--disable-cinnamon \
--disable-gnome-shell \
--disable-metacity \
- return 1
- make || return 1
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
sha512sums="99408a7c4db2bd2d81453e308ae5d9bc9bfda4f11e57191936f985de2937debff76c4d1f37a97ac8f5ad3751401ee8ad02457e4558b9c4aedc2bfeba1736ef03 arc-theme-20170302.tar.gz"