aboutsummaryrefslogtreecommitdiffstats
path: root/testing/attr/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-27 15:29:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-27 15:29:49 +0000
commitc155a2f0e978c28be3ce7d9786260f5cb9415fbb (patch)
tree71fe786d7afd62cb11fdede7ec21dcea73ea8eb2 /testing/attr/APKBUILD
parent01ee2e7d672a01d93bee57c4185e347a4487559a (diff)
testing/attr: new aport
Extended attribute support library for ACL support http://oss.sgi.com/projects/xfs/
Diffstat (limited to 'testing/attr/APKBUILD')
-rw-r--r--testing/attr/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/attr/APKBUILD b/testing/attr/APKBUILD
new file mode 100644
index 00000000000..bc8e46ce01a
--- /dev/null
+++ b/testing/attr/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=attr
+pkgver=2.4.43
+_ver=2.4.43-1
+pkgrel=0
+pkgdesc="Extended attribute support library for ACL support"
+url="http://oss.sgi.com/projects/xfs/"
+license="LGPL"
+depends=
+makedepends="libtool autoconf automake bash gzip"
+subpackage="$pkgname-dev $pkgname-doc"
+source="ftp://oss.sgi.com/projects/xfs/cmd_tars/${pkgname}_$_ver.tar.gz"
+
+build() {
+ cd "$srcdir"/attr-$pkgver
+ sed -i -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
+ include/builddefs.in
+
+ autoconf || return 1
+
+ unset PLATFORM #184564
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+
+ ./configure \
+ --prefix=/ \
+ --exec-prefix=/ \
+ --sbindir=/bin \
+ --bindir=/usr/bin \
+ --libdir=/lib \
+ --libexecdir=/usr/lib \
+ --enable-lib64=yes \
+ --includedir=/usr/include \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share \
+ --disable-gettext || return 1
+ make LIBTOOL="libtool --tag=CC" || return 1
+}
+
+package() {
+ cd "$srcdir"/attr-$pkgver
+ make DIST_ROOT="$pkgdir" install install-lib install-dev
+ # provided by man-pages
+ rm -fr "$pkgdir"/usr/share/man/man2
+}
+md5sums="91583a14bcbd637adaa9b07ea49c5d4b attr_2.4.43-1.tar.gz"