aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bat
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-08-30 20:58:36 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-08-30 19:05:48 -0300
commitce2d0b4860542af3072b9822dbc73dfb2fb23d76 (patch)
tree53de6e25c94fa6c0db750d6f9f3131ecf18b9c1f /testing/bat
parentc085bea2e4155db3b3720481b93addffbefa30d3 (diff)
testing/bat: enable on arches supported by rust >= 1.37.0-r0
* Remove uneccesary `export RUSTFLAGS="-C target-feature=-crt-static"`, which is disabled by default anyway
Diffstat (limited to 'testing/bat')
-rw-r--r--testing/bat/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/testing/bat/APKBUILD b/testing/bat/APKBUILD
index b72e11d2b6b..ad2be91834e 100644
--- a/testing/bat/APKBUILD
+++ b/testing/bat/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.11.0
pkgrel=1
pkgdesc="A cat(1) clone with wings"
url="https://github.com/sharkdp/bat"
-arch="x86_64" # limited by rust/cargo
+arch="x86_64 x86 armhf armv7 aarch64 ppc64le" # limited by rust/cargo
license="Apache-2.0"
depends="less" # Required for RAW-CONTROL-CHARS
makedepends="cargo"
@@ -13,9 +13,16 @@ subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/sharkdp/bat/archive/v$pkgver.tar.gz"
export CARGO_HOME="$srcdir"/cargo
-export RUSTFLAGS="-C target-feature=-crt-static"
build() {
+ # libminiz_sys fails to build otherwise
+ case "$CARCH" in
+ x86)
+ export CFLAGS="$CFLAGS -fno-stack-protector"
+ ;;
+ esac
+
+
cargo build \
--release \
--verbose