aboutsummaryrefslogtreecommitdiffstats
path: root/testing/borgmatic/APKBUILD
diff options
context:
space:
mode:
authorJustin Berthault <justin.berthault@zaclys.net>2020-05-17 05:45:19 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-07-08 16:49:26 +0000
commit5bb524d0216e63f1a4836e651546eba735375143 (patch)
tree0276e9449c0e0c36dfad836c541840d708efc1cc /testing/borgmatic/APKBUILD
parentb6c776a73f70123a53fb8cc87a6b723be3b37a46 (diff)
testing/borgmatic: upgrade to 1.5.8
Diffstat (limited to 'testing/borgmatic/APKBUILD')
-rw-r--r--testing/borgmatic/APKBUILD25
1 files changed, 20 insertions, 5 deletions
diff --git a/testing/borgmatic/APKBUILD b/testing/borgmatic/APKBUILD
index 6e602b138f4..eacaf9a4576 100644
--- a/testing/borgmatic/APKBUILD
+++ b/testing/borgmatic/APKBUILD
@@ -1,15 +1,29 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=borgmatic
-pkgver=1.5.3
+pkgver=1.5.8
pkgrel=0
pkgdesc="Simple, configuration-driven backup software for servers and workstations"
url="https://torsion.org/borgmatic/"
arch="noarch !s390x !mips !mips64" # limited by borgbackup
license="GPL-3.0-or-later"
-depends="borgbackup python3 py3-setuptools py3-pykwalify py3-requests py3-ruamel.yaml py3-colorama"
-checkdepends="py3-pytest py3-pytest-cov py3-flexmock"
-source="$pkgname-$pkgver.tar.gz::https://projects.torsion.org/witten/borgmatic/archive/$pkgver.tar.gz"
+depends="
+ borgbackup
+ python3
+ py3-setuptools
+ py3-pykwalify
+ py3-requests
+ py3-ruamel.yaml
+ py3-colorama
+ "
+checkdepends="
+ py3-pytest
+ py3-pytest-cov
+ py3-flexmock
+ "
+source="$pkgname-$pkgver.tar.gz::https://projects.torsion.org/witten/borgmatic/archive/$pkgver.tar.gz
+ fix-test-failure.patch
+ "
builddir="$srcdir/borgmatic"
build() {
@@ -25,4 +39,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
}
-sha512sums="aec949b00009893e90cd52a8d0cc18e7196581674390385293d2869f542f01016f676bbea08c74190132ca769b8dede8c4ac29bbd90a96a8a428425330c70a10 borgmatic-1.5.3.tar.gz"
+sha512sums="ac39aeaf4467fd387f7479c338b8ac78db12f6d0254c8b94dc72dd77e44c3a4b0e5550ae22594cefa8e7e069cdc8847b5b632466965a377be227014fe90710fb borgmatic-1.5.8.tar.gz
+d9a211ad30bf71364f7732e0558ebcb310b084938a47107ada4234943e9fdc8829e13a2459147bf789172bdd12e7a4b7199bd42ce03311e21275a41cb9b09eb1 fix-test-failure.patch"