summaryrefslogtreecommitdiffstats
path: root/testing/clisp
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-04-05 18:17:11 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-04-05 21:56:49 +0200
commit4a113e5c2ac66793cca51d1c5a480268f7ca1a0b (patch)
tree34506b9c80f97053c7ba690fff8d911c0bcb6c70 /testing/clisp
parentc6e2417092c56aa824ba44fa97b7db220cf83e36 (diff)
testing/clisp: move from unmaintained
Diffstat (limited to 'testing/clisp')
-rw-r--r--testing/clisp/APKBUILD52
-rw-r--r--testing/clisp/no-page.h.patch12
2 files changed, 64 insertions, 0 deletions
diff --git a/testing/clisp/APKBUILD b/testing/clisp/APKBUILD
new file mode 100644
index 00000000000..efaa15dc3d4
--- /dev/null
+++ b/testing/clisp/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=clisp
+pkgver=2.49
+pkgrel=2
+pkgdesc="ANSI Common Lisp interpreter, compiler and debugger"
+url="http://clisp.cons.org/"
+arch="x86 x86_64"
+license="GPL"
+depends=""
+depends_dev="libsigsegv-dev ffcall ncurses-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
+ no-page.h.patch"
+
+builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ default_prepare || return 1
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$builddir"
+ ulimit -s 16384
+
+ _configure="--prefix=/usr \
+ --with-ffcall \
+ --with-dynamic-ffi \
+ --without-dynamic-modules \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info"
+ ./configure $_configure || return 1
+
+ cd src
+ ./makemake $_configure > Makefile
+ make -j1 || return 1
+}
+
+package() {
+ cd "$builddir"/src
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="1962b99d5e530390ec3829236d168649 clisp-2.49.tar.bz2
+a8456d6a45340e091055b58c306022ef no-page.h.patch"
+sha256sums="8132ff353afaa70e6b19367a25ae3d5a43627279c25647c220641fed00f8e890 clisp-2.49.tar.bz2
+2d3bd8dde82e5cdf0a3825a0b67df110e20e19541308509d1165029c589b3d0a no-page.h.patch"
+sha512sums="eef66fc85199a2c283b616db61bf67ff103eeb0f19fa907da48994dc790b6f5f8d0c74fb3bd723c6b827c0ff3cfd89fa6ba67934fc669ed5d5249044b5140d81 clisp-2.49.tar.bz2
+86273c5d5d05a8d41ab6311192e0c757d3f7fe4d78546590830aa00f8c2f170fcb08f66ea739ae8834cec00cdf0f6a20824eb6a3d0f6df97be405c26b1cc5d39 no-page.h.patch"
diff --git a/testing/clisp/no-page.h.patch b/testing/clisp/no-page.h.patch
new file mode 100644
index 00000000000..aafb98a31e7
--- /dev/null
+++ b/testing/clisp/no-page.h.patch
@@ -0,0 +1,12 @@
+--- a/src/unix.d
++++ b/src/unix.d
+@@ -135,9 +135,6 @@
+ #ifdef UNIX_AUX
+ #include <sys/mmu.h> /* for SHMLBA */
+ #endif
+- #if defined(UNIX_LINUX) && !defined(UNIX_GNU)
+- #include <asm/page.h> /* for SHMLBA on Linux 2.0 */
+- #endif
+ /* <sys/shm.h> declares shmget(), shmat(), shmdt(), shmctl() */
+ #endif
+ /* used by SPVW, STREAM */