aboutsummaryrefslogtreecommitdiffstats
path: root/testing/coova-chilli/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-10-15 09:19:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-10-15 09:19:05 +0000
commitecb9d44c688c0892b0fcc2ccebbacf2981362748 (patch)
tree6e2e0cab32b1cf6fe67cebdefd130e08b013c565 /testing/coova-chilli/APKBUILD
parentf08fb9525885b169f03b0cd2684db1c3cc37fcd3 (diff)
testing/coova-chilli: new aport
CoovaChilli is an open source access controller for wireless LAN http://www.coova.org/
Diffstat (limited to 'testing/coova-chilli/APKBUILD')
-rw-r--r--testing/coova-chilli/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/coova-chilli/APKBUILD b/testing/coova-chilli/APKBUILD
new file mode 100644
index 00000000000..256475ba6bd
--- /dev/null
+++ b/testing/coova-chilli/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: grharry
+# Maintainer:
+
+# TODO: fix init.d script
+
+pkgname=coova-chilli
+pkgver=1.0.14
+pkgrel=0
+pkgdesc="CoovaChilli is an open source access controller for wireless LAN"
+url="http://www.coova.org/"
+license="GPL"
+depends=
+makedepends="perl openssl-dev autoconf automake libtool"
+install= #"coova-chilli.install"
+subpackages="$pkgname-doc $pkgname-dev"
+source="http://ap.coova.org/chilli/coova-chilli-$pkgver.tar.gz
+ coova-chilli-ssl.patch
+ "
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 -i ../coova-chilli-ssl.patch || return 1
+ aclocal && autoconf && automake && libtoolize || return 1
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var/run \
+ --libdir=/usr/lib \
+ --sysconfdir=/etc \
+ --with-openssl
+ make -j1 || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="88774ec55f9943d174ea7dd26e85fd8a coova-chilli-1.0.14.tar.gz
+e4e94b06540c10caa750a590f3ec9ec6 coova-chilli-ssl.patch"