aboutsummaryrefslogtreecommitdiffstats
path: root/testing/coregarage
diff options
context:
space:
mode:
authorrahmanshaber <rahmanshaber@yahoo.com>2019-07-29 12:03:47 +0800
committerLeo <thinkabit.ukim@gmail.com>2019-07-29 03:58:51 -0300
commit67551221d2e70b84690d6bbba604662bcd1256a2 (patch)
treee4b0231359cff660e2ed49ae4aa5eaa9e384ac50 /testing/coregarage
parent21c2de9e0ab4d4535e64aa2a9b296c0a126b30c9 (diff)
testing/coregarage: new aport
Diffstat (limited to 'testing/coregarage')
-rw-r--r--testing/coregarage/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/coregarage/APKBUILD b/testing/coregarage/APKBUILD
new file mode 100644
index 00000000000..f2957485ab1
--- /dev/null
+++ b/testing/coregarage/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
+# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
+pkgname=coregarage
+pkgver=2.6.0
+pkgrel=0
+pkgdesc="A settings manager for the CoreApps family."
+arch="all"
+url="https://gitlab.com/cubocore"
+license="GPL-2.0-only"
+depends="qt5-qtsvg"
+makedepends="qt5-qtbase-dev libcprime-dev libcsys-dev libarchive-qt-dev"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-v$pkgver"
+options="!check"
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+}
+sha512sums="625abb04b4edf7e76e7c077a2570546adfdbed81feebb55ea1cdef82afa30e559fb9bef0c0a32987fe060a1e30019d2c868d3e1055449bea6f33f36f75bb3a8e coregarage-2.6.0.tar.gz"