aboutsummaryrefslogtreecommitdiffstats
path: root/testing/csync2/APKBUILD
diff options
context:
space:
mode:
authorPablo Castorino <pcastorino@mendoza-conicet.gob.ar>2012-12-12 14:08:29 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2012-12-18 12:03:20 +0000
commit6fc7aa2d17af1ab39ee3255f46e516a851b1c8fb (patch)
treed6743d98a774516e4f51931d7567ba03da31c6aa /testing/csync2/APKBUILD
parent70da3b600b308f6623872635b66fd88c2c5d6965 (diff)
testing/csync2: upgrade to 2.0_rc1_git20121210
Diffstat (limited to 'testing/csync2/APKBUILD')
-rw-r--r--testing/csync2/APKBUILD39
1 files changed, 30 insertions, 9 deletions
diff --git a/testing/csync2/APKBUILD b/testing/csync2/APKBUILD
index 425d15cc25d..6b2ff919829 100644
--- a/testing/csync2/APKBUILD
+++ b/testing/csync2/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=csync2
-pkgver=1.34
+pkgver=2.0_rc1_git20121210
pkgrel=0
-pkgdesc="a cluster synchronization tool"
+pkgdesc="Cluster synchronization tool"
url="http://oss.linbit.com/csync2/"
arch="all"
license="GPL-2+"
@@ -10,12 +10,34 @@ depends=
makedepends="librsync-dev gnutls-dev sqlite-dev autoconf automake bison flex"
install=
subpackages="$pkgname-doc"
-source="http://oss.linbit.com/csync2/csync2-$pkgver.tar.gz
- 01-csync2-sqlite3.patch
- 02-csync2-1.34-gnutls_pkgconfig.patch
- "
+source="$pkgname-$pkgver.tar.gz
+ 03-strlcpy_disable.patch"
+# 01-csync2-sqlite3.patch
+# 02-csync2-1.34-gnutls_pkgconfig.patch
_builddir="$srcdir"/$pkgname-$pkgver
+_giturl="http://git.linbit.com/csync2.git"
+
+
+snapshot() {
+ local _pkg=$pkgname-$pkgver.tar.gz
+ mkdir -p "$srcdir"
+ cd "$srcdir"
+ msg "Creating snapshot: $_pkg"
+ rm -rf ${_giturl##*/}
+ git clone --bare $_giturl || return 1
+ git --git-dir ${_giturl##*/} archive -o $_pkg \
+ --prefix=$pkgname-$pkgver/ HEAD \
+ || return 1
+
+ msg "New snapshot: $_pkg"
+ if [ -n "$_upload" ]; then
+ msg "Uploading to $_upload"
+ scp $_pkg $_upload || return 1
+ abump $pkgname-$_tag
+ fi
+ #abuild checksum
+}
prepare() {
cd "$_builddir"
@@ -40,6 +62,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="efc8a3548996b79cef2ad76af5e93cd8 csync2-1.34.tar.gz
-35ba1bb1aafd87741c7ef55bdfb2e212 01-csync2-sqlite3.patch
-31b2ed6a7bb424ccdbf1486223eca323 02-csync2-1.34-gnutls_pkgconfig.patch"
+md5sums="9c835a405db0ab3496239ef185bc43f2 csync2-2.0_rc1_git20121210.tar.gz
+e6d8aaff70cf847b11873cd1cfaaa8f6 03-strlcpy_disable.patch"