summaryrefslogtreecommitdiffstats
path: root/testing/dc3dd
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-07-09 16:00:52 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:16 -0600
commit16e3a7663e26159b8d7d50b090d2e6333850d0a9 (patch)
tree13b17f0e39c56c916c679b16354b9fef98b079f9 /testing/dc3dd
parent4bb6ca58b6f2a1358527867e93fe20b5feb807cc (diff)
Initial APKBUILD for dc3dd
Package description: dc3dd is a patched version of GNU dd to include a number of features useful for computer forensics. Many of these features were inspired by dcfldd, but were rewritten for dc3dd. - Pattern writes. The program can write a single hexadecimal value or a text string to the output device for wiping purposes. - Piecewise and overall hashing with multiple algorithms. Supports MD5, SHA-1, SHA-256, and SHA-512. - Progress meter with automatic input/output file size probing. - Combined log for hashes and errors. - Error grouping. Produces one error message for identical sequential errors. - Verify mode. Able to hash output files and compare hashes to the acquisition hash. - Ability to split the output into chunks with numerical or alphabetic extensions. - Ability to write multiple output files simultaneuously.
Diffstat (limited to 'testing/dc3dd')
-rw-r--r--testing/dc3dd/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/dc3dd/APKBUILD b/testing/dc3dd/APKBUILD
new file mode 100644
index 00000000000..7a31ce43258
--- /dev/null
+++ b/testing/dc3dd/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=dc3dd
+pkgver=7.0.0
+pkgrel=0
+pkgdesc="Patched version of GNU dd for use in computer forensics"
+url="http://dc3dd.sourceforge.net/"
+arch="all"
+license="GPL2+ and GPL3+"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/dc3dd/dc3dd-$pkgver.tar.gz"
+_builddir="$srcdir"/dc3dd-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ rm po/*.gmo
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="37e00481273b4c4ae2ebb430e5fb80af dc3dd-7.0.0.tar.gz"