aboutsummaryrefslogtreecommitdiffstats
path: root/testing/discount
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-15 20:45:00 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-15 20:46:03 +0200
commit7a5dba72e38b4ea67b54216e490488fdf0a78714 (patch)
treef0fe360ac037256cbcba23ba0841f043f07aa516 /testing/discount
parentc3d109556a92005d3ddb06dd997c8780f5cd45c4 (diff)
testing/discount: replace fragile sed with patch
Diffstat (limited to 'testing/discount')
-rw-r--r--testing/discount/APKBUILD19
-rw-r--r--testing/discount/configure.inc.patch19
2 files changed, 27 insertions, 11 deletions
diff --git a/testing/discount/APKBUILD b/testing/discount/APKBUILD
index 87293b34781..dd8b851f62f 100644
--- a/testing/discount/APKBUILD
+++ b/testing/discount/APKBUILD
@@ -8,17 +8,11 @@ url="http://www.pell.portland.or.us/~orc/Code/discount/"
arch="all"
license="BSD"
depends="!markdown"
-depends_dev=""
makedepends=""
-install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://www.pell.portland.or.us/~orc/Code/discount/$pkgname-$pkgver.tar.bz2"
-
+source="http://www.pell.portland.or.us/~orc/Code/discount/$pkgname-$pkgver.tar.bz2
+ configure.inc.patch"
builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$builddir"
- sed -i -e 's/m 444/m 644/g' -e '1335d' configure.inc
-}
build() {
cd "$builddir"
@@ -36,6 +30,9 @@ package() {
make PREFIX=/usr DESTDIR="$pkgdir" install install.man || return 1
}
-md5sums="fc784284fbdddfa10ed394210cc16f53 discount-2.2.0.tar.bz2"
-sha256sums="b25395c29c2c08836199eb2eae87b56e6b545e77f5fbf921678aa1dc0ddab9f3 discount-2.2.0.tar.bz2"
-sha512sums="04b66496ca53a2ab73cba2a8f9d8e77efd13f318b188611aaaebc4fd036a02cd188aa712337df414ff3b7ac65d2ced17020085cae10338e8af47e5b9552d981a discount-2.2.0.tar.bz2"
+md5sums="fc784284fbdddfa10ed394210cc16f53 discount-2.2.0.tar.bz2
+03b4ae14cfe1344eba577169516a35e1 configure.inc.patch"
+sha256sums="b25395c29c2c08836199eb2eae87b56e6b545e77f5fbf921678aa1dc0ddab9f3 discount-2.2.0.tar.bz2
+7d524f06e6ede17657141b47a6da2bbc446101dc0bc9027e52e4b43820625427 configure.inc.patch"
+sha512sums="04b66496ca53a2ab73cba2a8f9d8e77efd13f318b188611aaaebc4fd036a02cd188aa712337df414ff3b7ac65d2ced17020085cae10338e8af47e5b9552d981a discount-2.2.0.tar.bz2
+d243f0b5e01cd91376fa94960e9abcdbf24d3579f7d4b5220262e867adefdc5e9ed850fe0228cc290ed605f4b42c50a5ce1ac3fb61ff191a24dc2349d16b2ff2 configure.inc.patch"
diff --git a/testing/discount/configure.inc.patch b/testing/discount/configure.inc.patch
new file mode 100644
index 00000000000..b665754150e
--- /dev/null
+++ b/testing/discount/configure.inc.patch
@@ -0,0 +1,19 @@
+--- a/configure.inc
++++ b/configure.inc
+@@ -1332,7 +1332,6 @@
+ $PROG_LN_S -f \$FULLNAME \$1/\$LIBNAME.\$MAJOR
+ $PROG_LN_S -f \$FULLNAME \$1/\$LIBNAME
+ EOF
+- test "$LDCONFIG" && echo ' '$LDCONFIG '"$1"' >> librarian.sh
+ cat >> librarian.sh << EOF
+ ;;
+ esac
+@@ -1420,7 +1419,7 @@
+
+ AC_SUB 'INSTALL' "$PROG_INSTALL"
+ AC_SUB 'INSTALL_PROGRAM' "$PROG_INSTALL -s -m 755"
+- AC_SUB 'INSTALL_DATA' "$PROG_INSTALL -m 444"
++ AC_SUB 'INSTALL_DATA' "$PROG_INSTALL -m 644"
+
+ # finally build a little directory installer
+ # if mkdir -p works, use that, otherwise use install -d,