aboutsummaryrefslogtreecommitdiffstats
path: root/testing/dolphin-emu/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-04-13 12:02:15 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-13 11:27:05 +0000
commit0895a1973f6768e397eea7d2174bf4f28a50d1fd (patch)
tree9e1c5212c101077b8c01f7e756d3dcaebed7f3d9 /testing/dolphin-emu/APKBUILD
parent65d7341d091149ee453bcca5673b8728d1b1459c (diff)
testing/dolphin-emu: upgrade to 5.0_git20200413
Diffstat (limited to 'testing/dolphin-emu/APKBUILD')
-rw-r--r--testing/dolphin-emu/APKBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/testing/dolphin-emu/APKBUILD b/testing/dolphin-emu/APKBUILD
index 9676109d917..531cbb99034 100644
--- a/testing/dolphin-emu/APKBUILD
+++ b/testing/dolphin-emu/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=dolphin-emu
-pkgver=5.0_git20200318
+pkgver=5.0_git20200413
pkgrel=0
-_commit="4711b76cc462fb8bab20c846c737b1360cde041b"
+_commit="39f107f360b22e2b3e3757136c80629c44dbfb9f"
# Upstream doesn't actively support non 64-bit platforms and they're too slow
# to emulate any games anyway
arch="x86_64 aarch64"
@@ -36,10 +36,12 @@ makedepends="
pulseaudio-dev
vulkan-headers
libxrandr-dev
+ fmt-dev
+ enet-dev
"
# The following dependencies are required, but atm not supported for using system wide libraries
# minizip-dev xxhash-dev soundtouch-dev gtest-dev
-source="$pkgname-$_commit.tar.gz::https://github.com/dolphin-emu/dolphin/archive/$_commit.tar.gz"
+source="https://github.com/dolphin-emu/dolphin/archive/$_commit/dolphin-emu-$_commit.tar.gz"
subpackages="$pkgname-doc $pkgname-lang"
builddir="$srcdir/dolphin-$_commit"
@@ -54,7 +56,6 @@ prepare() {
Bochs_disasm
FreeSurround
cpp-optparse
- fmt
glslang
imgui
xxhash
@@ -63,7 +64,6 @@ prepare() {
cubeb
gtest
picojson
- enet
"
# Move the libraries we want to keep out of the externals folder
@@ -78,23 +78,20 @@ prepare() {
for s in $KEEP_SOURCES; do
mv -v "$s" "Externals/"
done
-
- mkdir "$builddir"/build
}
build() {
- cd "$builddir"/build
- cmake "$builddir" \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_GENERATOR=Ninja \
-DUSE_DISCORD_PRESENCE=OFF \
-DUSE_SHARED_ENET=ON \
-DDISTRIBUTOR="alpinelinux.org"
- ninja
+ ninja -C build
}
check() {
+ cd build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
@@ -104,4 +101,4 @@ package() {
install -Dm 644 Data/51-usb-device.rules -t "$pkgdir"/usr/lib/udev/rules.d/
}
-sha512sums="acd3d0e2cc1858ae4a74dfebec7d3c0bfbb04b11e712266f6a3a4e19d19d4a198d1271fe47e609b97c8657e25ef7dfa6ab66975f35e390a56bd0d8317f822e77 dolphin-emu-4711b76cc462fb8bab20c846c737b1360cde041b.tar.gz"
+sha512sums="a03c4d9a3f49115ccae764b9b8bf033b8b3257a141b4dbfbc345666b1beb7fc3f684b19811f28dd97a5f8bba4e317e71fbf09f033b84e39905fc4513fe7df62a dolphin-emu-39f107f360b22e2b3e3757136c80629c44dbfb9f.tar.gz"