aboutsummaryrefslogtreecommitdiffstats
path: root/testing/drone/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-02-27 10:03:52 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-02-27 10:04:46 +0000
commit27bde63026102059c4aff7e9c3149a91f2fd9b83 (patch)
tree15202825052be9db7256102547abbec0b63dd04a /testing/drone/APKBUILD
parent2a394ee3ed6123aa559de4afc458fc6529c9b342 (diff)
testing/drone: new aport
This is a first step at adding drone to aports and is no way a finished product.
Diffstat (limited to 'testing/drone/APKBUILD')
-rw-r--r--testing/drone/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/drone/APKBUILD b/testing/drone/APKBUILD
new file mode 100644
index 00000000000..d96045ea752
--- /dev/null
+++ b/testing/drone/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer:
+pkgname=drone
+pkgver=0.9_git20190226
+pkgrel=0
+_sha=07f7fdd9830c32222db2e880a13d5fbb6ecee1a7
+pkgdesc="Container-Native, Continuous Delivery Platform"
+url="https://drone.io/"
+arch="all"
+license="custom"
+makedepends="go"
+options="!check"
+_commands="
+ $pkgname-agent:_pkg
+ $pkgname-controller:_pkg
+ $pkgname-server:_pkg
+"
+subpackages="
+ $_commands
+ $pkgname-doc
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/drone/drone/archive/$_sha.tar.gz"
+builddir="$srcdir/$pkgname-$_sha"
+
+build() {
+ cd "$builddir"
+ export GO111MODULE=on
+ for pkg in $_commands; do
+ go build -o bin/${pkg%%:*} ./cmd/${pkg%%:*}
+ done
+}
+
+package() {
+ install -Dm 644 "$builddir"/LICENSE \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+_pkg() {
+ pkgdesc="$pkgdesc ($subpkgname)"
+ install_if="$pkgname"
+ install -Dm775 "$builddir"/bin/$subpkgname \
+ "$subpkgdir"/usr/bin/$subpkgname
+}
+
+sha512sums="9278f238842bbdb988ecc950e311377aa15385c778df110e06b2452d116d7f93f49ffe663926bb7eb68313aa05a388701bdf734686835a64961302251e395208 drone-0.9_git20190226.tar.gz"