aboutsummaryrefslogtreecommitdiffstats
path: root/testing/dspam
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-04-08 22:44:45 +0000
committerBreno Leitao <breno.leitao@gmail.com>2017-04-08 22:48:35 +0000
commit47800ee3b0230ca59d1ef361bacde4d062cdf1ed (patch)
treef5958ab46d1486873065d3f79af1396f34312115 /testing/dspam
parenteaa30e47154f8d89d5fadc3304e2b59a928fd3e1 (diff)
testing/dspam: Moderning abuild
dspam APKBUILD applies the build manually instead of using the default_prepare() helper. Also using the $builddir variable.
Diffstat (limited to 'testing/dspam')
-rw-r--r--testing/dspam/APKBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/testing/dspam/APKBUILD b/testing/dspam/APKBUILD
index 3b6f1642326..f7774fb8fbf 100644
--- a/testing/dspam/APKBUILD
+++ b/testing/dspam/APKBUILD
@@ -23,19 +23,17 @@ source="http://downloads.sourceforge.net/$pkgname/$pkgname-$_ver.tar.gz
musl-fixes.patch"
+builddir="$srcdir/$pkgname-$_ver"
+
prepare() {
- cd "$srcdir"/$pkgname-$_ver
- for i in "$srcdir"/*.patch; do
- [ -f "$i" ] || continue
- msg "Applying $i"
- patch -p1 -i "$i" || return 1
- done
+ cd "$builddir"
update_config_guess || return 1
+ default_prepare || return 1
#aclocal -I m4 && libtoolize && autoconf && automake
}
build() {
- cd "$srcdir"/$pkgname-$_ver
+ cd "$builddir"
./autogen.sh || return 1
./configure --prefix=/usr \
--sysconfdir=/etc/dspam \
@@ -50,7 +48,7 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$_ver
+ cd "$builddir"
make install DESTDIR="$pkgdir"
install -Dm755 "$srcdir"/dspam.initd "$pkgdir"/etc/init.d/dspam
install -Dm644 "$srcdir"/dspam.logrotate "$pkgdir"/etc/logrotate.d/dspam