aboutsummaryrefslogtreecommitdiffstats
path: root/testing/duplicity/APKBUILD
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2010-12-15 03:48:58 -0600
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-16 10:59:04 +0000
commit10fdcd7caa1b09e87dad3aac157ac18f280ff1ef (patch)
tree802655ff3816e370b14eaa0f5fdbe93d710d4ddc /testing/duplicity/APKBUILD
parent5f3d3104b805379479a2b85f1892d6c58a29e0a2 (diff)
testing/duplicity: new aport
Diffstat (limited to 'testing/duplicity/APKBUILD')
-rw-r--r--testing/duplicity/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/duplicity/APKBUILD b/testing/duplicity/APKBUILD
new file mode 100644
index 00000000000..a380eea8582
--- /dev/null
+++ b/testing/duplicity/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Matt Smith <mcs@darkregion.net>
+# Maintainer: Matt Smith <mcs@darkregion.net>
+pkgname=duplicity
+pkgver=0.6.11
+pkgrel=0
+pkgdesc="Encrypted bandwidth-efficient backup using the rsync algorithm"
+url="http://duplicity.nongnu.org/"
+arch="x86 x86_64"
+license="GPL"
+depends="python py-boto ncftp librsync gnupg"
+makedepends="wget python-dev py-setuptools librsync-dev"
+install=
+subpackages="$pkgname-doc"
+source="https://code.launchpad.net/$pkgname/${pkgver:0:3}-series/$pkgver/+download/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir"
+}
+
+md5sums="1116be7aababa467336eac2092f66ab7 duplicity-0.6.11.tar.gz"