aboutsummaryrefslogtreecommitdiffstats
path: root/testing/eatmemory
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-01-12 13:28:57 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-01-12 13:28:57 +0000
commitd3cf1967483d1f925e59460d2aee7a9ff4747444 (patch)
tree91b95f864dfa01f23c0d124b662955fd934cc618 /testing/eatmemory
parent0881fc56b0977a60b970c68980188cdcdd8c8f25 (diff)
testing/eatmemory: new aport
Simple utility to allocate memory on a computer. Useful for testing.
Diffstat (limited to 'testing/eatmemory')
-rw-r--r--testing/eatmemory/APKBUILD40
-rw-r--r--testing/eatmemory/makefile.patch11
2 files changed, 51 insertions, 0 deletions
diff --git a/testing/eatmemory/APKBUILD b/testing/eatmemory/APKBUILD
new file mode 100644
index 00000000000..4103100f596
--- /dev/null
+++ b/testing/eatmemory/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=eatmemory
+pkgver=0.1.4
+pkgrel=0
+pkgdesc="Simple C program to allocate memory from the command line"
+url="https://github.com/julman99/eatmemory"
+arch="all"
+license="Custom"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=
+subpackages=
+source="$pkgname-$pkgver.tar.gz::https://github.com/julman99/eatmemory/archive/v$pkgver.tar.gz
+ makefile.patch
+ "
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$builddir"
+ default_prepare || return 1
+}
+
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX="$pkgdir" install || return 1
+}
+
+md5sums="9e4a35dc12be649ae2da45815b7da8bc eatmemory-0.1.4.tar.gz
+30697f50cf63cae4f1d72e3b574f63f3 makefile.patch"
+sha256sums="c4744e6b57129823b14e89f4bca39583b7ca2391ee8630c5f9b6f7217ad42cc4 eatmemory-0.1.4.tar.gz
+70d23b9ae74df6e408c4b9a7923df034d072dba6c3f0aed2f8bb2898bb524b8c makefile.patch"
+sha512sums="e2c1dfb20c050a4697a92588ad537c7784668b1dad978717a486441117f2e6c1f789ceb3bdff545354b7affceb9ff25d4d291d0499410bec68e89a91a5a4f435 eatmemory-0.1.4.tar.gz
+db1e48e71b1ce9754147c67a6ffeeae4f7e63895a5922b8213ae8ca7174bdefb552fce9c94b25891470e0daf6fd3fa86dfaf3569fa5572a31ceb15eac5b9e59e makefile.patch"
diff --git a/testing/eatmemory/makefile.patch b/testing/eatmemory/makefile.patch
new file mode 100644
index 00000000000..a838373a861
--- /dev/null
+++ b/testing/eatmemory/makefile.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,7 +2,7 @@
+ $(CC) eatmemory.c -o eatmemory
+
+ install: eatmemory
+- install -m 0755 eatmemory $(PREFIX)/usr/bin/eatmemory
++ install -D -m 0755 eatmemory $(PREFIX)/usr/bin/eatmemory
+
+ clean:
+ rm -rf *o eatmemory