summaryrefslogtreecommitdiffstats
path: root/testing/edje
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-25 15:54:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-25 15:54:28 +0000
commit3567d03ac26894e2537a32fb487ea2728b7cd421 (patch)
tree4cb32fa2b202cb63c282845a66c1e41062ac1215 /testing/edje
parentbf4fb0398fb761d5a811271186db7e0a1a16a668 (diff)
testing/edje: new aport
Enlightenment's graphical layout and animation library http://trac.enlightenment.org/e/wiki/Edje
Diffstat (limited to 'testing/edje')
-rw-r--r--testing/edje/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/edje/APKBUILD b/testing/edje/APKBUILD
new file mode 100644
index 00000000000..689977fdfb3
--- /dev/null
+++ b/testing/edje/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=edje
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Enlightenment's graphical layout and animation library"
+url="http://trac.enlightenment.org/e/wiki/Edje"
+arch="all"
+license="BSD"
+depends=
+depends_dev="lua-dev eina-dev eet-dev embryo-dev ecore-dev evas-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://download.enlightenment.org/releases/edje-$pkgver.tar.gz"
+
+_builddir="$srcdir"/edje-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="14c33c2b9d1bd36d8507d55597c77991 edje-1.0.0.tar.gz"