summaryrefslogtreecommitdiffstats
path: root/testing/envconsul
diff options
context:
space:
mode:
authorGennady Feldman <gena01@gmail.com>2016-10-25 02:45:58 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-11-15 12:38:37 +0100
commitc1116065ac463b136ec73e3892efeda5761015fc (patch)
tree0041874a4b46092a0bb4bb71802816d3db969fae /testing/envconsul
parente82a237f35e1712400ab60779ac379537f4fa4a4 (diff)
testing/envconsul: new aport
Diffstat (limited to 'testing/envconsul')
-rw-r--r--testing/envconsul/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/envconsul/APKBUILD b/testing/envconsul/APKBUILD
new file mode 100644
index 00000000000..7cba89b29bf
--- /dev/null
+++ b/testing/envconsul/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Gennady Feldman <gena01@gmail.com>
+# Maintainer:
+pkgname=envconsul
+pkgver=0.6.1
+pkgrel=0
+pkgdesc="Read and set environmental variables for processes from Consul."
+url="https://www.consul.io/"
+arch="all"
+license="MPL-2.0"
+depends=""
+makedepends="go"
+options="!strip"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ mkdir -p "$builddir/src/github.com/hashicorp"
+ ln -s "$builddir" "$builddir/src/github.com/hashicorp/$pkgname"
+ cd "$builddir/src/github.com/hashicorp/$pkgname" || return 1
+
+ GOPATH="$builddir" go build -v -o bin/$pkgname
+}
+
+package() {
+ cd "$builddir"
+
+ # Main binary
+ install -m755 -D bin/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+
+md5sums="f23dcd8e51910122ebe70a6d7612e129 envconsul-0.6.1.tar.gz"
+sha256sums="b676a12594464408e8fb64fb35f6586c5a43d7a6efc724c0e8e25dc848e3ea5f envconsul-0.6.1.tar.gz"
+sha512sums="82d0636c4437d5e620d14d86fd8f147782ec15bbbb364e398799dd021dc44da1e24926af2495ea90256e9db9482da3a6b9f8eb866debaa0af9ade0e2d7072025 envconsul-0.6.1.tar.gz"