aboutsummaryrefslogtreecommitdiffstats
path: root/testing/evolution-ews/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-17 10:57:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-17 10:59:05 +0000
commitda9f83910937ecebb6d83ad50f6426c1c309076f (patch)
tree31c12a8cd99b897a7016ddf45862625c77548411 /testing/evolution-ews/APKBUILD
parent75dac003d94e47ed243d563fd735871256325405 (diff)
testing/evolution-ews: upgrade to 3.24.1
Diffstat (limited to 'testing/evolution-ews/APKBUILD')
-rw-r--r--testing/evolution-ews/APKBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/testing/evolution-ews/APKBUILD b/testing/evolution-ews/APKBUILD
index ba44c38dfc5..468d3a5e7f3 100644
--- a/testing/evolution-ews/APKBUILD
+++ b/testing/evolution-ews/APKBUILD
@@ -2,36 +2,35 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=evolution-ews
_pkgname="EVOLUTION_EWS"
-pkgver=3.22.4
+pkgver=3.24.1
pkgrel=0
pkgdesc="MS Exchange integration through Exchange Web Services"
url="https://wiki.gnome.org/Apps/Evolution/EWS"
arch="x86 x86_64"
license="LGPL2.1"
depends="evolution"
-makedepends="libtool automake autoconf m4
- gtk-doc intltool glib-dev gettext-dev gnome-common
+makedepends="cmake
+ gtk-doc intltool glib-dev gettext-dev gnome-common
evolution-data-server-dev evolution-dev libmspack-dev"
-subpackages="$pkgname-dev $pkgname-lang"
+subpackages="$pkgname-lang"
source="$pkgname-$pkgver.tar.gz::https://github.com/GNOME/$pkgname/archive/${_pkgname}_${pkgver//./_}.tar.gz"
builddir="$srcdir/$pkgname-${_pkgname}_${pkgver//./_}"
build() {
- cd "$builddir"
- NOCONFIGURE=1 ./autogen.sh
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --libexecdir=/usr/lib/evolution \
- --disable-nls \
- --disable-static
+ mkdir -p "$builddir"/build
+ cd "$builddir"/build
+ CFLAGS="$CFLAGS -I/usr/include/gnu-libiconv" \
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ .. \
+ || return 1
make || return 1
}
package() {
- cd "$builddir"
+ cd "$builddir"/build
make DESTDIR="$pkgdir" install
}
-sha512sums="c411c9eab437949bcfa0a8541986fd5952cc39fc3d0cbebd8658b0b9b5533ef11c2fd83c87f140dcf2c7c66cab4064d852b34a3d25bd9bccc32ac9ec04df2ddd evolution-ews-3.22.4.tar.gz"
+sha512sums="7f25467e3a76346e323552a3b2dc9210d556e9cf702d81740d7b7ed8eb61552544eec8bb9fd7e926dc9323f0d93a81f1d95c35b5edf867ba58256e1973226ef0 evolution-ews-3.24.1.tar.gz"