aboutsummaryrefslogtreecommitdiffstats
path: root/testing/evolution-ews
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-02-09 15:29:12 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-02-09 15:29:18 +0000
commitaeacc77dcfc4962b8e0af6ad9b2e17400742474e (patch)
tree082d4ce0a89d005b4ece5eb74fca32858ac87250 /testing/evolution-ews
parent9e845d2399b83ad10b294373198e1964af1a7bae (diff)
testing/evolution-ews: new aport
Diffstat (limited to 'testing/evolution-ews')
-rw-r--r--testing/evolution-ews/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/evolution-ews/APKBUILD b/testing/evolution-ews/APKBUILD
new file mode 100644
index 00000000000..2c042d6736c
--- /dev/null
+++ b/testing/evolution-ews/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=evolution-ews
+_pkgname="EVOLUTION_EWS"
+pkgver=3.22.4
+pkgrel=0
+pkgdesc="MS Exchange integration through Exchange Web Services"
+url="https://wiki.gnome.org/Apps/Evolution/EWS"
+arch="all"
+license="LGPL2.1"
+depends="evolution"
+makedepends="libtool automake autoconf m4
+ gtk-doc intltool glib-dev gettext-dev gnome-common
+ evolution-data-server-dev evolution-dev libmspack-dev"
+subpackages="$pkgname-dev $pkgname-lang"
+source="$pkgname-$pkgver.tar.gz::https://github.com/GNOME/$pkgname/archive/${_pkgname}_${pkgver//./_}.tar.gz"
+builddir="$srcdir/$pkgname-${_pkgname}_${pkgver//./_}"
+
+build() {
+ cd "$builddir"
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib/evolution \
+ --disable-nls \
+ --disable-static
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="c411c9eab437949bcfa0a8541986fd5952cc39fc3d0cbebd8658b0b9b5533ef11c2fd83c87f140dcf2c7c66cab4064d852b34a3d25bd9bccc32ac9ec04df2ddd evolution-ews-3.22.4.tar.gz"