aboutsummaryrefslogtreecommitdiffstats
path: root/testing/exa/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-30 12:12:17 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-30 12:56:12 -0300
commite9e286191346b69f09a3249d995a9d2abc7d46be (patch)
tree6cf95cdca71802d558efa435a753846d9d8876fa /testing/exa/APKBUILD
parentf83062215f89973eb97a515e9bff4ed6569c49ef (diff)
testing/exa: link against zlib and libgit2
Diffstat (limited to 'testing/exa/APKBUILD')
-rw-r--r--testing/exa/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/testing/exa/APKBUILD b/testing/exa/APKBUILD
index 69db4094e25..7f7094a6038 100644
--- a/testing/exa/APKBUILD
+++ b/testing/exa/APKBUILD
@@ -2,16 +2,18 @@
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=exa
pkgver=0.9.0
-pkgrel=0
+pkgrel=1
pkgdesc="ls replacement written in Rust"
url="https://the.exa.website/"
options="!check" # Tests fail on drone-ci
arch="x86_64 armv7 armhf aarch64 x86" # Limited by cargo
license="MIT"
-makedepends="cargo cmake"
+makedepends="cargo zlib-dev libgit2-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ogham/exa/archive/v$pkgver.tar.gz"
+export LIBGIT2_SYS_USE_PKG_CONFIG=1 # Use system libgit2
+
build() {
cargo build --release
}