summaryrefslogtreecommitdiffstats
path: root/testing/exiv2/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-01-12 11:53:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-12 11:53:01 +0000
commit765bc48e81d0879543bcf63c4def2ec40236aab3 (patch)
treeb0fb269d325ee234f892de14270828ccedeefe0c /testing/exiv2/APKBUILD
parent8dff5c0fd9298d288de640f64d358652638f1253 (diff)
testing/exiv2: new aport
Exif and Iptc metadata manipulation library and tools. http://exiv2.org
Diffstat (limited to 'testing/exiv2/APKBUILD')
-rw-r--r--testing/exiv2/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/exiv2/APKBUILD b/testing/exiv2/APKBUILD
new file mode 100644
index 00000000000..b5f8343e841
--- /dev/null
+++ b/testing/exiv2/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=exiv2
+pkgver=0.21
+pkgrel=0
+pkgdesc="Exif and Iptc metadata manipulation library and tools."
+url="http://exiv2.org"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev="expat-dev zlib-dev"
+makedepends="zlib-dev expat-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.exiv2.org/exiv2-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="2caf74de59b5424996959ccea1c001fb exiv2-0.21.tar.gz"