summaryrefslogtreecommitdiffstats
path: root/testing/fabric/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-10-21 22:46:04 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:17 -0600
commit508f6804a42f7290e620876da90ba6c9e253105f (patch)
tree4b82e95192d56a367c907d07e9dadbd91ec5e85b /testing/fabric/APKBUILD
parent5a97de2d082062dce59bc6c35c2b99a764cee8f5 (diff)
Initial APKBUILD for fabric
Package description: Fabric is a Python (2.5 or higher) library and command-line tool for streamlining the use of SSH for application deployment or systems administration tasks. It provides a basic suite of operations for executing local or remote shell commands (normally or via sudo) and uploading/ downloading files, as well as auxiliary functionality such as prompting the running user for input, or aborting execution. http://www.fabfile.org
Diffstat (limited to 'testing/fabric/APKBUILD')
-rw-r--r--testing/fabric/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/fabric/APKBUILD b/testing/fabric/APKBUILD
new file mode 100644
index 00000000000..61f227001ac
--- /dev/null
+++ b/testing/fabric/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=fabric
+_pkgname=Fabric
+pkgver=1.2.2
+pkgrel=0
+pkgdesc="A simple pythonic remote deployment tool"
+url="http://www.fabfile.org"
+arch="noarch"
+license="BSD"
+depends="py-paramiko"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/F/$_pkgname/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="f234678d3886a0b224945281395fdbda Fabric-1.2.2.tar.gz"