aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fastd/APKBUILD
diff options
context:
space:
mode:
authorJohannes Matheis <jomat+alpinebuild@jmt.gr>2015-02-08 13:25:10 +0000
committerTimo Teräs <timo.teras@iki.fi>2015-02-09 08:50:18 +0200
commit93bf317ffed831452c69550b0179e2ded06aac7b (patch)
treeef91836c54fd3cfdd0a2adf4fe28791131fe9cb8 /testing/fastd/APKBUILD
parent706bcdda878579d42b4ec845892e2c2ee589611b (diff)
testing/fastd: new aport
Fast and Secure Tunneling Daemon https://projects.universe-factory.net/projects/fastd [tteras: fixed dependencies]
Diffstat (limited to 'testing/fastd/APKBUILD')
-rw-r--r--testing/fastd/APKBUILD63
1 files changed, 63 insertions, 0 deletions
diff --git a/testing/fastd/APKBUILD b/testing/fastd/APKBUILD
new file mode 100644
index 00000000000..1df56388b26
--- /dev/null
+++ b/testing/fastd/APKBUILD
@@ -0,0 +1,63 @@
+# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+pkgname=fastd
+pkgver=17
+pkgrel=0
+pkgdesc="Fast and Secure Tunneling Daemon"
+url="https://projects.universe-factory.net/projects/fastd"
+arch="all"
+license="BSD"
+depends=""
+depends_dev="bsd-compat-headers linux-headers libsodium-dev libcap-dev
+ libuecc-dev json-c-dev"
+makedepends="$depends_dev cmake doxygen bison"
+install=""
+subpackages="$pkgname-doc"
+source="http://git.universe-factory.net/${pkgname}/snapshot/${pkgname}-${pkgver}.tar
+ fastd.conf
+ fastd.initd"
+
+_builddir="$srcdir/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ mkdir build
+ cd build
+ cmake \
+ -D CMAKE_AR=/usr/bin/ar \
+ -D CMAKE_RANLIB=/usr/bin/ranlib \
+ -D CMAKE_NM=/usr/bin/nm \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D ENABLE_SYSTEMD=OFF \
+ ..
+ make
+}
+
+package() {
+ cd "$_builddir/build"
+ make install DESTDIR="${pkgdir}"
+ install -Dm644 "$srcdir/${pkgname}-${pkgver}/COPYRIGHT" "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
+ install -Dm644 "$srcdir/${pkgname}-${pkgver}/doc/fastd.1" "${pkgdir}/usr/share/man/man1/fastd.1"
+ install -D -m600 ${srcdir}/fastd.conf "${pkgdir}"/etc/fastd/fastd.conf
+ install -D -m755 ${srcdir}/fastd.initd "${pkgdir}"/etc/init.d/fastd
+ install -d -m700 "${pkgdir}"/etc/fastd/peers/
+}
+
+md5sums="40c9efd2c7eaba42b9b93add4a462b17 fastd-17.tar
+383a11cb8d804e6d91c2c66eb07b4246 fastd.conf
+f9516c8219b304ddb3ab5dc205e82937 fastd.initd"
+sha256sums="20390fc2110929ebf37feebe1bcce68d7920a5efd42c369bd2d886c6781966dc fastd-17.tar
+6c7821e9c6b85ee2baf2d5e2e7b1eb28d3ceebe876e3cb6686b3c1cb6649db68 fastd.conf
+dfc473baee3b7e1e509131010dc3d0a1b62bc7c684cc54daca1a91255e4a0dd2 fastd.initd"
+sha512sums="152e9b6a2df39375061aedee2e2ac586916ae634cd57ee8902f152d86a27db5d6353f411e038139721073caf35696c349aed2c09165578d81fe47daebead18e8 fastd-17.tar
+3e6c3a77f93a1e670e8f018833c499e8ec57b8240a6f472da03254ad9a7e6fed2c3459fa47b06c97e42afcfe6f0adfaaec39bce6b6a286a1ce7ef3585853b118 fastd.conf
+c0fff880384aa35e9d1d84ce98b2a103f1e974dfa54a29a65d7f0ff7d6e4b88d7afa51f0c1025b68078885d310f3a7a1d941149ec49025675d23310597c55906 fastd.initd"