summaryrefslogtreecommitdiffstats
path: root/testing/firefox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-09-01 08:44:50 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-09-01 11:34:22 +0200
commit8aad5847f94c2b06580d60784f97e393b57ce120 (patch)
tree1d0e4dcb6cd97bddacd3f9640c98eb78896e1eae /testing/firefox
parent4c1f42a5423b37d9c20f41c056bb72e883a18bef (diff)
testing/firefox: allow set utf-8 as fallback
We want let user be able to set utf-8 as fallback so text/plain works properly.
Diffstat (limited to 'testing/firefox')
-rw-r--r--testing/firefox/APKBUILD6
-rw-r--r--testing/firefox/allow-utf8-fallback.patch16
2 files changed, 21 insertions, 1 deletions
diff --git a/testing/firefox/APKBUILD b/testing/firefox/APKBUILD
index d9a5b063fdc..ece6fd23856 100644
--- a/testing/firefox/APKBUILD
+++ b/testing/firefox/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox
pkgver=40.0.3
_pkgver=$pkgver
_xulver=$pkgver
-pkgrel=1
+pkgrel=2
pkgdesc="Firefox web browser"
url="http://www.firefox.com"
arch="all"
@@ -67,6 +67,7 @@ source="https://ftp.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkg
rhbz-966424.patch
fix-fortify-inline.patch
fix-fortify-system-wrappers.patch
+ allow-utf8-fallback.patch
firefox.desktop
firefox-safe.desktop"
@@ -180,6 +181,7 @@ d9a2245b93a7f5855ee029b5fa44e4e9 stat.patch
15ebeeeb6823c185f4fed98e9bf1b786 rhbz-966424.patch
f29e0036edc7b3a4158a82fa97bde500 fix-fortify-inline.patch
9aba3811121f113fe547947591802d2b fix-fortify-system-wrappers.patch
+1feef5ea2fd5acc2a71a29350754d006 allow-utf8-fallback.patch
ba96924ece1d77453e462429037a2ce5 firefox.desktop
6f38a5899034b7786cb1f75ad42032b8 firefox-safe.desktop"
sha256sums="56ab32bfa070a1d86d356ad14ce74252b38dab9307948de8e4a3a2b7f3f22634 firefox-40.0.3.source.tar.bz2
@@ -197,6 +199,7 @@ a0f8a0fa9977ee43f3853b6c6bf5a506fdfabdfa32b4279e0ac3d7a3078f34cc stat.patch
a50d15a640f230a2c66e1eb2afd2bed4117605d0f1591dcfec1ca30f0bc2352f rhbz-966424.patch
ecf808ef1bc2920f6f7a4786fafb46c74e8a2c3bc628f28f10d6e8e1a265e609 fix-fortify-inline.patch
cd19195cb4c316ad9f7d377cd8581218c888863b1bc4d112c97f48a4425fb946 fix-fortify-system-wrappers.patch
+a1ba79ec0c50c19edcfb24bb2686a718a77b02035e412989b9208b9b818abe14 allow-utf8-fallback.patch
b571c4a49884a3c98806246c9cc3e60c73d5a8f4aeb7f96217db0be1d6210eda firefox.desktop
4b6de45753856a890f4482055666e77f9b01bdfb7e0df08bafaa3a4d9937eed3 firefox-safe.desktop"
sha512sums="8f0f3f3a38378b4a5c30e2a41888564f9eed3e8ec3571654849afbd8e8b46532777e15e148eb4820d14647b51adadf86ed77d80b359ebb289431ea31abfc5748 firefox-40.0.3.source.tar.bz2
@@ -214,5 +217,6 @@ e61664bc93eadce5016a06a4d0684b34a05074f1815e88ef2613380d7b369c6fd305fb34f83b5eb1
06ededcd196af98b77991dcba3b710b0dfc061404adb4676fcc380be80410a2621f64d67257b0aefdf36f566e0ea1294b5405b7b4db43e83281a1c64d02da579 rhbz-966424.patch
09bc32cf9ee81b9cc6bb58ddbc66e6cc5c344badff8de3435cde5848e5a451e0172153231db85c2385ff05b5d9c20760cb18e4138dfc99060a9e960de2befbd5 fix-fortify-inline.patch
2a967e4619fd89a046bd40be7fdcef646fcb1eba5e47afc96aa1d59c25bcc8747cb07baee6c11f3b803db0981aced181534b806778e4d21e74958f5f4d74c784 fix-fortify-system-wrappers.patch
+ebbc2b1336197c289e9b7c073d196fb5734e1dad0109fe70538f8089b1873e4b55305cd39cefcf95cd4eb36715be6dff298856c496616e935ff5579452e62b09 allow-utf8-fallback.patch
f3b7c3e804ce04731012a46cb9e9a6b0769e3772aef9c0a4a8c7520b030fdf6cd703d5e9ff49275f14b7d738fe82a0a4fde3bc3219dff7225d5db0e274987454 firefox.desktop
5dcb6288d0444a8a471d669bbaf61cdb1433663eff38b72ee5e980843f5fc07d0d60c91627a2c1159215d0ad77ae3f115dcc5fdfe87e64ca704b641aceaa44ed firefox-safe.desktop"
diff --git a/testing/firefox/allow-utf8-fallback.patch b/testing/firefox/allow-utf8-fallback.patch
new file mode 100644
index 00000000000..d283d60422e
--- /dev/null
+++ b/testing/firefox/allow-utf8-fallback.patch
@@ -0,0 +1,16 @@
+Allow user to actually set UTF-8 as the fallback charset.
+
+This is to allow UTF-8 as default for text/plain
+
+--- ./dom/encoding/FallbackEncoding.cpp.orig
++++ ./dom/encoding/FallbackEncoding.cpp
+@@ -55,8 +55,7 @@
+ // Don't let the user break things by setting the override to unreasonable
+ // values via about:config
+ if (!EncodingUtils::FindEncodingForLabel(override, mFallback) ||
+- !EncodingUtils::IsAsciiCompatible(mFallback) ||
+- mFallback.EqualsLiteral("UTF-8")) {
++ !EncodingUtils::IsAsciiCompatible(mFallback)) {
+ mFallback.Truncate();
+ }
+