aboutsummaryrefslogtreecommitdiffstats
path: root/testing/flatbuffers/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-07-25 11:01:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-25 11:01:33 +0000
commitda5483e02267a10923d4c7b26b352a7056b0256a (patch)
treeb3e9f123fe7c907ab44094acfa8275ce81c2bac9 /testing/flatbuffers/APKBUILD
parent85eace3f4e374668bac0c9a2a26342acb16161bd (diff)
testing/flatbuffers: new aport
Memory Efficient Serialization Library http://google.github.io/flatbuffers/
Diffstat (limited to 'testing/flatbuffers/APKBUILD')
-rw-r--r--testing/flatbuffers/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/flatbuffers/APKBUILD b/testing/flatbuffers/APKBUILD
new file mode 100644
index 00000000000..31a70f4cbc4
--- /dev/null
+++ b/testing/flatbuffers/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=flatbuffers
+pkgver=1.7.1
+pkgrel=0
+pkgdesc="Memory Efficient Serialization Library"
+url="http://google.github.io/flatbuffers/"
+arch="all"
+license="Apache-2.0"
+depends=""
+depends_dev=""
+makedepends="$depends_dev cmake"
+install=""
+subpackages="$pkgname-dev"
+source="flatbuffers-$pkgver.tar.gz::https://github.com/google/flatbuffers/archive/v$pkgver.tar.gz"
+builddir="$srcdir/flatbuffers-$pkgver"
+
+build() {
+ mkdir -p "$builddir"/build
+ cd "$builddir"/build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DFLATBUFFERS_BUILD_SHAREDLIB=on
+ make
+}
+
+package() {
+ cd "$builddir"/build
+ make install DESTDIR="$pkgdir"
+}
+
+sha512sums="57732fc352c216c4be6d3237f93b872abf9dd2b62361d7d2856f99804a178760e4665ead2e33d5acdd00984ad03a746f581c9784ece583e1b2df1a10776f967a flatbuffers-1.7.1.tar.gz"