summaryrefslogtreecommitdiffstats
path: root/testing/fuse/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-20 15:51:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-20 15:53:25 +0000
commit7a0b6bcc0bc61677944d7ab3f8e635347fd32353 (patch)
treefe30af7d9fffc65291d2cc84832315e8cd50f94d /testing/fuse/APKBUILD
parent8ead7a5dd2a21b3c51cab6f740c6f63c9fe31896 (diff)
testing/fuse: new aport
A library that makes it possible to implement a filesystem in a userspace program. http://fuse.sourceforge.net/ Needed by sshfs (ref #210) and open-vm-tools (ref #193)
Diffstat (limited to 'testing/fuse/APKBUILD')
-rw-r--r--testing/fuse/APKBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/testing/fuse/APKBUILD b/testing/fuse/APKBUILD
new file mode 100644
index 00000000000..5ce32a06bae
--- /dev/null
+++ b/testing/fuse/APKBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=fuse
+pkgver=2.8.1
+pkgrel=0
+pkgdesc="A library that makes it possible to implement a filesystem in a userspace program."
+url="http://fuse.sourceforge.net/"
+license="GPL2"
+depends=
+makedepends="pkgconfig libiconv-dev
+ autoconf automake libtool"
+install=
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ fuse-iconv.patch
+ fuse.initd"
+
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ patch -p1 -i "$srcdir"/fuse-iconv.patch || return 1
+ aclocal -I m4 && libtoolize && autoconf && automake
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --enable-lib \
+ --enable-util \
+ --bindir=/bin \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ rm -rf "$pkgdir"/dev
+ rm -rf "$pkgdir"/etc/init.d
+
+ install -Dm755 "$srcdir"/fuse.initd "$pkgdir"/etc/init.d/fuse
+ # create config
+ install -d "$pkgdir"/etc
+ cat >"$pkgdir"/etc/fuse.conf << _EOF_
+# Set the maximum number of FUSE mounts allowed to non-root users.
+# The default is 1000.
+#
+#mount_max = 1000
+
+# Allow non-root users to specify the 'allow_other' or 'allow_root'
+# mount options.
+#
+#user_allow_other
+_EOF_
+
+}
+
+md5sums="0e3505ce90155983f1bc995eb2cf6fa7 fuse-2.8.1.tar.gz
+e5183506aabc5bf7795da52953d38888 fuse-iconv.patch
+5983726cfabf0830dffbbbf9a3abcddc fuse.initd"