aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fwup/APKBUILD
diff options
context:
space:
mode:
authorFrank Hunleth <fhunleth@troodon-software.com>2018-07-15 23:03:19 -0400
committerFrank Hunleth <fhunleth@troodon-software.com>2018-07-16 10:30:38 -0400
commit21b63c09c64141294820e287e66a47d8f06a2c3f (patch)
treec56b40ecd5d052218debb131e028346fb8229c14 /testing/fwup/APKBUILD
parent8aa6a1c14470c68ddddb11f63c0289611016af11 (diff)
testing/fwup: new aport
https://github.com/fhunleth/fwup Configurable embedded Linux firmware update creator and runner
Diffstat (limited to 'testing/fwup/APKBUILD')
-rw-r--r--testing/fwup/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/fwup/APKBUILD b/testing/fwup/APKBUILD
new file mode 100644
index 00000000000..fab2594f77b
--- /dev/null
+++ b/testing/fwup/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Frank Hunleth <fhunleth@troodon-software.com>
+# Maintainer: Frank Hunleth <fhunleth@troodon-software.com>
+pkgname=fwup
+pkgver=1.2.3
+pkgrel=0
+pkgdesc="Configurable embedded Linux firmware update creator and runner"
+url="https://github.com/fhunleth/fwup"
+arch="all"
+license="Apache-2.0"
+makedepends="linux-headers confuse-dev libarchive-dev libsodium-dev help2man dosfstools mtools zip unzip"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/fhunleth/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b48cb3569731b17c25e5df3125090e44d7be0f01b8c5e07f639aa8cd3ab495c2ebfd93c8da95086e57a7d88fbf75a30055ed25b189610b3dffaabcbaf47c6d49 fwup-1.2.3.tar.gz"