aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gdal/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-10-03 12:45:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-10-03 12:45:34 +0000
commit777389bca1f3041ce2b2ff91f309ce4f7ac0d0a3 (patch)
treed2dfec1a078dd397016acdbccf5b65f493e52785 /testing/gdal/APKBUILD
parent1f90370c9032e77a9a08a71a72aae84d5fc868cd (diff)
testing/gdal: modernize, make build fail if curl is missing
dont rely on autodetection and make it fail if curl is missing for some reason.
Diffstat (limited to 'testing/gdal/APKBUILD')
-rw-r--r--testing/gdal/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/testing/gdal/APKBUILD b/testing/gdal/APKBUILD
index 037dcde9fc3..b8a4c7ad927 100644
--- a/testing/gdal/APKBUILD
+++ b/testing/gdal/APKBUILD
@@ -17,8 +17,9 @@ builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- ./configure --prefix=/usr || return 1
- make || return 1
+ ./configure --prefix=/usr \
+ --with-curl=/usr/bin/curl-config
+ make
cd swig/python
python2 setup.py build
@@ -27,7 +28,7 @@ build() {
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
chmod -x "$pkgdir"/usr/include/*.h
}
@@ -35,7 +36,7 @@ py() {
pkgdesc="$pkgname (python bindings)"
cd "$builddir"/swig/python
- python2 setup.py install --prefix=/usr --root="$subpkgdir" || return 1
+ python2 setup.py install --prefix=/usr --root="$subpkgdir"
chmod a+x scripts/*
install -d "$subpkgdir"/usr/bin