aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gdal/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-23 02:24:33 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-24 08:21:52 -0300
commit99982b7dde8f6e09281daa6cf30a3594ca421936 (patch)
treeeb116c681e2d838987f9b527bdd01976f03963fb /testing/gdal/APKBUILD
parent5770eccc2171bb0831d4f0efb0d84a896061f84c (diff)
testing/gdal: use python3
Diffstat (limited to 'testing/gdal/APKBUILD')
-rw-r--r--testing/gdal/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/testing/gdal/APKBUILD b/testing/gdal/APKBUILD
index 8aa65dd6897..ad1fb9c986f 100644
--- a/testing/gdal/APKBUILD
+++ b/testing/gdal/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Trevor R.H. Clarke <trevor@notcows.com>
pkgname=gdal
pkgver=2.4.0
-pkgrel=3
+pkgrel=4
pkgdesc="A translator library for raster and vector geospatial data formats"
url="https://gdal.org"
arch="all"
@@ -17,7 +17,7 @@ makedepends="
libpng-dev
linux-headers
postgresql-dev
- python2-dev
+ python3-dev
sqlite-dev
swig
tiff-dev
@@ -26,10 +26,10 @@ makedepends="
"
subpackages="
$pkgname-dev
- py-$pkgname:py
+ py3-$pkgname:py3
"
-source="http://download.osgeo.org/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"
+source="http://download.osgeo.org/gdal/$pkgver/gdal-$pkgver.tar.xz"
build() {
./configure --prefix=/usr \
@@ -37,7 +37,7 @@ build() {
make
cd swig/python
- python2 setup.py build
+ python3 setup.py build
}
package() {
@@ -45,11 +45,14 @@ package() {
chmod -x "$pkgdir"/usr/include/*.h
}
-py() {
- pkgdesc="$pkgname (python bindings)"
+py3() {
+ pkgdesc="$pkgname (python3 bindings)"
+
+ replaces="py-$pkgname" # Backwards compatibility
+ provides="py-$pkgname=$pkgver-r$pkgrel" # Backwards compatibility
cd "$builddir"/swig/python
- python2 setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$subpkgdir"
chmod a+x scripts/*
install -d "$subpkgdir"/usr/bin