aboutsummaryrefslogtreecommitdiffstats
path: root/testing/getmail
diff options
context:
space:
mode:
authorDubiousjim <dubiousjim@gmail.com>2013-06-27 02:12:25 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2013-06-28 06:58:42 +0000
commit610c091b16b80014fff7b5bde9d61e642d4789ee (patch)
tree67a23a6695598c0588c4c3dac2488045bd434731 /testing/getmail
parentd961fcd5c084df518ee1d8287f252c76aea7543f (diff)
testing/getmail: fix some old shebang lines
To be honest, I think these are irrelevant to the functioning of the program, since the files in question are imported by the offlineimap app, rather than being run as scripts. (Not sure why the shebang lines are there at all...cruft?)
Diffstat (limited to 'testing/getmail')
-rw-r--r--testing/getmail/APKBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/testing/getmail/APKBUILD b/testing/getmail/APKBUILD
index b5dc7639ed5..013c8630d60 100644
--- a/testing/getmail/APKBUILD
+++ b/testing/getmail/APKBUILD
@@ -33,6 +33,8 @@ build() {
package() {
cd "$_builddir"
python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ # fix some broken shebang calls
+ sed -i -e "s|#![ ]*/usr/bin/env python2\.3|#!/usr/bin/env python|" $(find $pkgdir -name '*.py')
}
md5sums="1ca7e1bc034cf5578e8ceb251668962a getmail-4.39.0.tar.gz"