aboutsummaryrefslogtreecommitdiffstats
path: root/testing/git-flow/APKBUILD
diff options
context:
space:
mode:
authorSimon Frankenberger <simon@fraho.eu>2020-04-02 12:20:46 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-03 07:58:57 +0000
commit74e6e7544e0f8ded30b700ddf560945c1fd54a29 (patch)
tree748a430de8ffe2d8be3750b9cce9543c4b662be2 /testing/git-flow/APKBUILD
parentaeaacb0142db14520618c92144af85224dd306cf (diff)
testing/git-flow: new aport
Diffstat (limited to 'testing/git-flow/APKBUILD')
-rw-r--r--testing/git-flow/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/git-flow/APKBUILD b/testing/git-flow/APKBUILD
new file mode 100644
index 00000000000..547870f3483
--- /dev/null
+++ b/testing/git-flow/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Simon Frankenberger <simon-alpine@fraho.eu>
+# Maintainer: Simon Frankenberger <simon-alpine@fraho.eu>
+pkgname=git-flow
+pkgver=1.12.3
+pkgrel=0
+pkgdesc="Git extension to provide a high-level branching model"
+url="https://github.com/petervanderdoes/gitflow-avh"
+arch="noarch"
+license="LGPL-2.1-or-later"
+depends="git"
+options="!check" # has no tests
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/petervanderdoes/gitflow-avh/archive/$pkgver.tar.gz
+ add-destdir-support.patch
+ fix-busybox-readlink.patch"
+builddir="$srcdir/gitflow-avh-$pkgver"
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="807cd36de7f5c9b4a7b28101de5ea8cfcbf528ff76578e4914c788b8098c7d3d91f8c19a3274e124ee7f7b4bdb6efdc5de2b74e09f374b71ae685beaa86e3e5a git-flow-1.12.3.tar.gz
+8206b38f5ed843519b33ebcdcc125c6dc6d6e9b6726919a1ec7becb52f22db125a3e58e3724ea95a4cf926cad8bb8cda5c163498d2de7ebb489d5b6985dc3cec add-destdir-support.patch
+c82b619470f3ecf14809e8ae742607b426de044e4a454f423563faba995b07f36bcf99ce8081dbc2a4f9342f23922b4df5d04993b93e10671e33af1d92b01076 fix-busybox-readlink.patch"