aboutsummaryrefslogtreecommitdiffstats
path: root/testing/git-secret
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-09-06 01:28:48 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-09-06 01:29:54 +0200
commitf85d009eec06b341766ae98e05b284a7e0c00287 (patch)
treec0d4c9146776c7e900c7e0d978f18cee89403ebc /testing/git-secret
parent57a51123a91675b55ce9fac8a1a9fe0822e244c8 (diff)
testing/git-secret: new aport
http://git-secret.io/ A bash-tool to store your private data inside a git repository
Diffstat (limited to 'testing/git-secret')
-rw-r--r--testing/git-secret/APKBUILD34
-rw-r--r--testing/git-secret/makefile.patch15
2 files changed, 49 insertions, 0 deletions
diff --git a/testing/git-secret/APKBUILD b/testing/git-secret/APKBUILD
new file mode 100644
index 00000000000..cb86144007d
--- /dev/null
+++ b/testing/git-secret/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=git-secret
+pkgver=0.2.2
+pkgrel=0
+pkgdesc="A bash-tool to store your private data inside a git repository"
+url="http://git-secret.io/"
+arch="noarch"
+license="MIT"
+depends="bash gnupg"
+checkdepends="bats"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sobolevn/$pkgname/archive/v$pkgver.tar.gz
+ makefile.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check" # does not work in a container w/o tty
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX="$pkgdir/usr" install
+}
+
+sha512sums="453b9012fd90e962ec47af598b43f1036b7e741d9f46053ff16a469c08c1da33f99c8e792119664c82dd63d24b8cf72736e445a454c7b7f59c0387e886ee5fde git-secret-0.2.2.tar.gz
+5e91d0830e95a8be0eb1f87b482a1d9216ff86be354d52c5f0f5cf5b7c4bba6833f09097ea83349178314d63c373683f1782315b862eb4fc728dc17c91ba9bad makefile.patch"
diff --git a/testing/git-secret/makefile.patch b/testing/git-secret/makefile.patch
new file mode 100644
index 00000000000..a864c95841a
--- /dev/null
+++ b/testing/git-secret/makefile.patch
@@ -0,0 +1,15 @@
+--- a/Makefile
++++ b/Makefile
+@@ -39,10 +39,10 @@
+ git clone https://github.com/sstephenson/bats.git vendor/bats; fi
+
+ .PHONY: test
+-test: install-test clean build
++test: build
+ @chmod +x "./utils/tests.sh"; sync; \
+ export SECRET_PROJECT_ROOT="${PWD}"; \
+- export PATH="${PWD}/vendor/bats/bin:${PWD}:${PATH}"; \
++ export PATH="${PWD}:${PATH}"; \
+ "./utils/tests.sh"
+
+ #