aboutsummaryrefslogtreecommitdiffstats
path: root/testing/glfw/APKBUILD
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2016-08-19 11:58:38 -0400
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-21 23:44:54 +0200
commit821b10ac29579cf4e9ac37f0c230ee23632f15b9 (patch)
tree1852c63600aaae6feb980bdf996a3496c6d85dd4 /testing/glfw/APKBUILD
parentb17b576bca999ceab57fe0f89db437d34c896c49 (diff)
testing/glfw: new aport
http://www.glfw.org/ Multi-platform library for OpenGL and Vulkan application development
Diffstat (limited to 'testing/glfw/APKBUILD')
-rw-r--r--testing/glfw/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/glfw/APKBUILD b/testing/glfw/APKBUILD
new file mode 100644
index 00000000000..5ec631e3049
--- /dev/null
+++ b/testing/glfw/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
+# Maintainer:
+pkgname=glfw
+pkgver=3.2
+pkgrel=0
+pkgdesc="Multi-platform library for OpenGL and Vulkan application development"
+url="http://www.glfw.org/"
+arch="all"
+license="zlib"
+depends=""
+depends_dev="libxinerama-dev linux-headers mesa-dev"
+makedepends="$depends_dev cmake libx11-dev libxcursor-dev libxrandr-dev"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/glfw/$pkgname/archive/$pkgver.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ cmake . \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=ON \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir/" install || return 1
+}
+
+md5sums="a4a7248d771717a84c8997b7b712cd57 glfw-3.2.tar.gz"
+sha256sums="cb3aab46757981a39ae108e5207a1ecc4378e68949433a2b040ce2e17d8f6aa6 glfw-3.2.tar.gz"
+sha512sums="55982cba8b6605fe5489f7396fb5101f3eedd121d13a51ab8178e4bd2c8b348a8b7869fcd00dbefe5725b5c04942318c2a99f13832da4bfa74db42ab2812f3a2 glfw-3.2.tar.gz"