aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gn
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-02-23 09:48:48 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-02-23 09:48:59 +0000
commitd250b76db74126ed24ea82086b59e4dea5679907 (patch)
treeab985d437dbe7fc843bf7f48ddf0806ca8b8d4ae /testing/gn
parent621dfaeba4ab79cc84cd9109fe13c263d811cba4 (diff)
testing/gn: run provided test suite
Diffstat (limited to 'testing/gn')
-rw-r--r--testing/gn/APKBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/testing/gn/APKBUILD b/testing/gn/APKBUILD
index 66eeea7d8b4..3dcf40af24a 100644
--- a/testing/gn/APKBUILD
+++ b/testing/gn/APKBUILD
@@ -21,6 +21,12 @@ prepare() {
"$builddir/git/build/gen.py"
}
+check() {
+ cd "$builddir/git/out/"
+
+ ./gn_unittests
+}
+
build() {
cd "$builddir/git"
ninja -C out -j 8