aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gnome-bluetooth/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-06 19:33:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-06 19:34:43 +0000
commitae1d45935e92e8b2ea7880c5b38915c5e01be5b0 (patch)
tree3d91e45cc9cadae69c55f9be9e5ede58fc18d061 /testing/gnome-bluetooth/APKBUILD
parent16fa086e0b4b5e5502d6ef8057d9e9c7165c6387 (diff)
testing/gnome-bluetooth: new aport
The GNOME Bluetooth Subsystem http://live.gnome.org/GnomeBluetooth
Diffstat (limited to 'testing/gnome-bluetooth/APKBUILD')
-rw-r--r--testing/gnome-bluetooth/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/testing/gnome-bluetooth/APKBUILD b/testing/gnome-bluetooth/APKBUILD
new file mode 100644
index 00000000000..c72d44588f9
--- /dev/null
+++ b/testing/gnome-bluetooth/APKBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnome-bluetooth
+pkgver=2.32.0
+pkgrel=0
+pkgdesc="The GNOME Bluetooth Subsystem"
+url="http://live.gnome.org/GnomeBluetooth"
+license="GPL LGPL"
+depends="hicolor-icon-theme obexd"
+makedepends="intltool py-gtk gobject-introspection libunique-dev libnotify-dev
+ libxi-dev libxslt py-libxml2"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.gnome.org/pub/GNOME/sources/gnome-bluetooth/${pkgver%.*}/gnome-bluetooth-$pkgver.tar.bz2
+ nogeoclue.patch
+ 61-gnome-bluetooth-rfkill.rules"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-desktop-update \
+ --disable-icon-update \
+ --disable-nautilus-sendto \
+ --disable-schemas-compile \
+ --disable-introspection \
+ --disable-scrollkeeper \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -m644 -D "$srcdir/61-gnome-bluetooth-rfkill.rules" \
+ "$pkgdir/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules"
+}
+
+md5sums="f129686fe46c4c98eb70a0cc85d59cae gnome-bluetooth-2.32.0.tar.bz2
+5ed6f59d02b45573a08155fca8f0d300 nogeoclue.patch
+9fb6c8dcb5a3de3a953bf2ef42063e6e 61-gnome-bluetooth-rfkill.rules"