aboutsummaryrefslogtreecommitdiffstats
path: root/testing/go-uuid/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-01-03 15:19:51 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-01-03 15:22:00 +0000
commit44247556387d5ebb63df3c8df64fc4598306b41c (patch)
treebc3cef942e22c22ad5ee51bed2b37203a88d76c1 /testing/go-uuid/APKBUILD
parent7897914f4b1d734c6e7eb93c789adfb583c4e975 (diff)
testing/go-uuid: new aport
UUID package for Go
Diffstat (limited to 'testing/go-uuid/APKBUILD')
-rw-r--r--testing/go-uuid/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/go-uuid/APKBUILD b/testing/go-uuid/APKBUILD
new file mode 100644
index 00000000000..a3929816986
--- /dev/null
+++ b/testing/go-uuid/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=go-uuid
+_realname=go.uuid
+pkgver=1.1.0
+pkgrel=0
+pkgdesc=" UUID package for Go"
+url="https://github.com/satori/$_realname"
+arch="noarch"
+license="Custom"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=
+subpackages="$pkgname-doc"
+_vendor="satori"
+source="$pkgname-$pkgver.tar.gz::https://github.com/$_vendor/$_realname/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/$_realname-$pkgver
+
+prepare() {
+ cd "$builddir"
+}
+
+build() {
+ cd "$builddir"
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/share/doc/$_vendor/$pkgname \
+ "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname
+ for file in \
+ LICENSE \
+ README.md \
+ COPYRIGHT \
+ AUTHORS \
+ ; do \
+ test -e $file && mv $file "$pkgdir"/usr/share/doc/$_vendor/$pkgname
+ done
+ mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname || return 1
+}
+
+md5sums="d0cd15432cf30fae3d6594f3f0839171 go-uuid-1.1.0.tar.gz"
+sha256sums="a9509d7769794df7d26964d5dc297c8ad7349f8ff5585f294e8fddd1c6abe946 go-uuid-1.1.0.tar.gz"
+sha512sums="2da3454ddd147d9e18c7405cdd95271c6d56aaac3085e0e9bc50106d224a28e3bd693bf1eb7e6109a0839a738cd068dddf3caa749e1bdf027627a65f3b747e1d go-uuid-1.1.0.tar.gz"