aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gopass
diff options
context:
space:
mode:
authorClaas Störtenbecker <claas.stoertenbecker@gmail.com>2019-03-17 00:45:18 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-17 19:04:32 +0000
commit57747e158192e9cfa055f4a6dc9b9b218327d52c (patch)
tree320db84f85476922cb119c5891f04ea0400c0185 /testing/gopass
parent50e8fc6853dce179acf5c6379d0acdd4ddffa2dc (diff)
testing/gopass: new aport
https://www.gopass.pw The slightly more awesome Standard Unix Password Manager for Teams. Written in Go.
Diffstat (limited to 'testing/gopass')
-rw-r--r--testing/gopass/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/gopass/APKBUILD b/testing/gopass/APKBUILD
new file mode 100644
index 00000000000..f68aa7c3823
--- /dev/null
+++ b/testing/gopass/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Claas Störtenbecker <claas.stoertenbecker@gmail.com>
+# Maintainer: Claas Störtenbecker <claas.stoertenbecker@gmail.com>
+pkgname=gopass
+pkgver=1.8.5
+pkgrel=0
+pkgdesc="The slightly more awesome Standard Unix Password Manager for Teams. Written in Go."
+url="https://www.gopass.pw"
+arch="x86_64"
+license="MIT"
+depends="gnupg git"
+makedepends="go ncurses"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/gopasspw/gopass/archive/v$pkgver.tar.gz"
+builddir="$srcdir/src/github.com/gopasspw/$pkgname"
+# test suite exists but fails for reasons i don't know yet, will talk with gopass developer
+options="!check"
+
+prepare() {
+ mkdir -p "$srcdir/src/github.com/gopasspw"
+ mv "$srcdir/$pkgname-$pkgver" "$srcdir/src/github.com/gopasspw/gopass"
+}
+
+build() {
+ export GOPATH="$srcdir"
+ cd "$builddir"
+ make build
+}
+
+#check() {}
+
+package() {
+ install -Dm755 "$builddir/$pkgname" -t "$pkgdir/usr/bin"
+}
+sha512sums="1f451b10aa87141de635650489bf7227c252e10e5139dad274c95d5625db74fec0b8892a468800d3d3c5dd8b3d64f1c93bd6c75a0ba54fe5f6e630c77b2c6c71 gopass-1.8.5.tar.gz"