aboutsummaryrefslogtreecommitdiffstats
path: root/testing/graphviz/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-07-28 08:48:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-07-28 08:48:34 +0000
commit707686fb92ef0923042409d385e760dfb67facd6 (patch)
tree0612bfa6182f4ffe189d1c2f1e1357a85eda100c /testing/graphviz/APKBUILD
parent7057b6f8cdda1f7acde5edcac7c97afaaad0a8b3 (diff)
testing/graphviz: workaround sincos issue for x86_64
Diffstat (limited to 'testing/graphviz/APKBUILD')
-rw-r--r--testing/graphviz/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/testing/graphviz/APKBUILD b/testing/graphviz/APKBUILD
index 78ba6b1974e..7df365b0ed5 100644
--- a/testing/graphviz/APKBUILD
+++ b/testing/graphviz/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.28.0
pkgrel=0
pkgdesc="Graph Visualization Tools"
url="http://www.graphviz.org/"
-arch="x86"
+arch="all"
license="EPL"
depends=""
depends_dev="zlib-dev libpng-dev jpeg-dev expat-dev freetype-dev bison m4 flex
@@ -44,6 +44,10 @@ build() {
--with-png \
--with-jpeg \
|| return 1
+ if [ "$CARCH" = "x86_64" ]; then
+ # the configure script thinks we have sincos. we dont.
+ sed -i -e '/HAVE_SINCOS/d' config.h || return 1
+ fi
make || return 1
}